These are chat archives for ushahidi/Community

24th
Jun 2015
Ushbot
@ushbot
Jun 24 2015 03:41
[Jess Shorland, Ushahidi] today: ruined robbie's life a little bit more, pricing tiers with @charlie and @nat (https://docs.google.com/spreadsheets/d/1vLODgIBSc5rkM0tGjVekYlAsyzqG-CD863gEytECOKs/edit#gid=0), broke my churn table in the v3 model (damn), started backend cloud planning
Ushbot
@ushbot
Jun 24 2015 04:30
[Robbie Mackay, Ushahidi] @jess we still need to do this board report..
[Jess Shorland, Ushahidi] coming
[Robbie Mackay, Ushahidi] its cold out here.. I might just come inside
[Jess Shorland, Ushahidi] ok
[Robbie Mackay, Ushahidi] Made a little progress on the CSV import but not enough..
[Jess Shorland, Ushahidi] food in, code out
hollycorbett
@hollycorbett
Jun 24 2015 18:25
maybe I missed something, but do we expect the backend to be totally b0rked at the moment?
I keep getting empty responses.. have tried all the usual restart/update tricks
Ushbot
@ushbot
Jun 24 2015 18:26
[Robbie Mackay, Ushahidi] hrm. nope
hollycorbett
@hollycorbett
Jun 24 2015 18:26
hrm
kay
restart laptop
(for lack of more intelligent intervention)
Ushbot
@ushbot
Jun 24 2015 18:27
[Robbie Mackay, Ushahidi] run migrations?
[Robbie Mackay, Ushahidi] checked logs?
hollycorbett
@hollycorbett
Jun 24 2015 18:27
yup yup
though haven’t checked logs on the vagrant server itself
though no errors came up during startup
Ushbot
@ushbot
Jun 24 2015 18:34
[Robbie Mackay, Ushahidi] hrm. major errors might only end up in the server logs
hollycorbett
@hollycorbett
Jun 24 2015 19:02
hrmpf… backend fine.. its the communication between them that is somehow all messed up.. despite the fact I can access the backend from my browser directly
and nothing obvious in my system logs… restart it is :)
Ushbot
@ushbot
Jun 24 2015 19:53
[Robbie Mackay, Ushahidi] @hollycorbett any luck?
[Robbie Mackay, Ushahidi] Alright.. updates time..

[Robbie Mackay, Ushahidi] Yesterday:

    - Very little CSV code done
    - Many pricing discussions

Today:

    - Writing the CSV junk (I've filled my db with blank posts accidentally once already)
[Robbie Mackay, Ushahidi] .. and reviewing things..
[Will, Ushahidi] Today:
  • Moved sql query dramatically forward
  • Next:
    • finish filter of queries
    • implement sql query
hollycorbett
@hollycorbett
Jun 24 2015 20:04
DOH @rjmackay … it was the env config
after the modifications to the gulpfile
hollycorbett
@hollycorbett
Jun 24 2015 20:10
I only just noticed that all my failed requests are to http://ushahidi-backend/BLAH :D
Ushbot
@ushbot
Jun 24 2015 20:10
[Jess Shorland, Ushahidi] alright. Update from me: pricing tiers iteration 1 ready to send out in survey to get feedback on, Q2 board update done, working on landing page today and getting google partner data ready to import
Robbie Mackay
@rjmackay
Jun 24 2015 20:37
Ah sorry. I was meant to post a note about how to update to .env
sorry
hollycorbett
@hollycorbett
Jun 24 2015 20:37
hahaha all good :)
I think I’m still doing it wrong.. even once I’ve set it, I keep getting http://localhost/192.168.33.110/api/v2/etc
Robbie Mackay
@rjmackay
Jun 24 2015 20:40
you need http:// in your backend url :)
hollycorbett
@hollycorbett
Jun 24 2015 20:41
ah :D that I did not expect
Robbie Mackay
@rjmackay
Jun 24 2015 20:41
it was the same in gulp options
hollycorbett
@hollycorbett
Jun 24 2015 20:42
just testing the rewrite of 1498, and then that’ll be through to you too
Robbie Mackay
@rjmackay
Jun 24 2015 20:42
cool