These are chat archives for ushahidi/Community

14th
Aug 2015
Ushbot
@ushbot
Aug 14 2015 00:13
[Charlie Harding, Ushahidi] @Robbie does the OSS version have any sort of feature that sends us a basic overview of the deployment that is installed and its name / general info
[Charlie Harding, Ushahidi] would be nice to get aggregate info from OSS with opt-in at the very least
Francesco Bartoli
@francbartoli
Aug 14 2015 09:20
@aoduor yes this one ushahidi/platform#326
Ushbot
@ushbot
Aug 14 2015 14:03
[Angela Oduor Lungati, Ushahidi] DUDE!! Swahili translations is up from 10% to 86 % today!! (allthethings)
[Jess Shorland, Ushahidi] that's a serious win.
[Will, Ushahidi] wow, that's stupendous
[Sebastian Mitchell, Ushahidi] Declan has spent all day translating
[Sophie Shepherd, Ushahidi] wowza!!!
Ushbot
@ushbot
Aug 14 2015 14:15
[Michelle Hamilton-Page, Ushahidi] @Dex !!! (rockon)
[Declan Ottaro, Ushahidi] :)
[Declan Ottaro, Ushahidi] I'm surprised by how much I've enjoyed it
Ushbot
@ushbot
Aug 14 2015 14:51
[Jess Shorland, Ushahidi] @all Today I am 90% focused on turning feedback into prioritized dev tasks, and 10% focused on talking points for launch.
[Sophie Shepherd, Ushahidi] I need to build the contact page & refine the footer layout. And work with Seth to figure out how we can combine the CMS repo with the PL repo. SO close to done.
[Will, Ushahidi] Update:
Today,
-I'm inserting and loading the icon picker
-Attempting to get it to work with noun
-wiring it in so it can evaluated by others
[Brandon Rosage, Ushahidi] UPDATE: I'm back from travel and vacation this morning, and taking today to fully engage in the run to the Aug. 19 public (soft) launch. Building dotcom and polishing Platform configuration UI.
Ushbot
@ushbot
Aug 14 2015 15:04
[Jason Mule, Ushahidi] looking at #321 and noted that functionality for Mark As as well Export has not been implemented. Wondering if this should be prioritized as well?
Ushbot
@ushbot
Aug 14 2015 15:23
[Zack Halloran, Ushahidi] Continuing to look into setup issues on a clean trusty64 server.
Ushbot
@ushbot
Aug 14 2015 15:40
[Henry Addo, Ushahidi] Working on custom forms for Android
Ushbot
@ushbot
Aug 14 2015 16:34

[Zack Halloran, Ushahidi] @here I updated nodejs from 0.10.25 to 0.12.7 and got through npm install with a couple warnings. Gulp is throwing an error. Any thoughts?

module.js:338
throw err;
^
Error: Cannot find module 'core-util-is'
at Function.Module._resolveFilename (module.js:336:15)
at Function.Module._load (module.js:278:25)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Object.<anonymous> (/var/www/platform-client/node_modules/gulp/node_modules/gulp-util/node_modules/through2/node_modules/readable-stream/lib/_stream_duplex.js:26:12)
at Module._compile (module.js:460:26)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)

Ushbot
@ushbot
Aug 14 2015 16:47
[Seth Hall, Ushahidi] @ZackHalloran first try deleting the whole node modules folder then run npm install
[Zack Halloran, Ushahidi] This is on a clean server, no node_modules exist, but thanks.
[Seth Hall, Ushahidi] ok
[Seth Hall, Ushahidi] no folder was created when you ran npm install?
[Seth Hall, Ushahidi] or there wasn't one to begin with, since server is clean
Ushbot
@ushbot
Aug 14 2015 16:53
[Zack Halloran, Ushahidi] No folder on to begin with because it was clean. npm install completes with only warnings now that I've upgraded, but when I run gulp it throws that error. I'm investigating. By the time I'm done install from the master branch of platform-client should be automated.
[Zack Halloran, Ushahidi] ...for debian
Ushbot
@ushbot
Aug 14 2015 22:52
[Zack Halloran, Ushahidi] When npm install runs, it doesn't install of of gulp's recursive dependencies locally. When I manually install dependencies, gulp then throws a syntax error. This is gulp@3.9.0 running on ubuntu 14.04x64 with nodejs@0.12.7 and npm@2.11.3. Has anyone run into this?