These are chat archives for ushahidi/Community

19th
Nov 2015
Ushbot
@ushbot
Nov 19 2015 08:21
[kisiro] i need some help with installing ushahidi on a linux web server
[kisiro] can some one help me run this through?
[Jess Shorland, Ushahidi] hey @kisiroGuest -- it looks like our devs are offline right at this second (timezone issues ha). But someone should be on in a few hours that can help out if I can't. In the meantime, we've had some other questions about installation. Are you trying to install on Linux?
[Jess Shorland, Ushahidi] right, sorry -- you've already said that
[Jess Shorland, Ushahidi] at which point in the process are you experiencing trouble?
Ushbot
@ushbot
Nov 19 2015 08:30
[kisiro] well
[kisiro] i am using ssh to install oto the web server
[kisiro] so everything goes well till i get to the point in the instructions wher it says
[kisiro] installing the client
Ushbot
@ushbot
Nov 19 2015 08:39
[Jess Shorland, Ushahidi] ahhh ok -- we had another person have an issue with that. Do you get a message that says "sorry, something went wrong, try reloading the page?"
[kisiro] i should say i am new to this
[kisiro] i havent reached the point of loading it or running it
[kisiro] i am at the state of installing the client.. so no i havent seen that error message
[Jess Shorland, Ushahidi] No problem! Ok it seems like I'm not the best person to help you out, but I'll let our devs know to get in touch with you. You posted the question on our site as well, right?
Ushbot
@ushbot
Nov 19 2015 08:48
[kisiro] yes
[Jess Shorland, Ushahidi] great! I'll let the team know.
[kisiro] trhank you
Raghav Sharma
@RaghavPro
Nov 19 2015 13:48

@eyedol Hey. Been trying to get SMSSync to work but failing.
This is what my web service return

HTTP/1.0 401 UNAUTHORIZED
Content-Type: application/json
Content-Length: 99
Server: Werkzeug/0.10.4 Python/2.7.6
Date: Wed, 18 Nov 2015 10:26:04 GMT

{
  "payload": {
    "error": "Secret key didn't match for LOCALHOST.", 
    "success": false
  }
}

The messages just don't go to publish list.
I'm running the app on gingerbread.

Ushbot
@ushbot
Nov 19 2015 13:50
[RaghavFTW (guest), irc.freenode.net] hey, @eyedol are you there?
[eyedol (guest), irc.freenode.net] RaghavFTW: you should return success true
[eyedol (guest), irc.freenode.net] if the server receives the same secret key set on the phone
[eyedol (guest), irc.freenode.net] SMSsync needs it's to be true to acknowlege that it successfully sent the message to the server
[RaghavFTW (guest), irc.freenode.net] I thought if it isn't returning json then it thinks that the message didn't reach the server.
[eyedol (guest), irc.freenode.net] it should return json
[RaghavFTW (guest), irc.freenode.net] I read in documentation that it just needs to return JSON in the desired format for SMSSync to think it reacched the server.
Ushbot
@ushbot
Nov 19 2015 13:55
[eyedol (guest), irc.freenode.net] oops maybe the doc isn't clear there
[RaghavFTW (guest), irc.freenode.net] Been messing aroung this for 3 days :/
[eyedol (guest), irc.freenode.net] Yikes! :(
[RaghavFTW (guest), irc.freenode.net] Ok so, return success true and make error not = null if I want to show an error?
[eyedol (guest), irc.freenode.net] yup
[eyedol (guest), irc.freenode.net] if there is error make success false
[eyedol (guest), irc.freenode.net] and set an error message
[eyedol (guest), irc.freenode.net] say if the secret key doesn't match what's set on the server
Ushbot
@ushbot
Nov 19 2015 14:00
[RaghavFTW (guest), irc.freenode.net] ye, there was an error. secret key didn't match but it reached the server so shouldn't it be in published instead?
[eyedol (guest), irc.freenode.net] correct,
[eyedol (guest), irc.freenode.net] it reached the server
[eyedol (guest), irc.freenode.net] howerver the server didn't return the right response for SMSsync to know the server reached it
[eyedol (guest), irc.freenode.net] the assumption is once the server sends back success as false
[eyedol (guest), irc.freenode.net] it will consider it as failed message
[eyedol (guest), irc.freenode.net] BTW, I have a fix for #356 on github. Let me know if you want to test it. You can install the build I will send you
[RaghavFTW (guest), irc.freenode.net] Imo, it doesn't make sense. If server didn't returned JSON it should then consider it as failed message.
[eyedol (guest), irc.freenode.net] side by side with your current install of SMSsync so it shouldn't get in the way
[RaghavFTW (guest), irc.freenode.net] It's ok. I've switched to JSON as data format.
[RaghavFTW (guest), irc.freenode.net] And please update your documention. :P
[eyedol (guest), irc.freenode.net] heh will do so
Ushbot
@ushbot
Nov 19 2015 14:06
[RaghavFTW (guest), irc.freenode.net] What was the fix if I may ask. Have you pushed it?
[eyedol (guest), irc.freenode.net] ushahidi/SMSSync@e9d3a44
[eyedol (guest), irc.freenode.net] RaghavFTW: If you have the bandwidth you can build it to test it
[eyedol (guest), irc.freenode.net] Going to hit the sack.
[eyedol (guest), irc.freenode.net] If you still having issues, feel free to reach out, via here or github. I'll do the necessary follow tomorrow
[RaghavFTW (guest), irc.freenode.net] No, I don't have the resources to test. I'm not an android developer.
[RaghavFTW (guest), irc.freenode.net] Going to test with success true now. Will get back to you if it didn't work. Thanks.
[eyedol (guest), irc.freenode.net] No worries
[eyedol (guest), irc.freenode.net] Sounds good.
[eyedol (guest), irc.freenode.net] Keep me posted
Raghav Sharma
@RaghavPro
Nov 19 2015 14:27
@eyedol, nope still not working.
This is what I'm returning now:
HTTP/1.1 401 UNAUTHORIZED
Connection: keep-alive
Server: gunicorn/19.3.0
Date: Thu, 19 Nov 2015 14:20:18 GMT
Content-Type: application/json
Content-Length: 98
Via: 1.1 vegur

{
  "payload": {
    "error": "Secret key didn't match for LOCALHOST.", 
    "success": true
  }
}
Ushbot
@ushbot
Nov 19 2015 14:29
[RaghavFTW (guest), irc.freenode.net] :s
[Angela Oduor Lungati, Ushahidi] Announcing v3.1 release! Now you can stay on top of changes to your deployment in a single 'Activity' view.
https://www.ushahidi.com/blog/2015/11/19/stay-on-top-of-changes-and-trends-in-your-deployment-with-activity
[Angela Oduor Lungati, Ushahidi] Congrats team v3!!!!!!
Ushbot
@ushbot
Nov 19 2015 14:57
[RaghavFTW (guest), irc.freenode.net] eyedol: are you there?
[RaghavFTW (guest), irc.freenode.net] set success=true but still not going to publish list.
hollycorbett
@hollycorbett
Nov 19 2015 21:08
Hum so yeah I think there might actually be an issue on teh server side. I’m doing some SMSSync work and am having dramas with the secret key matching also
I’m getting this in the server logs whenever I hit-up the dataproviders:
2015-11-19 21:02:36 --- EMERGENCY: Aura\Di\Exception\ReflectionFailure [ 0 ]: League\Event\Emitter ~ /var/www/vendor/aura/di/src/Factory.php [ 393 ] in /var/www/vendor/aura/di/src/Factory.php:447
seems the class object is empty
an SMSSync POST request gets through to the backend fine… but loading the request details into $this->request->post('secret’) just aint happening as expected… (although the request details are there if you just spit out $this->request in the log)
hollycorbett
@hollycorbett
Nov 19 2015 21:15
these could be entirely separate issues, of course, and it could just be my JSON formatting is whack for my makeshift SMSSync tester (I’m not using the app - just POST-ing to the backend/smssync endpoint).. but either way, thats what I’m currently tinkering with. Any thoughts are appreciated but I’ll keep prodding at it.