These are chat archives for ushahidi/Community

4th
May 2016
Ushbot
@ushbot
May 04 2016 07:33
[Sizikov Alex, Ushahidi] Hi everyone)
I try to install via manual: https://www.ushahidi.com/support/install-ushahidi#installing-on-linux
and stoped on step: Install Build Requirements
npm install -g gulp
Install Packages
npm install
[Sizikov Alex, Ushahidi] when i do "npm install -g gulp" a have warnings:
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v6.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated lodash@1.0.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0.
[Sizikov Alex, Ushahidi] on next step "npm install" i have errors:
3183 error TypeError: Object.keys called on non-object
3183 error at Function.keys (native)
3183 error at installTargetsError (/usr/lib/node_modules/npm/lib/cache.js:708:24)
3183 error at /usr/lib/node_modules/npm/lib/cache.js:638:10
3183 error at saved (/usr/lib/node_modules/npm-registry-client/lib/get.js:148:7)
3183 error at /usr/lib/node_modules/graceful-fs/polyfills.js:133:7
3183 error at Object.oncomplete (fs.js:108:15)
3184 error If you need help, you may report this log at:
3184 error [http://github.com/isaacs/npm/issues](http://github.com/isaacs/npm/issues)
3184 error or email it to:
3184 error [npm-@googlegroups.com](npm-@googlegroups.com)
3185 error System Linux 3.10.0-229.20.1.el7.x86_64
3186 error command "node" "/usr/bin/npm" "install"
3187 error cwd /var/www/html/ushahidi/platform-client
3188 error node -v v0.10.42
3189 error npm -v 1.3.6
3190 error type called_on_non_object

[Link, Ushahidi]

npm/npm

npm - a package manager for javascript

[Sizikov Alex, Ushahidi] CentOS Linux release 7.1.1503 (Core)
Ushbot
@ushbot
May 04 2016 08:36
[Angela Oduor Lungati, Ushahidi] hey @SizikovAlexGuest thanks for reaching out. @Jason could you help :)?
Ushbot
@ushbot
May 04 2016 08:48
[Jason Mule, Ushahidi] Hi there, what version of node are you using?
Ushbot
@ushbot
May 04 2016 14:12
[Seth Hall, Ushahidi] @Robbie @Jason @Will I am scheduling a meeting to clarify a few things with my current priority. https://github.com/ushahidi/platform/issues/1046#event-649671843

[Link, Ushahidi]

ushahidi/platform#1046

Update top level markup to include mode bar mode context bar filter bar Probably excluding ‘how to add a post’ since this feature doesn't exist yet. Make any other general look and feel changes...

[Seth Hall, Ushahidi] would prefer to meet today when @Robbie logs on.
[Seth Hall, Ushahidi] @Jason Robbie's start of day is way late for you, so I will just set it up with @Robbie and @Will
[Jason Mule, Ushahidi] Cool. Thanks for letting me know.
[Will, Ushahidi] @Seth could we do tomorrow? We have to land a lot fo work today
[Seth Hall, Ushahidi] np
[Seth Hall, Ushahidi] yes, will set up for tomorrow.
[Will, Ushahidi] `cool
[Will, Ushahidi] thanks!
Ushbot
@ushbot
May 04 2016 19:51
[Janet Davis, Ushahidi] Hello all! Hi! I'm adding Janet Davis, who's a CS professor at Whitman College in Washington State. She's at this workshop learning about Ushahidi: http://foss2serve.org/index.php/POSSE. Angela invited me here from the Skype group, and Pat Tressel invited me there from IRC.

[Link, Ushahidi]

POSSE - Foss2Serve

POSSE began as an outreach effort by Red Hat, Inc. to the higher education community. The goal was to help instructors learn about free and open source software (FOSS) so that they could incorporate FOSS into their courses. A description of the first POSSE workshops is contained here

[Janet Davis, Ushahidi] Sorry for the ungrammatical utterance - I copied and pasted Pat's introduction from Skype and forgot to edit.
Ushbot
@ushbot
May 04 2016 20:10
[Robbie Mackay, Ushahidi] Hi Janet!
[Robbie Mackay, Ushahidi] I'm about to run for a train - but let us know if you have questions. I'll be back online soon anyway.
[Janet Davis, Ushahidi] Thanks, Robbie! I don't know what questions to ask yet, so I'm just hanging out if that's okay.
[Robbie Mackay, Ushahidi] always
Ushbot
@ushbot
May 04 2016 23:18
[Sizikov Alex, Ushahidi] @Jason npm-1.3.6-5.el7.noarch
[Robbie Mackay, Ushahidi] @SizikovAlexGuest thats the npm version. Can you copy to output of 'node --version' ?
[Sizikov Alex, Ushahidi] [root@linux-site platform-client]# node --version
v0.10.42
Ushbot
@ushbot
May 04 2016 23:34
[Robbie Mackay, Ushahidi] Odd - that should be working. I'll test 0.10 locally when I get a chance.