These are chat archives for ushahidi/Community

1st
Nov 2016
Stephanie Liu
@sanqianliusi
Nov 01 2016 02:17
hi,I am install ushahidi ,and now my page show this
Stephanie Liu
@sanqianliusi
Nov 01 2016 02:28
newerror.png
what should I do next ?
Kyoungrok Jang
@kyoungrok0517
Nov 01 2016 02:36
What should I do to show Twitter search results? I'm using v3.6.1 + heroku deployment, and properly set the twitter secrets in the settings. But nothing is different.
Liwei
@willis50317
Nov 01 2016 03:59
I'm now installing the client.
I got something wrong while running "sudo npm install".
How can I fix this?
Screenshot from 2016-11-01 11-53-40.png
Liwei
@willis50317
Nov 01 2016 06:31
Ok I already fixed that problem. Here is another one while running "gulp".
How can I fix this?
blob
Kyoungrok Jang
@kyoungrok0517
Nov 01 2016 07:33
Well... I'm stuck to make twitter come up in my timeline. I modified Twitter settings several times, but tweets never comes up.
I'm using AP v3 + Heroku
Ushbot
@ushbot
Nov 01 2016 09:11
[David Losada, Ushahidi] Nesp, that’s an error in the docs, fixing that now. Thanks for bringing it up!
[David Losada, Ushahidi] kyoungrok, it may be that the necessary scheduled tasks are not configured in the heroku build. Let me check that
Stephanie Liu
@sanqianliusi
Nov 01 2016 09:46
DocRoot2.png
how to make the vhost and point the docroot?
Screenshot from 2016-11-01 17:48:30.png
I have wrote this,point the DocumentRoot to /Platform/httpdocs
@ushbot
Stephanie Liu
@sanqianliusi
Nov 01 2016 09:52
I do not understand the docroot at the first picture ----from the guide page
Could you help me?
Ushbot
@ushbot
Nov 01 2016 09:54
[David Losada, Ushahidi] kyoungrok, you would need to add the scheduled jobs addon: https://elements.heroku.com/addons/scheduler and configure it to run ‘bin/ushahidi dataprovider incoming’ every 10 minutes

[David Losada, Ushahidi] sanqian, the document root is the default folder where apache will map the paths present in the browser request.

If your browser asks for http://yourwebsite.com/myfolder , and the docroot for yourwebsite.com is set up to be /var/www/mywebsite , then apache will look for /var/www/mywebsite/myfolder in order to serve the request

[David Losada, Ushahidi] willis, you would need to install nodejs in your system , I think we require at least version 5 now
[David Losada, Ushahidi] Arturo, what is the error you are getting after the update?
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:03
I should build two vhost to run ushahidi right?
because the docroot is asked in two place
DocumentRoot1.png
DocRoot2.png
Ushbot
@ushbot
Nov 01 2016 10:05
[David Losada, Ushahidi] yes, the project consists of two codebases, one is the backend API that runs in the server ( https://github.com/ushahidi/platform ) , and another one provides the frontend assets that run in the browser (html, javascript etc, that’s https://github.com/ushahidi/platform-client )
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:06
DocRoot2.png
Ushbot
@ushbot
Nov 01 2016 10:06
[David Losada, Ushahidi] in the instructions you are following, each of those is served under a different virtual hosts, meaning two different document roots in total
[David Losada, Ushahidi] you will also need two different host names in the url
[David Losada, Ushahidi] i.e. http://api.mydeployment.com for the API
[David Losada, Ushahidi] and http://mydeployment.com for the frontend app
[David Losada, Ushahidi] visitors would need to know only the second one, but you’ve got to set up both to work regardless
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:14
newerror.png
It show the back API is fine,but It shows error for the front one
Sorry, something went wrong. Try reloading the page.
the web shows those words
Nesp
@Nesp
Nov 01 2016 10:16

[David Losada, Ushahidi] Nesp, that’s an error in the docs, fixing that now. Thanks for bringing it up!

@ushbot thanks!

:)
Ushbot
@ushbot
Nov 01 2016 10:17
[David Losada, Ushahidi] sanqian, how do you try to access the frontend server?
[David Losada, Ushahidi] Nesp, welcome!
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:18
Screenshot from 2016-11-01 18:17:54.png
Ushbot
@ushbot
Nov 01 2016 10:18
[David Losada, Ushahidi] kyoungrok , we’ve updated the heroku docs with instructions to configure the scheduled jobs that will enable your twitter datasource
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:18
I build vhost sfd for front
Ushbot
@ushbot
Nov 01 2016 10:18
[David Losada, Ushahidi] do you type sfd.myusha.com in your browser?
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:19
then enter sfd.myusha.com in where the url should be
yes
Nesp
@Nesp
Nov 01 2016 10:26
@ushbot as I have all set up right now, which file should I download and where should I place it? Should I put it in my platform folder? I re-cloned the platform.git but I don't see any 007 file.
Ushbot
@ushbot
Nov 01 2016 10:26
[David Losada, Ushahidi] sanqian, is your browser in the same computer where you are configuring all this?
Nesp
@Nesp
Nov 01 2016 10:26
(thanks)
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:26
yes
I do all this in one computer
Ushbot
@ushbot
Nov 01 2016 10:28
[David Losada, Ushahidi] sanqian, one thing you can do is edit /etc/hosts (you will need to do that as an admin) and add sfd.myusha.com at the end of to the line that starts with “127.0.0.1” . As an example you may have “127.0.0.1 localhost” , and you would edit that to “`127.0.0.1 localhost sfd.myusha.com`"
[David Losada, Ushahidi] this is fine for testing but you will need to think of this setup and the DNS resolution implications, once you intend to make your site available to others
[David Losada, Ushahidi] Nesp, what file do you mean?
Nesp
@Nesp
Nov 01 2016 10:31
Sorry I meant the 0777 file or folder which is not found when I run the command chown www-data 0777 application/logs application/cache application/media/uploads
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:31
problem still there
I have reload and restart apache
Ushbot
@ushbot
Nov 01 2016 10:33
[David Losada, Ushahidi] Nesp, the updated instructions substitute that command for these:
chmod 0777 application/logs application/cache application/media/uploads
chown www-data application/logs application/cache application/media/uploads
[David Losada, Ushahidi] sanqian, if you open a terminal and run the command `curl -v http://sfd.myusha.com` , what output do you get?
Liwei
@willis50317
Nov 01 2016 10:34
I think I have already installed nodejs and the version is 6.9.1
blob
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:34
Screenshot from 2016-11-01 18:34:03.png
a lot of codes
Screenshot from 2016-11-01 18:35:25.png
Ushbot
@ushbot
Nov 01 2016 10:36
[David Losada, Ushahidi] willis , my bad, please delete /home/liwei/platform-client/node_modules/node-sass and run npm install again . Put attention to any non-fatal errors related to installing node-sass
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:36
Screenshot from 2016-11-01 18:36:03.png
Ushbot
@ushbot
Nov 01 2016 10:36
[David Losada, Ushahidi] sanqian, that looks successful .. maybe your browser is still caching the name resolution failure
Nesp
@Nesp
Nov 01 2016 10:36
@ushbot thanks a lot , now it works :)
Ushbot
@ushbot
Nov 01 2016 10:36
[David Losada, Ushahidi] try to clear cache or an incognito session
[David Losada, Ushahidi] great, Nesp
Nesp
@Nesp
Nov 01 2016 10:46
blob
Stephanie Liu
@sanqianliusi
Nov 01 2016 10:46
error still there
after clean the cache
Nesp
@Nesp
Nov 01 2016 10:49
referred to the image: what should be the .env file name?
With "myapi.server/" do you mean the location of the platform (APIs) in the server? Should I write localhost then? Actually according to the instructions, my localhost points to "/platform/httpdocs". What should I write there?
Ushbot
@ushbot
Nov 01 2016 10:53
[David Losada, Ushahidi] Nesp, that’s the URL through which the browser will be able to connect to the platform API . Setting it to localhost is an option, but only browsers running in the same host as the server will be able to use the site.
[David Losada, Ushahidi] sanqian, unfortunately the error provided by the browser gives us very little to work on. Could you please see if you can get more detail out of that error?
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:00
i cannot access your website to read the install guide now. have I miss something in the file .env?
Screenshot from 2016-11-01 19:00:25.png
Did I lost some lines?
or the front vhost is nothing with that file?
Ushbot
@ushbot
Nov 01 2016 11:02
[David Losada, Ushahidi] Sanqian, those look good, and both virtual servers are configured as we have verified . I’m not sure what’s the deal with your browser though
[David Losada, Ushahidi] one thing you could try is go back to the step where you go to your platform-client folder, and set BACKEND_URL=”http://localhost” in the .env file in there, then run "gulp build" again
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:07
There is no file name .env in the platform-client,should i build one?
Ushbot
@ushbot
Nov 01 2016 11:09
[David Losada, Ushahidi] yes , with contents
\` BACKEND\_URL=”[http://localhost](http://localhost)”`
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:10
Screenshot from 2016-11-01 19:10:36.png
Ushbot
@ushbot
Nov 01 2016 11:11
[David Losada, Ushahidi] mm no.. I don’t think you should copy paste that
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:12
o
my back one
Ushbot
@ushbot
Nov 01 2016 11:12
[David Losada, Ushahidi] There shouldn’t be any \ , [ or ( symbols in there
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:14
Screenshot from 2016-11-01 19:13:45.png
Ushbot
@ushbot
Nov 01 2016 11:15
[David Losada, Ushahidi] but you access the backend like this, don’t you? https://files.gitter.im/ushahidi/Community/L9iP/newerror.png
[David Losada, Ushahidi] http://127.0.0.1
[David Losada, Ushahidi] does http://stephanie.myushahidi.com also give you that response ?
[David Losada, Ushahidi] (that response is not an error, it’s a good API server response)
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:16
no,I have changed it
Screenshot from 2016-11-01 19:16:20.png
the backend
Ushbot
@ushbot
Nov 01 2016 11:17
[David Losada, Ushahidi] ah ok, super then :)
[David Losada, Ushahidi] set BACKEND_URL to that.. the ServerName, not the the ServerAdmin
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:18
then what should my server admin be?
for the backend?
Ushbot
@ushbot
Nov 01 2016 11:19
[David Losada, Ushahidi] ServerAdmin is not a critical setting, it’s an email address that the server may return sometimes in case someone wants to send an email to the admin of that server
[David Losada, Ushahidi] I don’t think we are concerned with that in this case
[David Losada, Ushahidi] (ServerName is actually the address of the virtual host you are configuring)
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:31
At first ,I should write a .env and put it in the platform-client
Screenshot from 2016-11-01 19:30:14.png
Ushbot
@ushbot
Nov 01 2016 11:31
[David Losada, Ushahidi] that’s correct
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:32
then I should enter the /platform/platform-client to run gulp build
Ushbot
@ushbot
Nov 01 2016 11:32
[David Losada, Ushahidi] yes, it should be the same location where you created that .env file
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:33
Error: Missing binding /platform/platform-client/node_modules/node-sass/vendor/linux-x64-47/binding.node
Node Sass could not find a binding for your current environment: Linux 64-bit with Node.js 5.x
Screenshot from 2016-11-01 19:34:26.png
Ushbot
@ushbot
Nov 01 2016 11:35
[David Losada, Ushahidi] mm I’ll need to research that
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:35
thank you so much
Ushbot
@ushbot
Nov 01 2016 11:36
[David Losada, Ushahidi] try the suggested command npm rebuld node-sass ?
Liwei
@willis50317
Nov 01 2016 11:43
well... is it normal when I run "gulp", it stuck on this line?
However, I can manually open browser and successfully access "localhost:8080"
Also, I found that I can't stop this running by "ctrl+c", or this access may fail.
blob
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:45
Screenshot from 2016-11-01 19:45:02.png
Ushbot
@ushbot
Nov 01 2016 11:45

[David Losada, Ushahidi] willis, yea, “gulp” runs the development server .

It’s fine for developing. But if, you intend to leave this running or have other people access it , you need “gulp build”. That generates the files that then you would serve with a normal apache or nginx server

[David Losada, Ushahidi] sanqian, that doesn’t look very good.. what is the output right before “Bus error (core dumped)"
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:47
Screenshot from 2016-11-01 19:46:44.png
Ushbot
@ushbot
Nov 01 2016 11:51
[David Losada, Ushahidi] I’m not sure why that is happening
Liwei
@willis50317
Nov 01 2016 11:52
Ok, I may need some time to figure it out.
David, thank you so much for helping me these two days!
Ushbot
@ushbot
Nov 01 2016 11:52
[David Losada, Ushahidi] you are welcome willis
[David Losada, Ushahidi] sanqian , did you intend to make changes to our code right after installing?
Stephanie Liu
@sanqianliusi
Nov 01 2016 11:54
no
one thing I am concerned is that every time I start my computer, it show warning to me
like **coreerror
Ushbot
@ushbot
Nov 01 2016 11:56
[David Losada, Ushahidi] mm you may want to run a memory test to make sure
[David Losada, Ushahidi] regarding our app, you can also download a pre-built version of these frontend files, so you don’t need npm, or gulp
[David Losada, Ushahidi] unzip this in a folder, adjust the virtualhost DocumentRoot to match that folder (no “server/www” bit necessary), and edit the included config.js to :
\` window.ushahidi = { backendUrl : “[http://stephanie.myushahidi.com](http://stephanie.myushahidi.com)", };`
Stephanie Liu
@sanqianliusi
Nov 01 2016 12:01
does that matter?
Screenshot from 2016-11-01 20:00:49.png
Ushbot
@ushbot
Nov 01 2016 12:01
[David Losada, Ushahidi] I think it may be reflecting the same problem we have been seeing
Stephanie Liu
@sanqianliusi
Nov 01 2016 12:02
I can not open the link you offered to me
o
it is ok now
thank you
Ushbot
@ushbot
Nov 01 2016 12:03
[David Losada, Ushahidi] you are welcome
Ushbot
@ushbot
Nov 01 2016 12:17
[Jess Shorland, Ushahidi] Hi ush support -- I'm working on a deployment and need help configuring my Twilio account integration as a data source
Stephanie Liu
@sanqianliusi
Nov 01 2016 12:18
would you mind to send me email attache the ushahidi-platform-client-bundle-v3.6.1.tar.gz?
I try many times
Screenshot from 2016-11-01 20:19:17.png
It always fail to download
Ok,I will change a computer to do this
Ushbot
@ushbot
Nov 01 2016 12:23
[David Losada, Ushahidi] re: Twilio, have you checked our docs at https://www.ushahidi.com/support/data-sources#twilio ?
[David Losada, Ushahidi] sanqian, gitter may be doing something with the link , you will find the file if you browse to https://github.com/ushahidi/platform-client/releases
[David Losada, Ushahidi] look for “ushahidi-platform-client-bundle-v3.6.1.tar.gz"
Ushbot
@ushbot
Nov 01 2016 12:30
[Jess Shorland, Ushahidi] @davidlosada yes -- i've followed those instructions. i think the problem may be in my SMS request URL in Twilio app -- The instructions say to format it as https://<your-deployment-url>.api.ushahidi.io/sms/twilio/reply
[Jess Shorland, Ushahidi] so mine is currently input as https://usaelectionmonitor.ushahidi.io.api.ushahidi.io/sms/twilio/reply
[Jess Shorland, Ushahidi] but does it actually need to be https://usaelectionmonitor.api.ushahidi.io/sms/twilio/reply?
[David Losada, Ushahidi] yea the second one looks much better
[David Losada, Ushahidi] that part of the docs needs a change
[Jess Shorland, Ushahidi] ok i'll flag! and I'll test the other format and see if that works
[David Losada, Ushahidi] thank you @jshorland , I’ll do an edit right away
[Jess Shorland, Ushahidi] :) thanks for the support
Ushbot
@ushbot
Nov 01 2016 12:36
[Jess Shorland, Ushahidi] BOOM. THAT WORKED!
[Jess Shorland, Ushahidi] sms is functioning properly!
[David Losada, Ushahidi] wunderbar!
Arturo
@ArturoQuintana
Nov 01 2016 12:44
@davidlosada thanks for ask
@davidlosada, after applying the update following these instructions https://www.ushahidi.com/support/upgrading-ushahidi
the system stops to work
and I have to reset the update and recovering the last status
Ushbot
@ushbot
Nov 01 2016 12:49
[David Losada, Ushahidi] Arturo, do you get some concrete error message? we’d need some detail in order to guess what’s going on
Stephanie Liu
@sanqianliusi
Nov 01 2016 12:52
How about restart to install ushahidi from the ever begin?
Maybe I will face this problem again right?
Nesp
@Nesp
Nov 01 2016 12:53
Oh great, I understand. I am running the server in a virtual machine though and I don't manage to see what is published through apache2 from my host machine browser. I used localhost for now, but get the following problem
Stephanie Liu
@sanqianliusi
Nov 01 2016 12:54
I just can not download that oine
Nesp
@Nesp
Nov 01 2016 12:55
blob
Arturo
@ArturoQuintana
Nov 01 2016 12:55
@davidlosada this is my platform "http://bb.fiu.edu"
and it is working right now
I am going to update it:
1.- git pull
2.- npm install
Ushbot
@ushbot
Nov 01 2016 12:59
[David Losada, Ushahidi] ok Arturo, let me know once you’ve done that.. you also need to run “gulp build"
[David Losada, Ushahidi] Nesp, how did you install nodejs in your vm?
Arturo
@ArturoQuintana
Nov 01 2016 13:00
error.png
@davidlosada
this is what I getting now
this is completely new
Nesp
@Nesp
Nov 01 2016 13:02
I used sudo apt-get install nodejs
Ushbot
@ushbot
Nov 01 2016 13:04
[David Losada, Ushahidi] Sanqian, if you cannot download the release it’s quite hard to help..
[David Losada, Ushahidi] Screen Shot 2016-11-01 at 14.02.45.png
[David Losada, Ushahidi] Nesp, can you run node from the terminal?
[David Losada, Ushahidi] Arturo, are you updating the backend, the frontend or both?
Arturo
@ArturoQuintana
Nov 01 2016 13:05
@davidlosada this is what I get when I done the git pull
update_result.png
Nesp
@Nesp
Nov 01 2016 13:05
sure,
blob
Ushbot
@ushbot
Nov 01 2016 13:06
[David Losada, Ushahidi] oh Nesp, your stuff seems to be very advanced, I have to research
[David Losada, Ushahidi] Arturo, you seem to be updating the backend , there is no npm install to run in there , the instructions for this one are “# Updating the API” here: https://www.ushahidi.com/support/upgrading-ushahidi#updating-the-api
Arturo
@ArturoQuintana
Nov 01 2016 13:07
@davidlosada I am trying to update both, first the frontend and after the backend (API)
With the backend I am having other problems.
when I run "bin/update" i get this message >>> Skipping git
Ushbot
@ushbot
Nov 01 2016 13:09
[David Losada, Ushahidi] that should be fine, no other messages?
Arturo
@ArturoQuintana
Nov 01 2016 13:12
@davidlosada not other message trying to update the backend
error.png
let me see the frontend
Ushbot
@ushbot
Nov 01 2016 13:12
[David Losada, Ushahidi] Then backend should be ok
Arturo
@ArturoQuintana
Nov 01 2016 13:12
again
@davidlosada I have applied the update, and it is done!
Ushbot
@ushbot
Nov 01 2016 13:16
[David Losada, Ushahidi] Great!
Arturo
@ArturoQuintana
Nov 01 2016 13:17
the system is still working!
@davidlosada I need to ask you something else
Ushbot
@ushbot
Nov 01 2016 13:18
[David Losada, Ushahidi] That's always good
Arturo
@ArturoQuintana
Nov 01 2016 13:20
@davidlosada I having some problems with the notifications through emails
I have read from Will Doran that the solution is this
./ushahidi notification:savedsearch queue
error.png
but I am getting some errors
Ushbot
@ushbot
Nov 01 2016 13:24
[David Losada, Ushahidi] Try cd ..
[David Losada, Ushahidi] And start the command with bin/ushahidi
Nesp
@Nesp
Nov 01 2016 13:24
blob
now the command node works and I installed the required version as suggested in the updatedd version of the installation support, but I get this problem
Arturo
@ArturoQuintana
Nov 01 2016 13:26
@davidlosada I have tried, and I have got this
error.png
Ushbot
@ushbot
Nov 01 2016 13:27
[David Losada, Ushahidi] I'll get back to you both a bit later. Need to check some things
Nesp
@Nesp
Nov 01 2016 13:27
ok, thanks a lot! :)
Arturo
@ArturoQuintana
Nov 01 2016 13:28
ok, thank you very much!
;-)
Stephanie Liu
@sanqianliusi
Nov 01 2016 13:31
I have
Screenshot from 2016-11-01 21:30:14.png
the file now,and can`t release it
Arturo
@ArturoQuintana
Nov 01 2016 13:58
@davidlosada The platform stopped working, and I had to reset it to a previous version :-(
I tried to login and it didn't work
Then, I cleaned the cache and, I am in the beginning. Not updated :-/
Ushbot
@ushbot
Nov 01 2016 14:03
[David Losada, Ushahidi] Arturo, I guess we’ll have to look at the error in detail. Could you do the update again?
Arturo
@ArturoQuintana
Nov 01 2016 14:03
@davidlosada ok, let's go
remember, this is mi platform http://bb.fiu.edu/views/map
Ushbot
@ushbot
Nov 01 2016 14:05
[David Losada, Ushahidi] Nesp, please try removing node_modules and running npm install again
Arturo
@ArturoQuintana
Nov 01 2016 14:06
@davidlosada git pull done
Ushbot
@ushbot
Nov 01 2016 14:06
[David Losada, Ushahidi] ok, keeping an eye on it, Arturo
Arturo
@ArturoQuintana
Nov 01 2016 14:07
@davidlosada sudo npm install in process
ok
Ushbot
@ushbot
Nov 01 2016 14:08
[David Losada, Ushahidi] sanqian , it looks like the file you downloaded got corrupted somehow. it must be in gzip format
Arturo
@ArturoQuintana
Nov 01 2016 14:09
@davidlosada the system has stopped
Ushbot
@ushbot
Nov 01 2016 14:09
[David Losada, Ushahidi] ok let me see
Arturo
@ArturoQuintana
Nov 01 2016 14:10
@davidlosada the execution of the "sudo git pull" represents "536 files changed, 15735 insertions(+), 14565 deletions(-)"
Ushbot
@ushbot
Nov 01 2016 14:10
[David Losada, Ushahidi] weblib02.fiu.edu is that the backend server?
Arturo
@ArturoQuintana
Nov 01 2016 14:10
yes
Ushbot
@ushbot
Nov 01 2016 14:12
[David Losada, Ushahidi] i’m still looking
Nesp
@Nesp
Nov 01 2016 14:13
now it seems working though it gets stuck at this point, I had to close the virtual machine and restart again. I removed the modules and run npm install. The I did sudo gulp build
blob
this is the current status and where it got stuck earlier
Arturo
@ArturoQuintana
Nov 01 2016 14:14
@davidlosada I have restored the system
Nesp
@Nesp
Nov 01 2016 14:14
I will give it some time
thank you very much for your support, very appreciated
Arturo
@ArturoQuintana
Nov 01 2016 14:15
@davidlosada Or do you need the stage with the update applied?
Ushbot
@ushbot
Nov 01 2016 14:16
[David Losada, Ushahidi] yea, it would be good to leave it at that until I can understand what could be the problem
Arturo
@ArturoQuintana
Nov 01 2016 14:16
opk
Ushbot
@ushbot
Nov 01 2016 14:17
[David Losada, Ushahidi] what I’ve seen so far it’s still making me scratch my head..
Arturo
@ArturoQuintana
Nov 01 2016 14:17
ok, I will do it again
Ushbot
@ushbot
Nov 01 2016 14:17
[David Losada, Ushahidi] thanks
Arturo
@ArturoQuintana
Nov 01 2016 14:17
I am sorry! This problems is getting me crazy
Ushbot
@ushbot
Nov 01 2016 14:18
[David Losada, Ushahidi] we’ll figure it out :)
Arturo
@ArturoQuintana
Nov 01 2016 14:18
If you see the system is working now properly
Ushbot
@ushbot
Nov 01 2016 14:18
[David Losada, Ushahidi] yep i saw that
Arturo
@ArturoQuintana
Nov 01 2016 14:18
let's apply the update again
Ushbot
@ushbot
Nov 01 2016 14:19
[David Losada, Ushahidi] just a sec, got visit
Arturo
@ArturoQuintana
Nov 01 2016 14:21
@davidlosada Ok, the update has been applied (and the system is not working, of course :-( )
Ushbot
@ushbot
Nov 01 2016 14:25
[David Losada, Ushahidi] ok i’ll take a look now
[David Losada, Ushahidi] did you run gulp build?
Arturo
@ArturoQuintana
Nov 01 2016 14:28
@davidlosada Nop, I have followed this steps https://www.ushahidi.com/support/upgrading-ushahidi
Ushbot
@ushbot
Nov 01 2016 14:30
[David Losada, Ushahidi] the template files I’m getting are not correct and those are built with “gulp build"
Arturo
@ArturoQuintana
Nov 01 2016 14:31
huuummm
then, which are the steps to update?
Ushbot
@ushbot
Nov 01 2016 14:31
[David Losada, Ushahidi] yea, let me review the doc, we may have an ommission there
Arturo
@ArturoQuintana
Nov 01 2016 14:32
ok, thank you!
Ushbot
@ushbot
Nov 01 2016 14:32
[David Losada, Ushahidi] ah yea it’s missing :(
Arturo
@ArturoQuintana
Nov 01 2016 14:32
Can I restore the system?
Ushbot
@ushbot
Nov 01 2016 14:33
[David Losada, Ushahidi] just run "gulp build” from the platform-client folder
[David Losada, Ushahidi] hopefully that will fix it all
Arturo
@ArturoQuintana
Nov 01 2016 14:33
ok, lets start
when I must do the gulp build?
Ushbot
@ushbot
Nov 01 2016 14:34
[David Losada, Ushahidi] it’s an additional step , after the npm install
Arturo
@ArturoQuintana
Nov 01 2016 14:34
ok!
let's see
it is running, but I am getting this errors
Error in plugin 'gulp-notify'
(notify-send:31691): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Ushbot
@ushbot
Nov 01 2016 14:38
[David Losada, Ushahidi] that one should be harmless
Arturo
@ArturoQuintana
Nov 01 2016 14:39
David, The system has crashed
Ushbot
@ushbot
Nov 01 2016 14:40
[David Losada, Ushahidi] oh is it a small server?
[David Losada, Ushahidi] these builds can be demanding
Arturo
@ArturoQuintana
Nov 01 2016 14:41
nop, the build has finished, but the result it is the same
:-(
Nesp
@Nesp
Nov 01 2016 14:41
It worked! :)
Ushbot
@ushbot
Nov 01 2016 14:42
[David Losada, Ushahidi] mm still getting the wrong templates
Arturo
@ArturoQuintana
Nov 01 2016 14:43
:'(
:fire:
Ushbot
@ushbot
Nov 01 2016 14:44
[David Losada, Ushahidi] what do you get when you ls server/www/templates ?
Arturo
@ArturoQuintana
Nov 01 2016 14:44
wait
common main settings
Ushbot
@ushbot
Nov 01 2016 14:46
[David Losada, Ushahidi] mm did all the build really go well? nothing strange apart from that couple lines you pasted?
Arturo
@ArturoQuintana
Nov 01 2016 14:48
error.png
error.png
Ushbot
@ushbot
Nov 01 2016 14:50
[David Losada, Ushahidi] mm ok, please go back to the previous status
[David Losada, Ushahidi] i will do some more tests here
Arturo
@ArturoQuintana
Nov 01 2016 14:50
ok
Ushbot
@ushbot
Nov 01 2016 14:51
[David Losada, Ushahidi] could you please also initiate a conversation in our intercom support and mention me there?
[David Losada, Ushahidi] look for “Chat with a team member” in https://www.ushahidi.com/support
[David Losada, Ushahidi] please make sure to leave your email address in there, that way I can easily reach back to you
Arturo
@ArturoQuintana
Nov 01 2016 14:54
Angela Oduor Lungati knows that you are helping me with all this
;-)
Ushbot
@ushbot
Nov 01 2016 14:58
[David Losada, Ushahidi] :) cool
TheNiqabiCoderMum
@nqcm
Nov 01 2016 14:58
hi can anyone advise what is the better way to install ushahidi on aws? on an EC2 instance with LAMP stack or on elastic beanstalk?
Ushbot
@ushbot
Nov 01 2016 15:25
[David Losada, Ushahidi] theniq, ec2 instance will probably serve you better at this point
TheNiqabiCoderMum
@nqcm
Nov 01 2016 15:52
thanks!