These are chat archives for ushahidi/Community

2nd
Nov 2016
Stephanie Liu
@sanqianliusi
Nov 02 2016 09:58
hi
I got this
what does that mean?
myushahidi.png
after I download the platform-client-bundle-v3.6.1,and made my vhost docroot point to it
anyone help~
Ushbot
@ushbot
Nov 02 2016 10:05
[David Losada, Ushahidi] hi sanqian, is the browser in the same computer where your server is running?
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:06
yes
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:21
Screenshot from 2016-11-02 18:20:29.png
and why can`t I do bin-updata
Ushbot
@ushbot
Nov 02 2016 10:23
[David, Ushahidi] Hi everyone. My name is David Braun. In the past, my programmers and I have engaged you for support and really appreciate the help you've given us. :) Presently, I have a question regarding what map integration to use. We have made an Android app to integrate with the v.3 code. We're not sure if we should go with Google Maps or Open Street Map. I think my programmer is concerned Google won't accept/ publish our Android app when they review the app because we would be using a different map application other than their own. He also isn't sure how easy Open Street Maps is to plug into the app itself or how stable the service is (compared to Google maps). The same questions arise with iOS app versions, accept involving Mac maps. I'm wondering if you or anyone on your team has experience with these questions when v.2 Mobile App's were created. I would greatly appreciate your thoughts or any experience/ advice any on your team would have. Feel free to answer me on hipchat or by email--impactumbrella@gmail.com. Thanks again... love your dedication and wonderful service which is helping so many people... :)
Ushbot
@ushbot
Nov 02 2016 10:34
[David Losada, Ushahidi] Hi David, I think there are quite many applications out there that don't use google maps or apple maps. There's maps.me , for instance. I don’t know if they had problems themselves, but at least it points out that it’s not impossible.
[David Losada, Ushahidi] sanqian , there’s no bin/update in platform-client , that’s only an action in the backend (platform)
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:35
Ifoundout that just now
Ushbot
@ushbot
Nov 02 2016 10:35
[David, Ushahidi] That's a good point... I doubt Google would turn down a mobile app just because it didn't run Google Maps...
[David Losada, Ushahidi] regarding www.myusha.com , did you add that to /etc/hosts just as we did yesterday with stephanie.myushahidi.com ?
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:36
and still have problem
Ushbot
@ushbot
Nov 02 2016 10:36
[David Losada, Ushahidi] David, yea I also think it’s not in their general spirit of doing things
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:37
when do it at the right place

Cannot create cache directory /home/stephanie/.composer/cache/repo/https---packagist.org/, or directory is not writable. Proceeding without cache
Cannot create cache directory /home/stephanie/.composer/cache/files/, or directory is not writable. Proceeding without cache
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file

[RuntimeException]
/home/stephanie/platform/vendor/behat/gherkin does not exist and could not
be created.

Screenshot from 2016-11-02 18:34:09.png
Ushbot
@ushbot
Nov 02 2016 10:37
[David Losada, Ushahidi] sanqian, probably you ran that with sudo at some point, so now you should keep doing it
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:37
add sudo?
Screenshot from 2016-11-02 18:34:09.png
Ushbot
@ushbot
Nov 02 2016 10:38
[David Losada, Ushahidi] yes, run the same command with sudo at the beginning of it
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:38
Package guzzle/guzzle is abandoned, you should avoid using it. Use guzzlehttp/guzzle instead.
Package league/url is abandoned, you should avoid using it. Use league/uri instead.
how about this?
Ushbot
@ushbot
Nov 02 2016 10:39
[David Losada, Ushahidi] they are warnings, not fatal
[David, Ushahidi] Thanks for your thoughts David.
[David Losada, Ushahidi] you are most welcome. good luck with that app, we are also excited about it!
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:40
Screenshot from 2016-11-02 18:40:08.png
what does that mean?what should I do about that?
Ushbot
@ushbot
Nov 02 2016 10:41
[David Losada, Ushahidi] sanqian, unless you are planning to keep different execution environments for the same project (development, staging, production…), probably nothing
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:45
how to get nodejs v0.10 or v0.12 or io.js v1.2
Ushbot
@ushbot
Nov 02 2016 10:46
[David Losada, Ushahidi] actually we are up to nodejs v4 as a minimum , let me update those docs
[David Losada, Ushahidi] the way to get it depends on your linux distribution
Stephanie Liu
@sanqianliusi
Nov 02 2016 10:48
what if I enter :sudo apt-get nodejs@v4
Ushbot
@ushbot
Nov 02 2016 10:50
[David Losada, Ushahidi] install 6.x instead, it’s the latest stable: https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:05
I got more errors
Screenshot from 2016-11-02 19:04:54.png
Ushbot
@ushbot
Nov 02 2016 11:12
[David Losada, Ushahidi] that needs super user access, run with sudo
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:27
Screenshot from 2016-11-02 19:26:53.png
Have I done the right thing?
as it required?
Ushbot
@ushbot
Nov 02 2016 11:28
[David Losada, Ushahidi] looks ok. platform won’t need the BACKEND_URL , you’ll want that in platform-client only
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:29
?create a .env file under platform-client ,not under platform?
Ushbot
@ushbot
Nov 02 2016 11:29
[David Losada, Ushahidi] both places need .env files
[David Losada, Ushahidi] just with different contents
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:29
the last line is needed in platform-client
Ushbot
@ushbot
Nov 02 2016 11:29
[David Losada, Ushahidi] exactly
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:30
and other lines are under platform
ok
Have I write in a correct way? Does it need"" ?
like : I should write BACKEND_URL="http://stephanie.myushahidi.com/"
Ushbot
@ushbot
Nov 02 2016 11:32
[David Losada, Ushahidi] yea looks safer with quotes
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:33
Screenshot from 2016-11-02 19:33:27.png
now ,I have this error
Ushbot
@ushbot
Nov 02 2016 11:34
[David Losada, Ushahidi] I remember we had that the last couple days...
[David Losada, Ushahidi] I’m at loss, not sure what would be causing that
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:35
I restart install that
and still meet this
Ushbot
@ushbot
Nov 02 2016 11:36
[David Losada, Ushahidi] are you using ubuntu?
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:37
yes
can it insatll inwindows?
Ushbot
@ushbot
Nov 02 2016 11:38
[David Losada, Ushahidi] all that we are using is very well supported in ubuntu.. so I don’t think we should think of library or dependencies problems
[David Losada, Ushahidi] it may be something at the lower level, like memory or disk problems
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:38
maybe I should change a computer
Ushbot
@ushbot
Nov 02 2016 11:38
[David Losada, Ushahidi] we have never done a windows install, we wouldn’t be able to help you with that
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:39
Thank you very much for those days` help
I will restart with another computer again
Ushbot
@ushbot
Nov 02 2016 11:39
[David Losada, Ushahidi] you are welcome, we are happy to help and it helps us too to talk with you
Stephanie Liu
@sanqianliusi
Nov 02 2016 11:40
:+1:
Arturo
@ArturoQuintana
Nov 02 2016 12:48
@davidlosada Hi David, any news for me related to my issue?
Ushbot
@ushbot
Nov 02 2016 13:03
[David Losada, Ushahidi] unfortunately not yet Arturo, I’ll get to it later today
Arturo
@ArturoQuintana
Nov 02 2016 13:06
@davidlosada Ok David, thank you in advance. I'll be here.