These are chat archives for ushahidi/Community

29th
Nov 2016
Liwei
@willis50317
Nov 29 2016 01:09
@ushbot David, is there any way to solve my problem? thanks!
Robbie Mackay
@rjmackay
Nov 29 2016 01:56
@Theniqabicodermum what issues are you still having? I've tried to figure it out reading the history but can't find it.
the last logs you posted look fine, theres lots of debug output, but nothing broken.
@willis50317 I think the line you need is sql_mode = ALLOW_INVALID_DATES
its an _ not a -
Liwei
@willis50317
Nov 29 2016 03:00
okay thanks I correct that line. It works now I can login my account.
But the error still happens when I run "bin/update"
Screenshot from 2016-11-29 10-57-13.png
Screenshot from 2016-11-29 10-55-31.png
TheNiqabiCoderMum
@nqcm
Nov 29 2016 07:49
@rjmackay the problem is that when i email a post to the address i have specified in the ushahidid app, it does not show. when i check the email from webmail i can see that it is deliveerd but still it is not showing up in the ushahidi. so @ushbot asked me to send the log file.
@rjmackay can you help me please?
Ushbot
@ushbot
Nov 29 2016 07:52
[Robbie Mackay, Ushahidi] @theniqabicodermum right. Do you have cronjobs set up to run bin/ushahidi dataproviders incoming ?
[Robbie Mackay, Ushahidi] @willis50317 that error looks like its simply a permissions issue. ie. the user you have configured in .env can't access the database
[Robbie Mackay, Ushahidi] Can you test that ushahidiplus can access the ushahidiplus_db from the server you're running bin/update on?
TheNiqabiCoderMum
@nqcm
Nov 29 2016 08:00
yes i have, i followed the instructions from here
2016-11-29_0959.png
Ushbot
@ushbot
Nov 29 2016 08:10
[Robbie Mackay, Ushahidi] Odd. If you run bin/ushahidi dataprovider incoming manually, what does it output?
[Robbie Mackay, Ushahidi] actually maybe run it with a verbose option too: bin/ushahidi dataprovider incoming -vv
TheNiqabiCoderMum
@nqcm
Nov 29 2016 08:19
ok let me try
it says email 0
TheNiqabiCoderMum
@nqcm
Nov 29 2016 08:42
i have also added a twitter data source in the app. now if i run the above command i get email 0 and twitter 0
i hv tried a sample tweet with my specified hashtag, let me wait a few minutes and then i will let you know if it works.
TheNiqabiCoderMum
@nqcm
Nov 29 2016 09:03
the twitter and smssync are working but not the email
TheNiqabiCoderMum
@nqcm
Nov 29 2016 09:31
@ushbot @rjmackay twitter posts are coming fine, i tried changing the email to a gmail one but it is still not working, and the smssync test message came fine but since then when i am publishing the messages nothing is reaching
TheNiqabiCoderMum
@nqcm
Nov 29 2016 09:40
ok smssync has posted one message 97 times on my ushahidi :)
TheNiqabiCoderMum
@nqcm
Nov 29 2016 09:49
smssync has posted it for a total of 234 time :(