These are chat archives for ushahidi/Community

2nd
Dec 2016
TheNiqabiCoderMum
@nqcm
Dec 02 2016 07:33
and can anyone help me please . i can input data through twitter without any problem, email is not working at all and smssync is also giving problems.
Ushbot
@ushbot
Dec 02 2016 08:48
[Angela Oduor Lungati, Ushahidi] Ping @jason @davidlosada could one of you help @nqcm with his issue on email? I'll go ahead and add the SMSSync issue to GitHub as I experienced the same thing this past week.
Ushbot
@ushbot
Dec 02 2016 09:07
[Jason Mule, Ushahidi] @nqcm Could you check that you can receive email from your account using IMAP?
TheNiqabiCoderMum
@nqcm
Dec 02 2016 10:52
thnx @aoduor .

[Jason Mule, Ushahidi] @nqcm Could you check that you can receive email from your account using IMAP?

i can recv on webmail, shoul di try making an account on outlook and check?

TheNiqabiCoderMum
@nqcm
Dec 02 2016 11:02
yes i can recv emails on my outlook with the same settings (IMAP) that i am using on ushahidi
Ushbot
@ushbot
Dec 02 2016 11:57
[David Losada, Ushahidi] @nqcm , if using a gmail account for email, you may need to change the security settings of the associated google account. We’ve seen in some cases that it’s necessary to enable “Allow less secure apps"
Arturo
@ArturoQuintana
Dec 02 2016 13:45
@davidlosada I am having some issues with ushahidi.
If I try to access the map directly, the site does not work. However, if I access to the root of the site, the system redirect the surf to the map and work perfectly.
What's is happening here?
Ushbot
@ushbot
Dec 02 2016 13:53
[David Losada, Ushahidi] @ArturoQuintana it sounds like the frontend configuration is not rewriting internally to index.html the requests that don’t match a file. This is because how we use AngularJS and do routing. Do you have this file (renamed as .htaccess) in your document root? https://github.com/ushahidi/platform-client/blob/develop/server/rewrite.htaccess
Arturo
@ArturoQuintana
Dec 02 2016 13:53
let me see
@davidlosada this is something that started to happen after some actualizations
Ushbot
@ushbot
Dec 02 2016 13:56
[David Losada, Ushahidi] if those updates removed or rewrote the .htaccess file , it would make sense
Arturo
@ArturoQuintana
Dec 02 2016 13:57
@davidlosada I do not have this route in my platform-client folder
I do not have a blob folder
but
Ushbot
@ushbot
Dec 02 2016 13:57
[David Losada, Ushahidi] maybe there’s a file called rewrite.htaccess ?
Arturo
@ArturoQuintana
Dec 02 2016 13:58
I have found a rewrite.htaccess file in https://github.com/ushahidi/platform-client/server
Ushbot
@ushbot
Dec 02 2016 13:59
[David Losada, Ushahidi] well, I’m not sure what a blob folder is… but if you have rewrite.htaccess file in your server, you could try renaming it to .htaccess
Arturo
@ArturoQuintana
Dec 02 2016 14:00
you have mentioned a blob folder in the route given
Ushbot
@ushbot
Dec 02 2016 14:00
[David Losada, Ushahidi] ah I see that’s just github choice of naming , I just wanted to point at the contents of the file
[David Losada, Ushahidi] the file should be in the document root of your server, along with index.html
Arturo
@ArturoQuintana
Dec 02 2016 14:02
Ok, got it!
I was looking for this path
@davidlosada I have change rewrite.htaccess to .htaccess, but the problem persist
Ushbot
@ushbot
Dec 02 2016 14:06
[David Losada, Ushahidi] mm let’s check if my hypothesis was right, do you have a URL I could try?
Arturo
@ArturoQuintana
Dec 02 2016 14:07
Ushbot
@ushbot
Dec 02 2016 14:08
[David Losada, Ushahidi] yea, it looks like the problem I expected to see
Arturo
@ArturoQuintana
Dec 02 2016 14:08
@davidlosada This URL does not work
Ushbot
@ushbot
Dec 02 2016 14:08
[David Losada, Ushahidi] how about the Apache configuration file for that virtual server?
[David Losada, Ushahidi] there should be an "AllowOverride All” directive to ensure the .htaccess file is being honored
Arturo
@ArturoQuintana
Dec 02 2016 14:09
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^.*$ /index.html [PT,L]
this is what you can find in the .htaccess
Ushbot
@ushbot
Dec 02 2016 14:10
[David Losada, Ushahidi] mm yea that’s ok
[David Losada, Ushahidi] I mean in the Apache configuration files… usually they are found under /etc/apache2
Arturo
@ArturoQuintana
Dec 02 2016 14:11
@davidlosada let me see, but remember that previously it was working
Arturo
@ArturoQuintana
Dec 02 2016 14:18
@davidlosada I have change the apache
and it is still not working
Ushbot
@ushbot
Dec 02 2016 14:18
[David Losada, Ushahidi] what does the apache config look like?
Arturo
@ArturoQuintana
Dec 02 2016 14:19
<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>
<Directory /var/www/html/platform>
AllowOverride All
</Directory>
Ushbot
@ushbot
Dec 02 2016 14:20
[David Losada, Ushahidi] mm isn’t there somewhere a <Directory > section more specific to the location of your document root?
[David Losada, Ushahidi] ah
[David Losada, Ushahidi] mm , well that’s as much as it usually takes to make it work. Did you restart apache?
Arturo
@ArturoQuintana
Dec 02 2016 14:21
yep
Ushbot
@ushbot
Dec 02 2016 14:21
[David Losada, Ushahidi] mm wait
[David Losada, Ushahidi] <Directory /var/www/html/platform> that’s probably where your platform PHP files are
[David Losada, Ushahidi] but where are the platform-client HTML/JS/CSS etc
[David Losada, Ushahidi] ?
Arturo
@ArturoQuintana
Dec 02 2016 14:22

<Directory /var/www/html/platform-client>

AllowOverride All

</Directory>

sorry
Ushbot
@ushbot
Dec 02 2016 14:22
[David Losada, Ushahidi] ah try to uncomment that
Arturo
@ArturoQuintana
Dec 02 2016 14:24
great!
Ushbot
@ushbot
Dec 02 2016 14:24
[David Losada, Ushahidi] aha there you go, I see it working now
Arturo
@ArturoQuintana
Dec 02 2016 14:24
once again I must appreciate your help
yes
Can I ask you something else?
Ushbot
@ushbot
Dec 02 2016 14:25
[David Losada, Ushahidi] sure go ahead
Arturo
@ArturoQuintana
Dec 02 2016 14:26
why this link show the website content?
http://weblib02.fiu.edu/
is this secure?
Ushbot
@ushbot
Dec 02 2016 14:27
[David Losada, Ushahidi] this is what I’m seeing: { "now": "2016-12-02T14:10:49+00:00", "version": "3", "endpoints": [ "collections", "collections/posts", "comments", "config", "contacts", "csv", "csv/import", "dataproviders", "forms", "forms/attributes", "forms/roles", "forms/stages", "layers", "media", "messages", "migration", "notifications", "passwordreset", "permissions", "posts", "posts/export", "posts/geojson", "posts/revisions", "posts/translations", "posts/updates", "register", "roles", "savedsearches", "tags", "users" ], "user": { "id": null, "email": null, "realname": null } }
[David Losada, Ushahidi] are you seeing that too?
Arturo
@ArturoQuintana
Dec 02 2016 14:28
yes
Ushbot
@ushbot
Dec 02 2016 14:29
[David Losada, Ushahidi] ok, it’s a standard response and it’s safe as far as we can tell
Arturo
@ArturoQuintana
Dec 02 2016 14:29
ok
well @davidlosada , thank you very much!
Ushbot
@ushbot
Dec 02 2016 14:33
[David Losada, Ushahidi] you are most welcome!
Arturo
@ArturoQuintana
Dec 02 2016 14:37
It is really nice to solve these problems!
@davidlosada Have a wonderful weekend!
Ushbot
@ushbot
Dec 02 2016 14:37
[David Losada, Ushahidi] I’m glad that we could help :) have a nice weekend you too
TheNiqabiCoderMum
@nqcm
Dec 02 2016 19:05
@ushbot no i am not using gmail. it is an email with my own domian
domain*
Ushbot
@ushbot
Dec 02 2016 19:35
[David Losada, Ushahidi] ah yes I recall now @nqcm . Not sure what’s going on then… is it a possibility that we get a test email account in that domain to test stuff?