These are chat archives for ushahidi/Community

16th
Feb 2017
TheNiqabiCoderMum
@nqcm
Feb 16 2017 07:25
@ushbot yes but data input through emails and notifications out via email is not working. also smssync was not working properly, sending the same message hundreds of time to the app.
both data input*
Ushbot
@ushbot
Feb 16 2017 07:26
[Jess Shorland, Ushahidi] @nqcm we are fixing the multiple messages bug now. A fix should be pushed in the next few days
[Jess Shorland, Ushahidi] @nqcm with regards to emails not being pulled into the platform, which email client are you using to set up?
TheNiqabiCoderMum
@nqcm
Feb 16 2017 07:33
i am using email from my own domain @ushbot not gmail if that is what you are asking?
i have a dedicated email address and i used that to set up incoming data options from ushahidi app itself.
Ushbot
@ushbot
Feb 16 2017 07:35
[Jess Shorland, Ushahidi] Yes that's helpful to know. @davidlosada any ideas what may be happening here?
TheNiqabiCoderMum
@nqcm
Feb 16 2017 07:47
i made a separate email address and gave it to David last year, to check. He hasnt come back to me yet. @ushbot
Ushbot
@ushbot
Feb 16 2017 09:23
[David Losada, Ushahidi] sorry nqcm matters kept coming .. it looks like we’ve got a bug with unencrypted IMAP . I’ll create a bug report and link you to it with a temporary fix
Ushbot
@ushbot
Feb 16 2017 09:40
[Angela Oduor Lungati, Ushahidi] hey nqcm - we’ve got @eyedol working on a fix for the multiple message problem on SMSSync. We’re currently testing it out, so a release should be out soon
Ushbot
@ushbot
Feb 16 2017 09:47
[David Losada, Ushahidi] nqcm you would have to apply this change locally until we release it: https://github.com/ushahidi/platform/pull/1586/commits/3dc6be2f2c9b1d6c1292d8cadcd8a23b72c8af2c
[pravesh Verma] hi any one help me for add video link in Crowdmap becase if I am putting URL of video so that problem is directly play an other video and if I am putiing embed link so don't shwing as a video.
Ushbot
@ushbot
Feb 16 2017 09:56
[David Losada, Ushahidi] willis , maybe you are trying to update user information after the client has removed the authorization token from its memory?
[David Losada, Ushahidi] hi Pravesh , I don’t think you could embed the video in crowdmap. Adding the http URL of the video as a link doesn’t work as expected?
[pravesh Verma] Hi David , RLS Video link is working
[David Losada, Ushahidi] in what way? can we see where you’ve got your link?
Ushbot
@ushbot
Feb 16 2017 10:04
[femi Olawale] that's a difference
[pravesh Verma] <iframe width="320" height="265" src="[https://www.youtube.com/embed/dS2LfUeTdXc](https://www.youtube.com/embed/dS2LfUeTdXc)" frameborder="0" allowfullscreen></iframe>
[David Losada, Ushahidi] yea HTML code is probably not supported
[David Losada, Ushahidi] and my guess is, that if you just write https://www.youtube.com/embed/dS2LfUeTdXc it appears as plain text in the description?
[pravesh Verma] but in the - Description Include as much detail as possible. *
Allowed HTML tags: "a, p, img, br, b, u, strong, em, i".
Iframes are only allowed from: www.youtube.com/embed/, player.vimeo.com/video/, w.soundcloud.com/player.
[David Losada, Ushahidi] ah you are right! maybe try remove the “s" from https? make it http
[pravesh Verma] yes I am appearing as plan test but not working
Ushbot
@ushbot
Feb 16 2017 10:11
[pravesh Verma] not working after removing "s
[pravesh Verma] any limit of Video size?
Ushbot
@ushbot
Feb 16 2017 10:19
[David Losada, Ushahidi] Pravesh , sorry, unfortunately I don’t know the answer and it’s been a while since we worked on Crowdmap :\
Arturo
@ArturoQuintana
Feb 16 2017 13:50
Hi @davidlosada
how are you?
are you there?
Ushbot
@ushbot
Feb 16 2017 13:54
[David Losada, Ushahidi] hi Arturo, all’s good, hope you are doing well too! I’m about to leave for a while, but if you have any questions you may write here and I will get to them a bit later.
Arturo
@ArturoQuintana
Feb 16 2017 13:55
thanks so much David!
I will appreciate it
Arturo
@ArturoQuintana
Feb 16 2017 14:00
I am trying to upgrade the API
and I am getting this [RuntimeException]
Could not delete /var/www/html/platform/bin/sentry: date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are required
to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning,
you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.
The other thing I would like to share is about session time
Can we increase session time to avoid being rejected?
Arturo
@ArturoQuintana
Feb 16 2017 14:14
@davidlosada I fixed the first problem, but I still get an error
[RuntimeException]
Could not delete /var/www/html/platform/bin/sentry:
Arturo
@ArturoQuintana
Feb 16 2017 14:45
@davidlosada I fixed the last one.
Now I will continue to ask about session time.
Can we increase session time?
Ushbot
@ushbot
Feb 16 2017 17:10
[David Losada, Ushahidi] Arturo, we currently don’t have that as a configurable parameter.. but you can accomplish it with a line of code in the right place. See this example: project-pheme/project-pheme-platform@eb5cee6
Arturo
@ArturoQuintana
Feb 16 2017 17:24
thanks @davidlosada
if I change it, what happens if I update the API?
Should I do it every time I upgrade?
Ushbot
@ushbot
Feb 16 2017 17:27
[David Losada, Ushahidi] do you upgrade by downloading a package with code? or use git?
Arturo
@ArturoQuintana
Feb 16 2017 17:28
I use git
git pull
bin/update
Ushbot
@ushbot
Feb 16 2017 17:29
[David Losada, Ushahidi] then yea, it will probably respect this change when you pull further updates
Arturo
@ArturoQuintana
Feb 16 2017 17:33
ok, thanks!
can I ask you about the SMS data sources using Nexmo and Twillio ?
Ushbot
@ushbot
Feb 16 2017 18:09
[David Losada, Ushahidi] sure, I don’t have a very good handle on those, but please post your questions
Arturo
@ArturoQuintana
Feb 16 2017 18:18
thanks so much!
We have configured both, but we are not receiving the SMS, do you know if we have to do something special on our server?
Or if it is something related to Ushahid/Nexmo, Ushahid/Twillio
Ushbot
@ushbot
Feb 16 2017 18:41
[David Losada, Ushahidi] we actually have got another report in this channel about such problems, I’m going to see with my colleagues if we can start looking into this
Arturo
@ArturoQuintana
Feb 16 2017 18:42
oh great! Thanks so much!
hydrosIII
@hydrosIII
Feb 16 2017 19:04
@davidlosada, Hi i think the report is mine, maybe, i got a problem to configure nexmo, following the instructions in the webpage....
TheNiqabiCoderMum
@nqcm
Feb 16 2017 19:31
@ushbot many thanks! i will wait for the bug fixes and meanwhile have a look at the local change route. thanks guys! much appreciated