These are chat archives for ushahidi/Community

6th
Apr 2017
Ushbot
@ushbot
Apr 06 2017 09:16
[Annaliza Mayor] Hi Good Afternoon. I have successfully installed ushahidi backend and client. Just want to ask what is the pattern library for?
[Annaliza Mayor] I am planning to install it
Ushbot
@ushbot
Apr 06 2017 10:20
[Linda Kamau, Ushahidi] Hello. The pattern library is basically where all the assets for the UI live and you don’t have to install it to get your deployment running as it’s already handled with set up, but in case you just want to learn how it is integrated with the platform, then you can just clone it and play around with it.
[Annaliza Mayor] Oh I see. I will try to play around with it
[Annaliza Mayor] Would it be possible to add additional inputs in the user registration?
[Annaliza Mayor] Do have any idea where the location of files
Ushbot
@ushbot
Apr 06 2017 10:27
[Linda Kamau, Ushahidi] you should be able to
[Linda Kamau, Ushahidi] I think the best place to start is to understand the architecture first
[Linda Kamau, Ushahidi] as there are several moving parts
[Linda Kamau, Ushahidi] API, Client and Data layers
Ushbot
@ushbot
Apr 06 2017 10:40
[Annaliza Mayor] Thank you very much
[Annaliza Mayor] I will check the architecture
Bornfree
@bornfree1987_twitter
Apr 06 2017 12:44
Hello, I'm still struggling with my install from earlier (shared hosting http://crowdmap.smartharare.org. Am getting "Sorry, something went wrong. Try reloading the page." Any idea on how best I can troubleshoot? Thanks.
Ushbot
@ushbot
Apr 06 2017 12:55
[Linda Kamau, Ushahidi] hey hey
[Linda Kamau, Ushahidi] your install is for Ushahidi v3 right
Bornfree
@bornfree1987_twitter
Apr 06 2017 12:55
yep
Ushbot
@ushbot
Apr 06 2017 12:56
[Linda Kamau, Ushahidi] ok, let me point you to a thread here for someone who had similar problem
[Linda Kamau, Ushahidi] a sec
Bornfree
@bornfree1987_twitter
Apr 06 2017 13:01
sounds good, thanks
Ushbot
@ushbot
Apr 06 2017 13:09
[Linda Kamau, Ushahidi] ok, looks like I’m not able to share the thread
[Linda Kamau, Ushahidi] anywya
[Linda Kamau, Ushahidi] so the client is not usually installed on custom folders , only on webroot.
[Linda Kamau, Ushahidi] so this means you will need to edit contents of index.html and change
[Linda Kamau, Ushahidi] Untitled
[Linda Kamau, Ushahidi] Untitled
Bornfree
@bornfree1987_twitter
Apr 06 2017 13:13
ok, I tried that earlier. Currently my base url is: <base href="/crowdmap/">
Ushbot
@ushbot
Apr 06 2017 13:14
[Linda Kamau, Ushahidi] ok, did you get this from the chat with David above
Bornfree
@bornfree1987_twitter
Apr 06 2017 13:14
yep, I was following that chat and tried a few of the steps but no luck
Ushbot
@ushbot
Apr 06 2017 13:14
[Linda Kamau, Ushahidi] mmmh
[Linda Kamau, Ushahidi] your “crowdmap” == the client
Bornfree
@bornfree1987_twitter
Apr 06 2017 13:16
Am not following, what do you mean?
Ushbot
@ushbot
Apr 06 2017 13:19
[Linda Kamau, Ushahidi] see the `base href’ points to the folder for the client code
[Linda Kamau, Ushahidi] so I’m asking if your crowdmap folder is the one that contains the client code
Bornfree
@bornfree1987_twitter
Apr 06 2017 13:22
yes, the crowdmap folder is where I unzipped the platform release files
sorry, am a newbie developer not so familiar with the lingo
Bornfree
@bornfree1987_twitter
Apr 06 2017 13:44
Hello - are you still there?
Ushbot
@ushbot
Apr 06 2017 14:20
[Jason Mule, Ushahidi] @bornfree1987_twitter Did you enable url_rewriting?
Bornfree
@bornfree1987_twitter
Apr 06 2017 14:22
no... how do I check that?
Ushbot
@ushbot
Apr 06 2017 14:35
[Jason Mule, Ushahidi] are you running Apache with PHP as a module?
Bornfree
@bornfree1987_twitter
Apr 06 2017 14:36
yes
PHP Version 5.6.30; Apache; MySQL server version: 5.6.28-76.1-log ;
Ushbot
@ushbot
Apr 06 2017 14:38
[Jason Mule, Ushahidi] Are you able to configrm that you are using mod_php?
[Jason Mule, Ushahidi] If that's the case, could you check the output of phpinfo() and look for mod_rewrite?
Bornfree
@bornfree1987_twitter
Apr 06 2017 14:40
Ok, let me do that and get back to you
Ushbot
@ushbot
Apr 06 2017 14:42
[Jason Mule, Ushahidi] Make sure that mod_rewrite is enabled for the rules in .htaccess
Bornfree
@bornfree1987_twitter
Apr 06 2017 14:52
Hi there, I don't see mod_rewrite anywhere in my phpinfo() output
Though am not so familiar with using it - perhaps you would be willing to take a look to confirm?
Ushbot
@ushbot
Apr 06 2017 15:02
[Jason Mule, Ushahidi] It's probably not enabled then. Could you take a look at http://stackoverflow.com/questions/3131236/how-do-you-enable-mod-rewrite to see how that can be done on your setup?
Bornfree
@bornfree1987_twitter
Apr 06 2017 15:02
ok, will do thanks