These are chat archives for ushahidi/Community

7th
Dec 2017
Cam Macdonell
@cmacdonell
Dec 07 2017 06:50

Hi, I have a platform server up and running with nginx. The root directory spits out the expected JSON details. But anything else, /oauth/token for example, returns 404.

I suspect it might be something to do with my nginx config, maybe the rewrite?

Anyway suggestions?

Ushbot
@ushbot
Dec 07 2017 08:01
[Robbie Mackay, Ushahidi] @cmacdonell does /api/v3/config return anything?
[Robbie Mackay, Ushahidi] If not then it'll definitely be a rewrite issue
Ushbot
@ushbot
Dec 07 2017 11:51
[vishnu_rao] we need urgent support to make our ushahidi map public
https://ecc.ushahidi.io/views/map
[vishnu_rao] once I login - i am able to view the data points on the map.
[vishnu_rao] After I log out and view the map or share it with my friends - I am unable to see the data points on the map. But the update is available on the data link
[vishnu_rao] Please help as it needs to be rolled out urgently
[vishnu_rao] How to make the maps public
Ushbot
@ushbot
Dec 07 2017 11:58
[vishnu_rao] Kindly help
Ushbot
@ushbot
Dec 07 2017 12:03
[vishnu_rao] is anyone there
kvishnurao
@kvishnurao
Dec 07 2017 12:05
Kindly help
we need urgent support to make our ushahidi map public
https://ecc.ushahidi.io/views/map
once I login - i am able to view the data points on the map.
After I log out and view the map or share it with my friends - I am unable to see the data points on the map. But the update is available on the data link
How to make the maps public
Ushbot
@ushbot
Dec 07 2017 12:18
[vishnu_rao] hi
[David Losada, Ushahidi] hi, I see you’ve got ~50 published posts there now, but I don’t see that the location data for those posts is public. Have you by any chance marked the location field as private in the survey definition?
[vishnu_rao] oh let me check
Ushbot
@ushbot
Dec 07 2017 12:26
[vishnu_rao] thank you!
[vishnu_rao] yes it worked!
[vishnu_rao] you saved us
[David Losada, Ushahidi] :) glad it worked, all the best wishes from us, thank you for using our software!
[vishnu_rao] great software. excellent!
Cam Macdonell
@cmacdonell
Dec 07 2017 14:55

Hi @rjmackay, when I use the nginx-site.conf from https://github.com/ushahidi/platform-release/blob/master/dist/nginx-site.conf everything gives a 403 forbidden.

When I tweak the default /etc/nginx/sites-enabled/default on ubuntu to work with ushahidi-platform, the / route shows json, but eveything else is 404

Ushbot
@ushbot
Dec 07 2017 15:04
[David Losada, Ushahidi] @cmacdonell note that file is intended for serving both api and client under the same virtual host name . Is that what you want?
[David Losada, Ushahidi] it sounds as if you are doing a setup of the API only, in that virtual host
Koda521
@Koda521
Dec 07 2017 16:04
Hello there:) I am trying to set up the latest release of ushahidi on my local server. I followed the instructions, but get an error when I run the database migrations (using migration paths
  • /Applications/MAMP/htdocs/platform/migrations
    warning no environment specified, defaulting to: ushahidi, There was a problem connecting to the database: SQLSTATE[HY000]). Accessing my localhost I only get "sorry something went wrong". If someone has an idea please let me know!
Ushbot
@ushbot
Dec 07 2017 16:18
[David Losada, Ushahidi] Hi @Koda521 did you create the .env file with your database server connection details?
Koda521
@Koda521
Dec 07 2017 16:23
Yes, it looks like this: DB_HOST=<127.0.0.1>
DB_NAME=<localhost>
DB_USER=<root>
DB_PASS=<root>
DB_TYPE=MySQLi
DB_SOCKET = /Applications/MAMP/tmp/mysql/mysql.sock
Ushbot
@ushbot
Dec 07 2017 16:27
[David Losada, Ushahidi] mm I’m not sure connection through socket will work.. try DB_HOST=127.0.0.1 ?
Koda521
@Koda521
Dec 07 2017 16:39
If I remove DB_Socket, I get: Access denied for user 'root'@'localhost' (using password: YES). But with "mysql -u root -p" it is possible to login.
Ushbot
@ushbot
Dec 07 2017 16:41
[David Losada, Ushahidi] what about DB_NAME , did you create a database?
Koda521
@Koda521
Dec 07 2017 16:44
Yes, I created one. It shows the same result in the browser.
Ushbot
@ushbot
Dec 07 2017 16:48
[David Losada, Ushahidi] how about trying to log in with “mysql -h 127.0.0.1 -u root -p” . does that work too?
Koda521
@Koda521
Dec 07 2017 16:49
No, it doesn't
Ushbot
@ushbot
Dec 07 2017 16:51
[David Losada, Ushahidi] so that’s why .. need to make sure that the port is open and that the user ‘root’@‘127.0.0.1’ has the correct password set
Koda521
@Koda521
Dec 07 2017 17:20
Okay thank you very much. I will try that.
Cam Macdonell
@cmacdonell
Dec 07 2017 18:30
david, I only want to serve the API from this host
If someone has an nginx configuration to serve the API over https, I would be greatly appreciative.