These are chat archives for ushahidi/Community

15th
Jan 2018
Ushbot
@ushbot
Jan 15 2018 11:42
[Pires Nogueira] Hello
Ushbot
@ushbot
Jan 15 2018 14:07
[David Losada, Ushahidi] yea, that JSON document looks good
[David Losada, Ushahidi] did you install client and backend separately? or did you use the pre-built bundle? since we can only be online for a few minutes at a time, it would really help if you detailed all the steps you’ve taken for your setup
[David Losada, Ushahidi] that way we can minimise the back and forth
Ushbot
@ushbot
Jan 15 2018 14:32
[Pires Nogueira] Yes, I installed
[Pires Nogueira] Are you there?
[David Losada, Ushahidi] yes, can you please detail what you have done?
[Pires Nogueira] Yes
[David Losada, Ushahidi] what did you exactly download ?
[Pires Nogueira] I downloaded first the platform from https://github.com/ushahidi/platform.git
[David Losada, Ushahidi] ok, and then the client also separately?
Ushbot
@ushbot
Jan 15 2018 14:37
[Pires Nogueira] yes
[David Losada, Ushahidi] ok, so it looks like the platform is working for you
[David Losada, Ushahidi] because you can see that JSON document when accessing /api/v3/config
[Pires Nogueira] Yes
[David Losada, Ushahidi] for the client, did you create a separate virtual host in apache?
[Pires Nogueira] yes
[David Losada, Ushahidi] ok, so you adjusted BACKEND_URL to point to your platform URL
[David Losada, Ushahidi] and then run “gulp build” ?
[David Losada, Ushahidi] brb
Ushbot
@ushbot
Jan 15 2018 14:43

[Pires Nogueira] So like a told you, my dns it isn't work now and I'm using my server ip to run the application.
I use the ip to point the BACKEND_URL.

Yes I runned gulp build after that

[Pires Nogueira] I'm here
Ushbot
@ushbot
Jan 15 2018 14:51
[David Losada, Ushahidi] so you set BACKEND_URL=http://192.168.33.110 and http://192.168.33.110/api/v3/config is working?
[David Losada, Ushahidi] are both those statements true?
[Pires Nogueira] The http://192.168.33.110 and http://192.168.33.110/api/v3/config is not working
[David Losada, Ushahidi] ok so what is the URL for platform that is working?
Ushbot
@ushbot
Jan 15 2018 15:04
[Pires Nogueira] http://199.193.6.245
Ushbot
@ushbot
Jan 15 2018 15:13
[Pires Nogueira] Hello
[David Losada, Ushahidi] so you set BACKEND_URL=http://199.193.6.245 and ran gulp build?
[David Losada, Ushahidi] http://199.193.6.245/api/v3/config doesn’t seem to be working
[David Losada, Ushahidi] so unfortunately your platform setup is actually broken
[Pires Nogueira] Run the http://199.193.6.245
[David Losada, Ushahidi] yea, that works but not the other necessary URLs , maybe a problem with the .htaccess file in platform
[David Losada, Ushahidi] it would be good to see the .htaccess file
[David Losada, Ushahidi] seems to be fine
[David Losada, Ushahidi] and the virtual host config?
[David Losada, Ushahidi] it looks like you are missing the section that allows .htaccess to override certain configurations

[David Losada, Ushahidi] ```

<Directory /var/www/txekaserver.com/public_html/platform/httpdocs>
AllowOverride All
</Directory>
```

[David Losada, Ushahidi] something like that
[Pires Nogueira] Let me add that
Ushbot
@ushbot
Jan 15 2018 15:27
[David Losada, Ushahidi] hopefully that fixes it, make sure to check http://199.193.6.245/api/v3/config
[David Losada, Ushahidi] I’ve got to jump out now
[David Losada, Ushahidi] good luck!
[Pires Nogueira] You will back?
[Pires Nogueira] Today?
[David Losada, Ushahidi] I’ll do my best, but I can’t promise, we’ve got a full agenda here
[Pires Nogueira] I understand, but I'll appreciate if you back today.
Ushbot
@ushbot
Jan 15 2018 15:56
[Pires Nogueira] I'm in, but i can't se the Map
[Pires Nogueira] How this version Work?
Ushbot
@ushbot
Jan 15 2018 18:21
[David Losada, Ushahidi] it should work
[David Losada, Ushahidi] if you open the error console in the browser, do you see errors there?
Ushbot
@ushbot
Jan 15 2018 21:43
[David Losada, Ushahidi] ah ok, check the htaccess in the client virtual host, and that you also have the appropriate AllowOverride section in the virtual host config