These are chat archives for ushahidi/Community

18th
Sep 2018
Ushbot
@ushbot
Sep 18 2018 09:41 UTC
[David Losada, Ushahidi] the dialog is a bit confusing sometimes @qovnika . are you sure it is rejecting your credentials? or maybe asking you to update your username?
Ushbot
@ushbot
Sep 18 2018 10:23 UTC
[Staicy Gitau, Ushahidi] Hey @vixadd thanks for reaching out. We are actually planning out some activities for our Open Source Community for this month of October and would love if you could participate! How does that sound? Please share your email address with me and we could discuss further?
Ushbot
@ushbot
Sep 18 2018 11:57 UTC
[Invoq John Majone] Hi, I just finished installing ushahidi on ubuntu. However, when I go to the landing page, I cannot login for some reason, using admin as both username and password. Please tell me; is there something I'm doing wrong or is it a known issue? Thanks.
qovnika
@qovnika
Sep 18 2018 12:07 UTC
Hi @ushbot, It just says Login Failed. Check your email and password. That's all. And then on the Network tab, I can see that an oauth/token tried to communicate with the server but returned 400 as the status code.
poVoq
@poVoq
Sep 18 2018 14:04 UTC
I have the same issue. Since I completely wiped and reinstalled the Docker images. With a previous installation upgraded it was actually working.
I suspect it might be related to mcrypt, php7.2 and ubuntu18.04 (I am using the QuantumObject docker images)
Ushbot
@ushbot
Sep 18 2018 14:39 UTC
[David Losada, Ushahidi] thank you @poVoq , @qovnika how did you install? did you also use a docker image?
poVoq
@poVoq
Sep 18 2018 14:44 UTC
The previous docker images worked fine on my setup (traefik as reverse proxy) so it must be either a change in the Ushahidi codebase during the last couple of months, or the recent upgrade of the QuantumObject docker images (they has some issues making it run with Ubuntu18.04 due to the removal of mcrypt in php7.1
Ushbot
@ushbot
Sep 18 2018 14:49 UTC
[Invoq John Majone] I installed following the instructions for installing on a linux server. I downloaded the files using wget and installed by following the instructions from https://www.ushahidi.com/support/install-ushahidi on open source installation. However I can access the landing page, but cannot login using "admin" as both username and password.
poVoq
@poVoq
Sep 18 2018 14:51 UTC
ok, so that sounds like this issue isn't related to the docker images. Is there a logfile I could check. /var/log/ doesn't give me much in this case and the system log also looks fine
Ushbot
@ushbot
Sep 18 2018 15:05 UTC
[David Losada, Ushahidi] @poVoq , re:logs that depends much on how QuantumObject packaged the images and what version they packaged. In any case, it should be under whatever folder inside the container they installed the API code, then either the storage/logs subfolder (newer version) or the application/logs subfolder (older versions)
[David Losada, Ushahidi] I will give it myself a try and try to reproduce your problems, @poVoq and @qovnika
poVoq
@poVoq
Sep 18 2018 15:06 UTC
the Quantum object docker images were just updated to the latest ushahidi release on github
I'll check the logs there
Ushbot
@ushbot
Sep 18 2018 15:13 UTC
[Invoq John Majone] No it doesn't relate to the docker images... I cannot login after installation is all. When I try to signup as a new user it says there was an error while trying to register.
poVoq
@poVoq
Sep 18 2018 15:18 UTC
Hmm strange, the is only an applications/logs folder and it is empty
ahh, looks like the QuantumObject guy is just working on it? https://github.com/QuantumObject/docker-ushahidi-platform/tree/fix_issue
Jose Antonio Prado
@joseantoprado_twitter
Sep 18 2018 15:23 UTC
Hi! I wonder if there are any good news regarding sharing posts to facebook, with some way of fetching image to display a preview… thank you!
poVoq
@poVoq
Sep 18 2018 15:40 UTC
nope with the new docker image I still can't log in. Even after trying to wipe the database first
the funny thing is that I can sign up as a new user just fine. but then I also can't log in with that user
however if I try to sign-up again with the same email adress, it says already in use, so at least the sign up communicates with the database fine
poVoq
@poVoq
Sep 18 2018 16:11 UTC
ahh, just a thought... would a platform-client based on the latest develop branch have problems interacting with the v3.12.3 release?
I noticed that the v3.12.3 release seems to be branched off the "production" branch?
with release I mean of the plaform api
Ushbot
@ushbot
Sep 18 2018 19:37 UTC
[loyalty_eli] Hello :) I am trying to install latest version of Ushahidi, using cPanel. I followed the steps, as they are in the documentation, but when I run ./bin/phinx migrate -c application/phinx.php I receive error that there is no /bin/phinx. Can you please assist?