Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Frank Kumro Jr
    @fkumro
    def x do <enter> and the next line doesn't indent. also end isn't being inserted.
    fr1zle
    @fr1zle
    Hmm that doesnt sound right. Let me check
    image.png
    there should be a snippet that does it... otherwise it seems to indent correct for me. but it won't insert "end" if you don't choose the snippet
    Frank Kumro Jr
    @fkumro
    if I select the snippet all is well, if I don't then it doesn't indent. The lack of end makes sense.
    fr1zle
    @fr1zle
    Ok, weird... It does for me. also when I add the "end" it does indent it as well... hmm
    Frank Kumro Jr
    @fkumro
    my settings file is small
    {
        "workbench.colorTheme": "One Dark Pro",
        "workbench.iconTheme": "vscode-icons",
        "vim.disableAnnoyingNeovimMessage": true,
        "editor.fontFamily": "'Panic Sans'",
        "editor.fontSize": 16,
        "editor.tabSize": 2,
        "editor.renderWhitespace": "all",
        "editor.cursorStyle": "block-outline",
        "editor.tabCompletion": true,
        "editor.rulers": [
            80, 100
        ],
        "editor.autoIndent": true,
        "editor.cursorBlinking": "phase"
    }
    fr1zle
    @fr1zle
    Hmm, did you try to disable the vim plugin?
    Frank Kumro Jr
    @fkumro
    defmodule works without using the snippet
    fr1zle
    @fr1zle
    just to rule if out
    Frank Kumro Jr
    @fkumro
    yes I tried, no luck
    fr1zle
    @fr1zle
    image.png
    export const configuration: vscode.LanguageConfiguration = {
      wordPattern: /:?\w+[\.\w+]*/g,
      indentationRules: {
        increaseIndentPattern: new RegExp('(after|else|catch|rescue|fn|^.*(do|<\\-|\\->|\\{|\\[))\\s*$'),
        decreaseIndentPattern: new RegExp('^\\s*((\\}|\\])\\s*$|(after|else|catch|rescue|end)\\b)')
      }
    };
    this looks correct to me
    it hasn't been changed for a while as well
    Only thing i can think of: Hit Ctrl+Shift+P and Enter "start" it should give you the option to start elixir sense in the current workspace
    btw: are you running the insider build?
    Frank Kumro Jr
    @fkumro
    sorry, had a call and then dumped water all over my desk
    Version 1.16.0
    Commit 787b31c0474e6165390b5a5989c9619e3e16f953
    Date 2017-09-06T16:19:37.192Z
    Shell 1.7.3
    Renderer 58.0.3029.110
    Node 7.9.0
    Architecture x64
    I started elixir sense as well
    Frank Kumro Jr
    @fkumro
    Yea, something isn't right with my setup. No autocomplete after I type Enum. like it does in the repo examples
    fr1zle
    @fr1zle
    Hmm can you open the developer tools in vs code and check the console for errors?
    Frank Kumro Jr
    @fkumro
    Nothing in the console
    fr1zle
    @fr1zle
    You did open the one looking like the chrome Dev tools, right? Via the help menu?
    Frank Kumro Jr
    @fkumro
    Yep
    Screenshot at 2017-09-14 15-11-07.png
    fr1zle
    @fr1zle
    Weird, you do have a mix project open, right?
    Frank Kumro Jr
    @fkumro
    correct, and its been compiled
    elixir 1.5.1
    actually I am 1 folder above it
    and now it works
    fr1zle
    @fr1zle
    Ohhh..
    I see, we still have an issue for this
    Frank Kumro Jr
    @fkumro
    So I didn't waste your time :)
    fr1zle
    @fr1zle
    #82
    No it's fine ;D pretty reasonable to expect this to work.
    Frank Kumro Jr
    @fkumro
    404s on the #82 link
    fr1zle
    @fr1zle
    fr1zle/vscode-elixir#82
    Sung-Chul Lee
    @sclee15
    how can i get genserver related return intelisense? such as {:reply, message, state}
    kk
    @0radek
    hi
    I'm having some issues with vscode-elixir namely the autocomplete and stuff from the gifs on the extensions page. all that stuff doesn't work
    fr1zle
    @fr1zle
    @ScaryWolfMan are you inside a mix project?
    Adam Bellinson
    @djthread
    Hi! So who can tell me why my code commenting function in elixir source files are using a double slash instead of the proper pound symbols?
    fr1zle
    @fr1zle
    Hey @ctrlShiftBryan I will look into it
    fr1zle
    @fr1zle
    @djthread sorry, wanted to ping you. I cant reproduce this in .ex and .exs files. do you mind opening an github issue with more details?
    Adam Bellinson
    @djthread
    I uninstalled and reinstalled the "PHP IntelliSense" extension and it seems to be working now . .
    fr1zle
    @fr1zle
    @djthread glad to hear!
    Jess Haddow
    @jhaddow
    Anybody have any tips on how to diagnose problems with the extension? It seems to randomly stop working and the blue progress animation at the top of the screen goes on inifinitely.
    and intellisense stops working
    fr1zle
    @fr1zle
    You can open up dev tools: Help -> Developer Tools