Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Michael Sproul
    @michaelsproul

    Hey, anyone using Vyper on macOS have any tips for resolving errors like this one: "OSError: Cannot load native module 'Crypto.Hash._keccak'"?

    It was initially breaking my viper binary and make test, but now viper seems to work ok (manual import of Crypto.Hash.keccak in a REPL also works). Full stack trace: https://gist.github.com/michaelsproul/b640555d7b14ee18aaa4ef61b68328a9

    James Ray
    @jamesray1
    I'm confused, what's the difference between vyper and viper?
    It seems like you changed the name of the repo recently?
    @DavidKnott there are two gitter rooms, this one and https://gitter.im/ethereum/viper, but the wiki for both direct to https://github.com/ethereum/vyper.
    James Ray
    @jamesray1
    It seems like https://gitter.im/ethereum/viper should be archived so that nobody can post on it.
    However, the activity for the repo shows on https://gitter.im/ethereum/viper, but not this room.
    Basically we have two rooms, but only one is necessary, since we have only one repo.
    (Searching for "viper" in the Ethereum Github organization returns no result, while searching for "vyper" returns one.
    James Ray
    @jamesray1
    Jacques
    @jacqueswww
    Viper was renamed to Vyper
    So I agree, we should only have this channel from now on
    James Ray
    @jamesray1
    :thumbsup:
    william bright
    @whb07
    @michaelsproul get it solved?
    mattasp
    @mattasp
    It's not clear where to find ethereum 2.1.3 using google, link anyone?
    I'd like to dive into sharding: error: ethereum 2.3.0 is installed but ethereum==2.1.3 is required by set(['viper'])
    DavidKnott
    @DavidKnott
    @mattasp Which repo are you pulling down from?
    william bright
    @whb07
    if you have a clean setup @mattasp i got 3 or 4 lines of stuff to 100% get all dependencies installed
    lemme know
    im going to work on a cleaner install guide this weekend
    El De-dog-lo
    @fubuloubu
    We should check to see if >2.2.0 works
    mattasp
    @mattasp
    @whb07 Yes it's a clean setup, I would like your 3,4 lines setup.
    mattasp
    @mattasp
    Could it be some naming issues? ex: viper => vyper. I see that sharding/setup.py is accessing for dependencies in http://github.com/ethereum/pyethereum/tarball/%s#egg=ethereum-9.99.9' % pyethereum_ref line 28.
    mattasp
    @mattasp
    DEPENDENCY_LINKS.append('http://github.com/ethereum/viper/tarball/%s#egg=viper-9.99.9' % viper_ref)
    Michael Sproul
    @michaelsproul
    @whb07 regarding the issues with pycryptodome I was having, they ended up disappearing once I installed v3.4.7 from source. If I get time I'll dig deeper to see if it was updating to v3.4.7 or building from source that fixed it (as an aside, in the process I ended up depending on ethereum v2.3.0 from vyper, and it seemed to work fine).
    william bright
    @whb07
    ive spun up like 20 ~30 ubuntu servers from 16.04 to 17.10