Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 22 17:13
    Simounet converted_to_draft #4969
  • Jan 22 16:52
    myuseraccount commented #4964
  • Jan 22 16:50
    myuseraccount commented #4964
  • Jan 22 13:22
    Simounet commented #4969
  • Jan 22 13:18
    Kdecherf commented #4969
  • Jan 22 13:17
    Kdecherf labeled #4969
  • Jan 22 13:00
    Simounet opened #4969
  • Jan 22 12:50
    j0k3r edited #4965
  • Jan 22 12:50

    j0k3r on master

    Bump friendsofphp/php-cs-fixer … Merge pull request #4967 from w… (compare)

  • Jan 22 12:50

    j0k3r on composer

    (compare)

  • Jan 22 12:50
    j0k3r closed #4967
  • Jan 22 10:58

    j0k3r on npm_and_yarn

    (compare)

  • Jan 22 10:58

    j0k3r on master

    Bump postcss-loader from 4.1.0 … Merge pull request #4966 from w… (compare)

  • Jan 22 10:58
    j0k3r closed #4966
  • Jan 22 10:56

    j0k3r on master

    Translated using Weblate (Chine… Translated using Weblate (Galic… Translated using Weblate (Galic… and 1 more (compare)

  • Jan 22 10:56
    j0k3r closed #4968
  • Jan 22 06:32
    j0k3r labeled #4968
  • Jan 22 06:32
    weblate opened #4968
  • Jan 22 03:44
    dependabot[bot] review_requested #4967
  • Jan 22 03:44
    dependabot[bot] review_requested #4967
Thomas Citharel
@tcitworld
oh no, wait
we had build a special apk for devices with Android < 5.0 in 2.2
Jibran Shaikh
@js-d-coder
is there a way to disable certain features of wallabag and not install those particular dependencies?
Thomas Citharel
@tcitworld
that's the HTTP client, so not really
and also supporting android < 5 leads to all kinds of TLS-related bugs unfortunately
Dmitriy Bogdanov
@di72nn
@silberzwiebel I was thinking about making a branch compatible with Android ~4 (because there's still a lot of old checks that should be removed from master). okhttp can be replaced with the still maintained 3.12.*. No estimates though.
Jibran Shaikh
@js-d-coder
I am having multiple php versions installed on ubuntu 20. I have just downloaded the static build and trying to install it by make install but it is failing by saying that composer.phar is not install, which is incorrect. I run composer.phar manually on cli without any errors.
The Doctor
@virtadpt
I find that you have to run Composer with the version of PHP that you intend to run the application under.
3 replies
I'm running Wallabag under PHP v7.3 (Ubuntu 18.04 LTS), so I had to do php-7.3 composer.phar to get it to work.
Also, try running the scripts/install.sh script instead of using the makefile. If nothing else, you'll get some clearer errors to help troubleshoot.
Dmitriy Bogdanov
@di72nn
@js-d-coder if by static build you mean one of these, then you don't need to run make - see this.
Jibran Shaikh
@js-d-coder
managing multiple php versions is very difficult. I am thinking about writing my own Pocket alternative in Node.js
Jérémy Benoist
@j0k3r
:-D
Robert
@metbril
I created a trial account on wallabag.it and started an import from Pocket. It showed ~1900 items to be imported. It's been a few hours since, and no items show. How long does it usually take to import a Pocket account?
Robert
@metbril
Anyone?
rtevans
@rtevans01_gitlab
My pocket articles haven't imported either and it's been a month. I have premium too.
Robert
@metbril

My pocket articles haven't imported either and it's been a month. I have premium too.

@rtevans01_gitlab Thanks for the info. And the support is also unresponsive. Not a service I want to spend my money on. Too bad. Because that would be a way to support the developer.

matrixbot
@matrixbot
nicofrand Robert (Gitter): and rtevans (Gitter) I don't know if you heard back from the support (I pinged them) but : https://twitter.com/wallabagit/status/1322167620267843586
rtevans
@rtevans01_gitlab
@matrixbot Is still tells me it's "queued" after trying to import, which is the same message it's always given me.
@metbril I even trying importing my Pocket articles as Firefox bookmarks but that didn't work either.
matrixbot
@matrixbot
nicofrand Did you try to contact them through any of the ways listed here: https://www.wallabag.it/en/contact?
Jibran Shaikh
@js-d-coder

My pocket articles haven't imported either and it's been a month. I have premium too.

more reason to write new Pocket alternative

romu
@romu70
Hello everyone. I'm struggling at upgrading my Postgres instance. As I run Postgres in a container, I'm trying to export my DBs from the old Postgres, and import the SQL files in the new Postgres. I do this through Adminer. When I import my wallabag.sql file, I get the following error : Error in query (7): ERROR: schema "wallabag" does not exist at character 14 which is indeed the first SQL instruction to add a data. Any help?
romu
@romu70
Managed to get this done by using pg_dump / psql, works way better than Adminer.
matrixbot
@matrixbot
haldorsen Hi guys! Is there any way to edit tags on saved articles on the desktop interface? It's easy on mobile, but I can't figure it out on the web desktop interface.
matrixbot
@matrixbot
Paul there is
Paul there are trashbins on each tag for me
Paul and a menu on the left with "add tag"
matrixbot
@matrixbot
haldorsen Paul: I think I might have worded myself badly. Say I save an article, and later on I want to add some tags to this article entry. How do I do that? On each article I see "Toggle Mark As Read", "Toggle Starred" and "Delete".
haldorsen But no option to add or edit tags.
matrixbot
@matrixbot
Paul when I open the article on the web, there is a menu on the left
matrixbot
@matrixbot
haldorsen Oh yes! I don't understand why I didn't see that.
matrixbot
@matrixbot

deankayton Hi all. I am thinking of installing this on a pretty large internal network (listening on public ip) so that community members part of the network can save their content from anywhere, but in case the internet goes down at home, they should still be able to access the server internally.

Was wondering if there are any ways to save articles to the wider community.

Hoping to create a community run digest.

With that I would also potentially need to censor potentially explicit content though. Is this at all something that has been explored with this software?

The Doctor
@virtadpt
That's a really interesting question.
Jérémy Benoist
@j0k3r
@deankayton not aware of something like that
matrixbot
@matrixbot

deankayton Wondering if I can maybe hook into some kind of API and allow a user to submit an article, then host approved articles some standard way.

Are the articles plain html in the end? Maybe a browser plugin that uploads the current article or something.

Could maybe even authenticate against the service using wallabag credentials, giving it permission to read the content a user chooses to submit.

Just spit-balling. Would be cool if that form of authentication could happen. Similar to how you can authenticate against Netlify with github credentials, allowing netlify to view selected repositories.

Micha-Btz
@Micha-Btz
Hey
I have installed wallabag in a webhoster environment. But it is not working. The error log show:AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Symfony\\Component\\Validator\\Exception\\MappingException: The mapping file "/wb.mdomann.tk/vendor/symfony/symfony/src/Symfony/Component/Form/Resources/config/validation.xml" does not exist in /var/www/vhosts/web46819.ssd-space.de/wb.mdomann.tk/vendor/symfony/symfony/src/Symfony/Component/Validator/Mapping/Loader/FileLoader.php:38\nStack trace:\n#0 /var/www/vhosts/web46819.ssd-space.de/wb.mdomann.tk/vendor/symfony/symfony/src/Symfony/Component/Validator/ValidatorBuilder.php(277): Symfony\\Component\\Validator\\Mapping\\Loader\\FileLoader->__construct('/wb.mdomann.tk/...')\n#1 /var/www/vhosts/web46819.ssd-space.de/wb.mdomann.tk/vendor/symfony/symfony/src/Symfony/Component/Validator/ValidatorBuilder.php(303): Symfony\\Component\\Validator\\ValidatorBuilder->getLoaders()\n#2 /var/www/vhosts/web46819.ssd-space.de/wb.mdomann.tk/var/cache/prod/appProdProjectContainer.php(5964): Symfony\\Component\\Validator\\ValidatorBuilder->getValidator()\n#3 /var/www/vhosts/web46819.ssd-space.de/wb.mdoma...\n'
I have searched for a solution and it it mentoined in a github issue, but sadly without solution.
Do you have an hint what can I do?
Simon Alberny
@Simounet
Hi @Micha-Btz which is your wallabag's version? How did you set it up (source, package)? Can you give the issue you found please?
Micha-Btz
@Micha-Btz
I use version 2.3.8 installed with the doc from your website for shared hosting. https://doc.wallabag.org/en/admin/installation/installation.html#on-shared-hosting
This is the issue wallabag/wallabag#3735
Simon Alberny
@Simounet
So you dropped the package on your shared server, edited the parameters.yml, created your first user then tried to connect through the browser and get this missing file error. Is it correct @Micha-Btz ?
Micha-Btz
@Micha-Btz
Yes, but the file is there and the install was fine.
matrixbot
@matrixbot
simounet Micha-Btz (Gitter): I'm trying to reproduce your issue. What is your php version (even if I'm pretty confident that this is not related).
Micha-Btz
@Micha-Btz
I have tested with 7.2 and 7.3
Simon Alberny
@Simounet
You didn't have any trouble creating the first user?
Micha-Btz
@Micha-Btz
no, run fine
Simon Alberny
@Simounet
How did you defined the vhost? What is the path you are trying to reach (I don't need the domain, just the last part of the URL)?