Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jul 23 07:27
    oupala commented #3070
  • Jul 23 07:25
    oupala commented #3070
  • Jul 23 04:33
    weblate synchronize #5187
  • Jul 23 03:43
    Anant-1 reopened #1189
  • Jul 23 03:43
    Anant-1 closed #1189
  • Jul 23 03:42
    Anant-1 opened #1189
  • Jul 22 15:34
    weblate opened #1188
  • Jul 22 15:34
    weblate synchronize #336
  • Jul 22 13:32
    oupala opened #5352
  • Jul 22 08:48
    bourvill commented #347
  • Jul 22 08:45
    blacs30 commented #347
  • Jul 22 08:44
    blacs30 commented #347
  • Jul 22 08:39
    bourvill commented #347
  • Jul 22 08:26
    blacs30 commented #347
  • Jul 22 07:06
    oupala commented #3070
  • Jul 22 07:05
    oupala commented #3070
  • Jul 22 02:02
    dependabot[bot] labeled #1187
  • Jul 22 02:02
    dependabot[bot] opened #1187
  • Jul 22 02:02

    dependabot[bot] on gradle

    Bump media from 1.3.1 to 1.4.0 … (compare)

  • Jul 22 02:02
    dependabot[bot] labeled #1186
Patg
@patgg
arf, it was something like the bbegining and te end os the file which was bad. sorry for noise.
kdecherf
@kdecherf:matrix.org
[m]
nicofrand: perfect, thx
Henry
@henry:badly.co
[m]
Hi, just a question, Is it possible to install wallabag on a shared web hosting service with no root access?
Erik
@erikh:matrix.org
[m]

Hello, I've been getting an exception every time I try to add a URL via the mobile app. I'm using wallabag.it for my server. Here's the stacktrace: https://paste.ee/p/qLKtS

Is this a known issue or should I file a new GitHub issue?

I was originally getting an exception that I discovered was due to my subscription on wallabag.it expiring. I renewed it and was able to add URLs via the Firefox extension, but have now been getting this exception on mobile.
Dmitriy Bogdanov
@di72nn
Hello, @erikh:matrix.org! Follow the instructions in the first half of this comment.
1 reply
tandy
@tandy1000:matrix.org
[m]
hey im having an issue serving wallabag with caddy 2, is anyone having success with that in here?
a10
@a10software
hey team :wave: I just installed Wallabag via Docker and I'm really happy with this product! I'm quite glad I gave it a shot. I have a question about contributing back to the project: I noticed that a lot of the English copy is a bit rough around the edges. Can I just submit a PR against messages.en.yml for my suggested changes, or do I have to do anything more? I noticed that the translations have a "Translated using Weblate" as a recent comment which makes me think that they are being generated automatically. I want to make sure my submissions don't break anything, nor do they get overwritten
kdecherf
@kdecherf:matrix.org
[m]
@a10software hey :)
We now use weblate to ease contributions around translations, so you can contribute to wallabag on weblate and it will automatically push a PR on github
Kevin
@kn100
Hi, I have Wallabag running inside Docker and I am trying to front it with nginx. I want it to run on a subdirectory (so I can access it via domain.com/wallabag/). I can now hit wallabag inside docker, but wallabag redirects me to domain.com/login. Is there some config variable where I can specify a different approot?
Kevin
@kn100
Nevermind, I solved it a different way!
taha
@taha:matrix.org
[m]
Hi all,
I was migrating Wallabag between hosts, and need to install v2.3.8 on the new host to match the old one. But it seems "make install" automatically triggers a checkout of the latest release. Any way to stop it from doing that (other than manually git checking out the earlier release)? Reason I'm asking is because I'm also writing an Ansible role to install Wallabag (will share on codeberg.org/ansible when done) and this behaviour of "make install" is seriously hindering my flow ;-)
I found a comment from another user noting this same behaviour on the issue tracker https://github.com/wallabag/wallabag/issues/5197#issuecomment-815267031
taha
@taha:matrix.org
[m]
Following up,
it seems it's not possible to cleanly checkout an older release after "make install" has auto-updated the local repo. When running any console command, I get PHP fatal errors. The errors disappear if I git checkout 2.4.2 first. Unless there's some way to stop "make install" from always using the latest release, it seems the only way to install a specific v2 release is to install from the precompiled tarballs?
2 replies
Basically just run the following:
export ENV=prod
SYMFONY_ENV=$ENV $COMPOSER_COMMAND install --no-dev -o --prefer-dist
php bin/console wallabag:install --env=$ENV
And make sure composer is installed
Maxwell
@gotmax:matrix.org
[m]
The makefile really just runs this script which just has some extra sanity checks built-in.
taha
@taha:matrix.org
[m]
Maxwell: Thank you so much, that was a very nice explainer! That solves that :-)
mishra
@mishra:matrix.org
[m]

Hi everyone! I'm brand new to wallabag and unfortunately I'm having some trouble with the initial spinup of the docker installation. I've searched through the chat history here, along with the github repo, and can't pinpoint the source of this error.

I'm adding wallabag to an existing docker-compose, running on a Synology (Linux) with docker version 10.09.8. DB is a mariadb, reverse proxy is Traefik. I've tried folder permission modifications, removed the forward auth on the reverse proxy. I'm sure it's something stupid on my end.

Logs here: https://privatebin.net/?0c1bfd4679a95fe7#DSEBW33PXApj5E7xTBKWgkT33SNFbbHr5XjKT8iMc9P7

^ This is from two startup attempts. The second time, I waited, then tried to go to the URL, and got an error 500 (can be seen in logs too). My MariaDB has no data inside the newly created table for wallabag. The mounted volume has no files in it either

1 reply

docker-compose code

wallabag:
    image: wallabag/wallabag
    container_name: ourgreatfamilyweb-Wallabag
    environment:
      # - MYSQL_ROOT_PASSWORD=wallaroot
      - SYMFONY__ENV__DATABASE_DRIVER=pdo_mysql
      - SYMFONY__ENV__DATABASE_HOST=192.168.14.251
      - SYMFONY__ENV__DATABASE_PORT=3306
      - SYMFONY__ENV__DATABASE_NAME=wallabag
      - SYMFONY__ENV__DATABASE_USER=wallabag
      - SYMFONY__ENV__DATABASE_PASSWORD=$WALLABAG_DB_PASS
      - SYMFONY__ENV__DATABASE_CHARSET=utf8mb4
      - SYMFONY__ENV__MAILER_HOST=$SMTP_host
      - SYMFONY__ENV__MAILER_USER=$SMTP_email
      - SYMFONY__ENV__MAILER_PASSWORD=$SMTP_PW
      - SYMFONY__ENV__FROM_EMAIL=$SMTP_email
      - SYMFONY__ENV__DOMAIN_NAME=https://wallabag.ourgreatfamilyweb.com
      - SYMFONY__ENV__SERVER_NAME="ourgreatfamilyweb"
    ports:
      - 8090:80
    volumes:
      - $CLOUDDIR/wallabag/images:/var/www/wallabag/web/assets/images
    restart: unless-stopped
    networks:
      - traefik_external
    labels:
      - "traefik.enable=true"
      ## HTTP Routers
      - "traefik.http.routers.wallabag-rtr.entrypoints=https"
      - "traefik.http.routers.wallabag-rtr.tls=true"
      - "traefik.http.routers.wallabag-rtr.rule=Host(`wallabag.$DOMAINNAME`)"
      ## Middlewares
      - "traefik.http.routers.wallabag-rtr.middlewares=chain-no-auth@file"
      ## HTTP Services
      - "traefik.http.routers.wallabag-rtr.service=wallabag-svc"
      - "traefik.http.services.wallabag-svc.loadbalancer.server.port=80"

(domain changed for privacy)

taha
@taha:matrix.org
[m]

Hi guys, another question, different issue. This is more of a would-be-nice-to-know, and not a show-stopper. Anyway, for the curious...

I attempted to upgrade a Wallabag v2.3.8 instance (installed using precompiled tarball) to a v2.4.2 install from source (both with the same PostgreSQL backend).
It did not work. To be honest, I did not really expect it to, it was more of a "let's try and see what happens" :-)

What happened was multiple errors during the doctrine:migrations:migrate step of the make update process: Cardinality violation: 7 ERROR: more than one row returned by a subquery.

My question is simply: is this what you would expect too? Or is there a way to switch an existing Wallabag installed using precompiled tarball to an install from source?

(And why would I want to do this? Primarily, I think it'd be easier to Ansiblify/script the upgrade steps of an install from source).

1 reply
Maxwell
@gotmax:matrix.org
[m]
:point_up: Edit: Basically just run the following:
export ENV=prod
SYMFONY_ENV=$ENV 
composer install --no-dev -o --prefer-dist
php bin/console wallabag:install --env=$ENV
:point_up: Edit: Basically just run the following:
export ENV=prod
SYMFONY_ENV=$ENV composer install --no-dev -o --prefer-dist
php bin/console wallabag:install --env=$ENV
taha
@taha:matrix.org
[m]
Maxwell: Not following any instructions, just experimenting. I was just curious whether it would be possible to "switch tracks" from pre-compiled install to source install. I might have complicated the issue for myself by upgrading at the same time. Just thought to ask, in case someone else had already considered it.
Oh, and btw, thanks to your help I've completed the Ansible role for Wallabag I was developing. Maybe someone else will find it useful: https://codeberg.org/ansible/wallabag
Strubbl
@Strubbl
it would be awesome to get a new android app release to the stores. this would make offline image caching work again besides a load of other fixes and dependency/translation updates
goodelyfe
@goodelyfe
Greetings all! Hope all is well.
I have pulled data from a wallabag instance. I grabbed the wallabag.sqlite file and transferred it into the data/db folder. The instance where I'm putting the old wallabag.sqlite file is in docker
I'm getting
500: Internal Server Error

An exception has been thrown during the rendering of a template ("An exception occurred while executing 'SELECT w0_.id AS id_0 FROM "wallabag_entry" w0_ WHERE w0_.user_id = ? AND w0_.is_starred = 1 GROUP BY w0_.id ORDER BY w0_.starred_at DESC' with params [1]: SQLSTATE[HY000]: General error: 1 no such column: w0_.starred_at").
Dmitriy Bogdanov
@di72nn
@nicosomb can you check why wallabag.it can't handle the creation of an annotation longer than 1000 characters (answers with HTTP 500) even though it should be able to handle 10k: wallabag/wallabag#3093
ploc
@ploc:matrix.gresille.org
[m]
I'm looking for documentation about the default created admin user on a fresh install of Wallabag. Can we set its login somewhere?
ploc
@ploc:matrix.gresille.org
[m]
How do we know what parameter can we pass to the create user fos cli? login, email, password, what else?
Edmund Kasprzak
@ekasprzak

Hi, I think there's some issue with exporting articles service (using app hosted by you/wallabag).
I'm trying to export my unread articles into epub so having this url:
https://app.wallabag.it/export/unread.epub?search_entry%5Bterm%5D=

and it ends with :
504 Gateway Time-out
nginx/1.14.2

Jez (he/him)
@jez:petrichor.me
[m]
I've only ever been able to export single articles from app.wallabag.it: trying to export more than that has timed out every time I've tried it.
I think ultimately the solution will be to switch from generating the export on the fly during the request and instead create a background export job that can be queued and then downloaded by the user when it's done, but I'm not really familiar with the source and how it's currently done.
Edmund Kasprzak
@ekasprzak
yup, exporting single article works. For multiple - it's been working for last few months that I;ve been using it - it stopped working yesterday or a day before
kdecherf
@kdecherf:matrix.org
[m]
Edmund Kasprzak
@ekasprzak
and I use it almost every day so it's not like sometimes it works and sometimes not - definitelly sth happened yesterday/day before yesterday
Edmund Kasprzak
@ekasprzak
Could you just let me know if someone is going to take a look on that (not pushing or demanding anything of course, it just breaks my daily routine with reading articles on ebook reader so I would like to know if I need to switch to another service for some time or maybe just some nginx server needs to be restarted and it will work back soon) ?
kdecherf
@kdecherf:matrix.org
[m]
@ekasprzak: for the async export feature there's no work planned for now but I may consider it in the future. For the error seen on app.wallabag.it there may be an infra change or a workaround available to the admin of the service, nicosomb
tandy
@tandy1000:matrix.org
[m]
I just retried trying to install wallabag, I used this guide https://www.garron.me/en/linux/install-wallabag-ubuntu-nginx-sqlite.html
it works kinda but .css / .js / assets dont load
i've found a bunch of people with the same issue but havent found a fix yet
domain_name: 'http://127.0.0.1:8010'
^ from app/config/parameters.yml
and the nginx conf port is 8010 too
Edmund Kasprzak
@ekasprzak
small update on "not being able to export multiple articles" - it only affects unread export. No problem with exporting to epub whole starred or some specific tag section. Nginx gateway timeout 504 happens ONLY when trying to export unread section.
kdecherf
@kdecherf:matrix.org
[m]
@ekasprzak: how many unread articles do you have?
Edmund Kasprzak
@ekasprzak
Tried going that road too and did attempts to export unread when I left there only 1 article (multiple attempts) and still nging 504 so I dont think that's the case here
hmm, looks like I was happy too soon - exporting starred (containing just 10 articles) is not working anymore. But I was able to export it 3 times (10 articles every time) and now it just stopped working. It's like I'm overloading some buffer or sth...