Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 07:41
    yguedidi commented #5790
  • Aug 08 23:42
    fisiognomico commented #262
  • Aug 08 19:52
    rakleed commented #5790
  • Aug 08 17:41
    yguedidi edited #5758
  • Aug 08 17:41
    yguedidi edited #5758
  • Aug 08 17:41
    yguedidi converted_to_draft #5758
  • Aug 08 17:38
    yguedidi commented #5914
  • Aug 08 17:36
    yguedidi synchronize #5758
  • Aug 08 14:30
    Kdecherf labeled #5924
  • Aug 08 14:30
    Kdecherf labeled #5924
  • Aug 08 14:26
    aiwo79 opened #5924
  • Aug 08 14:08
    yguedidi edited #5759
  • Aug 08 14:08
    yguedidi synchronize #5759
  • Aug 08 13:54
    yguedidi commented #5782
  • Aug 08 13:53
    yguedidi ready_for_review #5782
  • Aug 08 13:53
    yguedidi edited #5782
  • Aug 08 13:49
    yguedidi edited #5782
  • Aug 08 13:48
    yguedidi synchronize #5782
  • Aug 08 13:44
    Kdecherf commented #5784
  • Aug 08 13:44
    Kdecherf closed #5784
Cook1e_mr
@cook1e_mr:matrix.org
[m]
yeah but is that, just not for the stack?
so to pass to the postgres container?
TimeWalker
@timewalker:foxden.party
[m]
No, that is for the wallabag container I don't see that one in your yaml
Except I'm misunderstanding something 😀
Cook1e_mr
@cook1e_mr:matrix.org
[m]
its not there. i had it but that wasnt working either
so i removed it
but lets put it back in
and see what happens
ok get a different error now
let me look at that for a minute
Cook1e_mr
@cook1e_mr:matrix.org
[m]
Hi, still having problems https://pastebin.com/tJYmXaEf it seems to be saying it cant authenticate to the DBs
Cook1e_mr
@cook1e_mr:matrix.org
[m]
Hi, i have managed to work my way through a number of errors, however I am now getting the attached. https://pastebin.com/tknbr4Bt Does anyone know what configurations i need to change in the postgres DB to resolve this?
TimeWalker
@timewalker:foxden.party
[m]
Did you run /var/www/wallabag/bin/console wallabag:install --env=prod --no-interaction? The database does not get created automatically at first run. You have to run a command for it
2 replies
Cook1e_mr
@cook1e_mr:matrix.org
[m]
that maybe what i am missing
TimeWalker
@timewalker:foxden.party
[m]
Also as a precaution, I had issues with Android throwing error 500 and other setData errors. I had it fixed by going into the docker container at /var/www/wallabag and running chown -R nobody:nobody bin app/config vendor data web var to fix this from this issue link: wallabag/docker#145
TimeWalker
@timewalker:foxden.party
[m]
No, I don't recall seeing it in the docs. I had found it in a Github issue
Cook1e_mr
@cook1e_mr:matrix.org
[m]
well it is now in my notes, thanks
you don't happen to know how to migrate the sqlite db to postgres do you?
TimeWalker
@timewalker:foxden.party
[m]
Sorry, I don't know. When I installed the server, I immediately used postgres
1 reply
Cook1e_mr
@cook1e_mr:matrix.org
[m]
i assume in pgloader it will be something like load database
from sqlite:///data/wallabag/data/db.sqlite3
into postgresql://wallabag:PASSWORD@postgresql:5432/vaultwarden
WITH data only, include no drop, reset sequences
EXCLUDING TABLE NAMES LIKE '__diesel_schema_migrations'
ALTER SCHEMA 'wallabag' RENAME TO 'public'
;
TimeWalker
@timewalker:foxden.party
[m]
I haven't had time to enable redis yet. But it should technically be super easy according to the docker README: https://github.com/wallabag/docker#redis 🙂
Bruno Fontes
@brunofontes:matrix.brunofontes.net
[m]
Yes, Redis is probably super easy. Redis itself is easy (I've tried it once for a test)
Cook1e_mr
@cook1e_mr:matrix.org
[m]
so now im nervous of redis ha ha
Bruno Fontes
@brunofontes:matrix.brunofontes.net
[m]

I am going to tell the truth. My wallabag installation is not even working properly yet. I am getting a 500 error SQLSTATE[HY000]: General error: 1366 Incorrect string value: '\xFCrnber...' for column 'headers' at row 1 on certain websites, but I am using the last version and my DB (mysql) is using utf8mb4.

So I didn't tried anything else yet, as Redis.

1 reply
Bruno Fontes
@brunofontes:matrix.brunofontes.net
[m]

I found one already open and just included a comment for that. Most of the issues I saw people were complaining about the "content" column, not the "headers" one.

wallabag/wallabag#5002

Cook1e_mr
@cook1e_mr:matrix.org
[m]
Hi, wallabag is not displaying correctly, has anyone see this before?
Cook1e_mr
@cook1e_mr:matrix.org
[m]
Ok fixed this, in my environment variables, i had an incorrect port number
Bruno Fontes
@brunofontes:matrix.brunofontes.net
[m]

Hey, can someone try to add this page to Wallabag and let me know if it will result in a 500 Internal Server Error?

https://www.fastcompany.com/3042046/the-science-behind-how-boredom-benefits-creative-thought

2 replies
Bruno Fontes
@brunofontes:matrix.brunofontes.net
[m]
at fully, but it still about the last issue I mentioned yesterday. It appears to be an encoding error on header column. I've tried to delete the database, delete wallabag, install it again and the issue is still there.
I am importing 2000+ entries from Pocket. Almost everything works fine, except for fastcompany and inc.com website urls.
Christian
@christian:kampka.net
[m]
Hi guys, quick question:
From what I can figure, I can tell wallabag to change the user agent on certain sites, however documentation seems to be sparse.
It seems like the configuration moved from internal to site_config but I am not familiar with what that is exactly.
Can someone provide some pointers? 🙃
2 replies
kdecherf
@kdecherf:matrix.org
[m]
Let me know if you still have questions
odyon01
@odyon01
Hi, need some help as I'm getting:
2021/09/11 10:13:35 [error] 174#174: *118 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught PDOException: SQLSTATE[HY000]: General error: 1 no such table: wallabag_internal_setting in /var/www/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:67
The table wallabag_internal_setting exists in the DB when I connect using PGadmin.
Wallabag was working fine for months/years, but suddenly (not sure if i updated something back then), it stopped working and i got the above message. I'm running Postgres (12.6), and Wallabag (2.4.2). Do you know if there's some incompatibility with this Postgres version, or should i do something extra after upgrading postgres? All env-settings of wallabag are the same as the used to be when it all worked just fine.
Thanks!
1 reply
Bruno Fontes
@brunofontes:matrix.brunofontes.net
[m]
Its not the first time I see someone having issues with postgres bit I didn't notice versions
odyon01
@odyon01
Yes, I also saw something before. The strange thing is, it was working for more than a year just smoothly.
ploc
@ploc:matrix.gresille.org
[m]

Is it possible de delete a user in Wallabag? I found in the doc that it was possible to create or to deactivate a user, but I found no way to delete an existing user.

By the way I found no way to set an existing user to an admin role within the GUI. Is there a way to do that?

kdecherf
@kdecherf:matrix.org
[m]
ploc you can delete a user from the user management interface after clicking on edit
1 reply
MTX-6oX
@MTX-6oX

hello guys i got 2 questions:

1.some reddit posts are fetched correctly and some get the error "... new Reddit on an old browser. The site may not work ... update your browser ! If you do not update ... visit old reddit ."
links are build exactly the same, no archive or other subdomain on them.
Can somebody explain?

AND
2.what does "content" relate to at the "tagging rules"?
From my observations it seems to be at least title+body? maybe even more like url or like rly everything that was fetched?

Thanks!

kdecherf
@kdecherf:matrix.org
[m]
@MTX-6oX: for the second question, content should only refer to the body of an entry
1 reply
kdecherf
@kdecherf:matrix.org
[m]
ploc: it looks like it's not possible via the api
1 reply
kdecherf
@kdecherf:matrix.org
[m]
I know, feel free to make contributions if you want
ploc
@ploc:matrix.gresille.org
[m]

I'm not very skilled in php. I know procedural php and not much about object php. I don't know nything about Symphony either.

Would it be hard for me to contribute considering my poor skills?

kartoffelsalat
@kartoffelsalat:tchncs.de
[m]

Hi there!
I have the following parsing problem and hoped that someone here has a handy XPATH-expression for this?
The articles I want to parse have custom article-trigger-element (and similar) tags for some custom highlighting. The actual text is continued in the field "trigger-text". So, for this example,

In Köln habe ich dann das Kommunalwahlprogramm mitgeschrieben, mich als <article-trigger-element trigger-text="City-Lead" article-text="So nennt Volt den Parteivorstand auf lokaler Ebene."> </article-trigger-element> innerhalb der Partei aufstellen lassen und wurde gewählt.

the full sentence would be

"In Köln habe ich dann das Kommunalwahlprogramm mitgeschrieben, mich als City-Lead innerhalb der Partei aufstellen lassen und wurde gewählt."

How can I write a proper XPath config for this? Thanks!

kartoffelsalat
@kartoffelsalat:tchncs.de
[m]
Noone any suggestion for my xpath problem above?
Dmitriy Bogdanov
@di72nn
@kartoffelsalat:tchncs.de I don't remember much about parsing, but I would try replacing <article-trigger-element trigger-text=" with an empty string, article-text=" with some opening tag that is ignored, and "> </article-trigger-element> with respective closing tag.
kartoffelsalat
@kartoffelsalat:tchncs.de
[m]

Thanks @di72nn , good idea! It fails however, because these empty nodes are automatically removed before being able to replace them:

graby.DEBUG: HTML after regex empty nodes stripping

I've specified prune: no and tidy: no but still do not see the tags survive the first processing step ...

André M. Faria
@andre-faria
Hello, I got a problem with my MariaDB where I'm storing the wallabag database, I did a dump and loaded it in another server, configured permissions to remote access and I just can't make wallabag works.
I've changed parameters.yml to point to the new server.
\n\nSQLSTATE[42S02]: Base table or view not found: 1932 Table 'wallabag.wallabag_user' doesn't exist in engine at /var/www/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:115