Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Aug 08 23:42
    fisiognomico commented #262
  • Aug 08 19:52
    rakleed commented #5790
  • Aug 08 17:41
    yguedidi edited #5758
  • Aug 08 17:41
    yguedidi edited #5758
  • Aug 08 17:41
    yguedidi converted_to_draft #5758
  • Aug 08 17:38
    yguedidi commented #5914
  • Aug 08 17:36
    yguedidi synchronize #5758
  • Aug 08 14:30
    Kdecherf labeled #5924
  • Aug 08 14:30
    Kdecherf labeled #5924
  • Aug 08 14:26
    aiwo79 opened #5924
  • Aug 08 14:08
    yguedidi edited #5759
  • Aug 08 14:08
    yguedidi synchronize #5759
  • Aug 08 13:54
    yguedidi commented #5782
  • Aug 08 13:53
    yguedidi ready_for_review #5782
  • Aug 08 13:53
    yguedidi edited #5782
  • Aug 08 13:49
    yguedidi edited #5782
  • Aug 08 13:48
    yguedidi synchronize #5782
  • Aug 08 13:44
    Kdecherf commented #5784
  • Aug 08 13:44
    Kdecherf closed #5784
  • Aug 08 13:44

    Kdecherf on 2.6.0

    Fix DateTime case Remove transitive dependencies Merge pull request #5784 from y… (compare)

Andreas Schilling
@aschilling
Hi everybody, I am trying to refine the siteconfig for heise. Thereby I am struggling with the following problem is there a way in graby to unwrap inner tags? For example lets take this article view-source:https://www.heise.de/ratgeber/Statt-WLAN-Alternative-Leitungswege-fuers-heimische-Internet-6337619.html you see within the figure tag there is an a-img tag and inside this is the real img tag. Is there a good way to unwrap the inner img tag from the surrounding a-img tag?
kdecherf
@kdecherf:matrix.org
[m]
@aschilling: there's no direct instruction for that, afaik
However you could try writing find_string/replace_string instructions to find and replace them with something else, e.g. a garbage inline container like span
Andreas Schilling
@aschilling
@kdecherf:matrix.org thx. Do you have a particular example which I can relate to? Is span a garbage container because wallabag ignores its content?
Monirzadeh
@Monirzadeh

hi
h try to run wallabag with running ./scripts/dev.sh after do all of them when it try to run get this error

SQLSTATE[HY000]: General error: 1 no such table: tablename

some how it can't create table but i don't have any clue why not
any body can help on this?

anybody can help on this?

2 replies
kdecherf
@kdecherf:matrix.org
[m]
@aschilling: by garbage I meant "a container without any effect", it should be retrieved normally by wallabag
Andreas Schilling
@aschilling
Hi everybody, I try to refine the heise siteconfig. I stumbled accross the following question: How to I define linebreaks in the replace_string command? The following command works: replace_string(class="js-pswp-image): class="test . However the following code does not work: replace_string(<a class="js-pswp-image): <a class="testAs far as I understand the reason for it is that the a-tag and the class-definition are in separate lines. How would I have to adjust the command?
tamrinko
@tamrinko
Hi, my hosting firm uses stupid directadmin control panel so whenever I go to /config page it is redirected to hosting control panel URL.
Where can I change the address of /config in Wallabag source code? Thanks
2 replies
hexa
@hexa:lossy.network
[m]
Hi, thanks for providing wallabag. I wonder if someone can push the latest release tarball into here: https://static.wallabag.org/releases/
1 reply
j0k3r
@j0k:matrix.org
[m]
It’ll be pushed tomorrow
kdecherf
@kdecherf:matrix.org
[m]
nicofrand lapineige hey, is mariadb the only supported engine on the yunohost package?
nicofrand
@nicofrand:matrix.nicofrand.eu
[m]
Hey! I think so, we create the database in the package. If that was postgres this would use different helpers/functions
kdecherf
@kdecherf:matrix.org
[m]
Ok thanks 👍
lapineige
@lapineige:matrix.lapineige.fr
[m]
I can confirm that :)
and no change has been made since the package was created (or maybe a mysql/mariadb migration, I'm unsure)
grosjambon
@grosjambon:matrix.org
[m]
Hello everyone
i need some help getting walabag to work on my self hosted home server (debian 11)
i've followed the doc but still can't get to display the login page
blank page
i can't find anything on the logs
grosjambon
@grosjambon:matrix.org
[m]
whatever parameter i put in domain name in parameters.yml, apache keep redirecting me to http://www6.your-wallabag-url-instance.com/..................
kdecherf
@kdecherf:matrix.org
[m]
do you clear the symfony cache after changing parameters in the config file?
(using bin/console cache:clear --env=prod)
grosjambon
@grosjambon:matrix.org
[m]
ok thanks. this command says that my url is invalid
grosjambon
@grosjambon:matrix.org
[m]
i manage to get a valid url by adding http://
but now when i try to login to my wallabag instance, i've got a totally blank login page
no forms of some sort
no style
kdecherf
@kdecherf:matrix.org
[m]
grosjambon: what's in your logs?
1 reply
kdecherf
@kdecherf:matrix.org
[m]
Both
grosjambon
@grosjambon:matrix.org
[m]
the apache2/error.log says
[Fri Feb 18 19:10:06.518294 2022] [php:error] [pid 16789] [client 192.168.1.5:56675] PHP Fatal error: Uncaught PDOException: SQLSTATE[08006] [7] connection to server at "192.168.1.2", port 5432 failed: Connection refused\n\tIs the server running on that host and accepting TCP/IP connections? in /var/www/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:40\nStack tr>
and the wallabag log says
[2022-02-18 19:10:06] request.CRITICAL: Uncaught PHP Exception Doctrine\DBAL\Exception\ConnectionException: "An exception occurred in driver: SQLSTATE[08006] [7] connection to server at "192.168.1.2", port 5432 failed: Connection refused Is the server running on that host and accepting TCP/IP connections?" at /var/www/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractPostgr>
[2022-02-18 19:10:06] request.CRITICAL: Exception thrown when handling an exception (RuntimeException: Unable to create the cache directory (/var/www/html/wallabag/var/cache/prod/twig/e2). at /var/www/html/wallabag/vendor/twig/twig/src/Cache/FilesystemCache.php line 57) {"exception":"[object] (RuntimeException(code: 0): Unable to create the cache directory (/var/www/html/wallabag/var/cache/pro>
kdecherf
@kdecherf:matrix.org
[m]
Logs tell that wallabag is unable to connect to the postgresql database
1 reply
kdecherf
@kdecherf:matrix.org
[m]
Is your database really listening on 192.168.1.2:5432?
1 reply
And did you update pg_hba.conf for allowing connection?
grosjambon
@grosjambon:matrix.org
[m]
i am already using postgresql for other self hosted app (grafana)
so i guess that my postgresql is well configured
grosjambon
@grosjambon:matrix.org
[m]
hello Any help ? still got totally blank page instead of login page
grosjambon
@grosjambon:matrix.org
[m]
so i managed to get the login page displayed correctly
but when i type http://server-ip/wallabag or http://server-ip/wallabag/web in my browser, the php file is not executed. i get the content of the folder instead of the login page
i need to type http://server-ip/wallabag/web/app.php to get the login page
grosjambon
@grosjambon:matrix.org
[m]
is there any forum where i can get any help on wallabag ?
may be this element channel isn't the right place !
grosjambon
@grosjambon:matrix.org
[m]
thanks for your help guys :)
grosjambon
@grosjambon:matrix.org
[m]
it was a pleasure to meet you
Jan
@janstieler
hi,
I got a error in my wallabag installation and I’m a little bit overhelmed with it:
Its look that there is a problem with teh DB or the DB Connection.
I moved the wallabag installation from one server to another and here I’ll be stoped :) .
Fatal error: Uncaught PDOException: SQLSTATE[HY000] [1044] Access denied for user 'kdjfs'@'%' to database 'wallabag' in /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:27 Stack trace: #0 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(27): PDO->__construct('mysql:host=loca...', 'kdjfs', 'XXXXX', Array) #1 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php(22): Doctrine\DBAL\Driver\PDOConnection->__construct('mysql:host=loca...', 'kdjfs', 'XXXXX', Array) #2 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(362): Doctrine\DBAL\Driver\PDOMySql\Driver->connect(Array, 'kdjfs', 'XXXX', Array) #3 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(1473): Doctrine\DBAL\Connection->connect() #4 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Do in /var/www/virtual/kdjfs/html/wallabag/src/Wallabag/CoreBundle/Resources/views/base.html.twig on line 78
3 replies
kdecherf
@kdecherf:matrix.org
[m]
no, the '%' shown here is the result of a mysql log, nothing related to the connection string
The Doctor
@virtadpt
@kdecherf:matrix.org Oh, okay.
LeslieP-TX
@LeslieP-TX
Is there a way for admin to reset the password for a user, I can't get the system to send out reset emails no matter what I try. (brand new install via softaculous, all works great as long as you don't need to reset the password)