Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 14:41
    j0k3r edited #6006
  • 14:34
    wallabag-bot opened #6006
  • 14:34
    wallabag-bot labeled #6006
  • 12:33
    j0k3r commented #3793
  • 12:18
    MartinCigarsky commented #3793
  • 11:55
    j0k3r edited #6005
  • 10:09
    wallabag-bot labeled #6005
  • 10:09
    wallabag-bot opened #6005
  • 07:23
    j0k3r edited #5675
  • 07:12
    salexan2001 commented #5675
  • Oct 04 06:12

    j0k3r on master

    Typofixes Merge pull request #6004 from n… (compare)

  • Oct 04 06:12
    j0k3r closed #6004
  • Oct 04 00:32
    nexxai opened #6004
  • Oct 03 18:52
    helmut72 commented #4205
  • Oct 03 07:55

    j0k3r on master

    Allow auto merging of Dependabo… Merge pull request #6003 from w… (compare)

  • Oct 03 07:55

    j0k3r on auto-merge-js-deps

    (compare)

  • Oct 03 07:55
    j0k3r closed #6003
  • Oct 03 07:40
    j0k3r review_requested #6003
  • Oct 03 07:40
    j0k3r review_requested #6003
  • Oct 03 07:40
    j0k3r review_requested #6003
Andreas Schilling
@aschilling
Hi everybody, I try to refine the heise siteconfig. I stumbled accross the following question: How to I define linebreaks in the replace_string command? The following command works: replace_string(class="js-pswp-image): class="test . However the following code does not work: replace_string(<a class="js-pswp-image): <a class="testAs far as I understand the reason for it is that the a-tag and the class-definition are in separate lines. How would I have to adjust the command?
tamrinko
@tamrinko
Hi, my hosting firm uses stupid directadmin control panel so whenever I go to /config page it is redirected to hosting control panel URL.
Where can I change the address of /config in Wallabag source code? Thanks
2 replies
hexa
@hexa:lossy.network
[m]
Hi, thanks for providing wallabag. I wonder if someone can push the latest release tarball into here: https://static.wallabag.org/releases/
1 reply
j0k3r
@j0k:matrix.org
[m]
It’ll be pushed tomorrow
kdecherf
@kdecherf:matrix.org
[m]
nicofrand lapineige hey, is mariadb the only supported engine on the yunohost package?
nicofrand
@nicofrand:matrix.nicofrand.eu
[m]
Hey! I think so, we create the database in the package. If that was postgres this would use different helpers/functions
kdecherf
@kdecherf:matrix.org
[m]
Ok thanks 👍
lapineige
@lapineige:matrix.lapineige.fr
[m]
I can confirm that :)
and no change has been made since the package was created (or maybe a mysql/mariadb migration, I'm unsure)
grosjambon
@grosjambon:matrix.org
[m]
Hello everyone
i need some help getting walabag to work on my self hosted home server (debian 11)
i've followed the doc but still can't get to display the login page
blank page
i can't find anything on the logs
grosjambon
@grosjambon:matrix.org
[m]
whatever parameter i put in domain name in parameters.yml, apache keep redirecting me to http://www6.your-wallabag-url-instance.com/..................
kdecherf
@kdecherf:matrix.org
[m]
do you clear the symfony cache after changing parameters in the config file?
(using bin/console cache:clear --env=prod)
grosjambon
@grosjambon:matrix.org
[m]
ok thanks. this command says that my url is invalid
grosjambon
@grosjambon:matrix.org
[m]
i manage to get a valid url by adding http://
but now when i try to login to my wallabag instance, i've got a totally blank login page
no forms of some sort
no style
kdecherf
@kdecherf:matrix.org
[m]
grosjambon: what's in your logs?
1 reply
kdecherf
@kdecherf:matrix.org
[m]
Both
grosjambon
@grosjambon:matrix.org
[m]
the apache2/error.log says
[Fri Feb 18 19:10:06.518294 2022] [php:error] [pid 16789] [client 192.168.1.5:56675] PHP Fatal error: Uncaught PDOException: SQLSTATE[08006] [7] connection to server at "192.168.1.2", port 5432 failed: Connection refused\n\tIs the server running on that host and accepting TCP/IP connections? in /var/www/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:40\nStack tr>
and the wallabag log says
[2022-02-18 19:10:06] request.CRITICAL: Uncaught PHP Exception Doctrine\DBAL\Exception\ConnectionException: "An exception occurred in driver: SQLSTATE[08006] [7] connection to server at "192.168.1.2", port 5432 failed: Connection refused Is the server running on that host and accepting TCP/IP connections?" at /var/www/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractPostgr>
[2022-02-18 19:10:06] request.CRITICAL: Exception thrown when handling an exception (RuntimeException: Unable to create the cache directory (/var/www/html/wallabag/var/cache/prod/twig/e2). at /var/www/html/wallabag/vendor/twig/twig/src/Cache/FilesystemCache.php line 57) {"exception":"[object] (RuntimeException(code: 0): Unable to create the cache directory (/var/www/html/wallabag/var/cache/pro>
kdecherf
@kdecherf:matrix.org
[m]
Logs tell that wallabag is unable to connect to the postgresql database
1 reply
kdecherf
@kdecherf:matrix.org
[m]
Is your database really listening on 192.168.1.2:5432?
1 reply
And did you update pg_hba.conf for allowing connection?
grosjambon
@grosjambon:matrix.org
[m]
i am already using postgresql for other self hosted app (grafana)
so i guess that my postgresql is well configured
grosjambon
@grosjambon:matrix.org
[m]
hello Any help ? still got totally blank page instead of login page
grosjambon
@grosjambon:matrix.org
[m]
so i managed to get the login page displayed correctly
but when i type http://server-ip/wallabag or http://server-ip/wallabag/web in my browser, the php file is not executed. i get the content of the folder instead of the login page
i need to type http://server-ip/wallabag/web/app.php to get the login page
grosjambon
@grosjambon:matrix.org
[m]
is there any forum where i can get any help on wallabag ?
may be this element channel isn't the right place !
grosjambon
@grosjambon:matrix.org
[m]
thanks for your help guys :)
grosjambon
@grosjambon:matrix.org
[m]
it was a pleasure to meet you
Jan
@janstieler
hi,
I got a error in my wallabag installation and I’m a little bit overhelmed with it:
Its look that there is a problem with teh DB or the DB Connection.
I moved the wallabag installation from one server to another and here I’ll be stoped :) .
Fatal error: Uncaught PDOException: SQLSTATE[HY000] [1044] Access denied for user 'kdjfs'@'%' to database 'wallabag' in /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:27 Stack trace: #0 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(27): PDO->__construct('mysql:host=loca...', 'kdjfs', 'XXXXX', Array) #1 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php(22): Doctrine\DBAL\Driver\PDOConnection->__construct('mysql:host=loca...', 'kdjfs', 'XXXXX', Array) #2 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(362): Doctrine\DBAL\Driver\PDOMySql\Driver->connect(Array, 'kdjfs', 'XXXX', Array) #3 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(1473): Doctrine\DBAL\Connection->connect() #4 /var/www/virtual/kdjfs/html/wallabag/vendor/doctrine/dbal/lib/Do in /var/www/virtual/kdjfs/html/wallabag/src/Wallabag/CoreBundle/Resources/views/base.html.twig on line 78
3 replies
kdecherf
@kdecherf:matrix.org
[m]
no, the '%' shown here is the result of a mysql log, nothing related to the connection string
The Doctor
@virtadpt
@kdecherf:matrix.org Oh, okay.
LeslieP-TX
@LeslieP-TX
Is there a way for admin to reset the password for a user, I can't get the system to send out reset emails no matter what I try. (brand new install via softaculous, all works great as long as you don't need to reset the password)
kdecherf
@kdecherf:matrix.org
[m]
@LeslieP-TX: if you have access to the command line, you may have a command with composer wallabag:user or something
LeslieP-TX
@LeslieP-TX
I do have terminal access via cpanel, which i've never used, so would need the actual complete command line. Why is there no admin capability for this? Why also does the password reset email not work? I've tried to setup parameters.yml properly, but there's no test capability I have no idea why it's failing. Rather frustrating basic features on such an awesome software product.
kdecherf
@kdecherf:matrix.org
[m]
there's no admin capability because we didn't see a use case or need until now
on the email failure, you should see errors in var/logs/prod.log if there is any
Be sure to have configured the email section of parameters.yml, you must specify how to send emails (through local sendmail or through third-party service with credentials)