Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Chris Weber
    @cosmicdreams
    much further:
    cweber-osx:nerdery cweber$ env DEBUG=\* wcf start
      @oclif/config reading core plugin /Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli +0ms
      @oclif/config loadJSON /Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli/package.json +0ms
      @oclif/config loadJSON /Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli/oclif.manifest.json +2ms
      @oclif/config:@wcfactory/cli using manifest from /Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli/oclif.manifest.json +0ms
      @oclif/config reading user plugins pjson /Users/cweber/.local/share/@wcfactory/cli/package.json +0ms
      @oclif/config loadJSON /Users/cweber/.local/share/@wcfactory/cli/package.json +2ms
      @oclif/config loading plugins [ '@oclif/plugin-help' ] +1ms
      @oclif/config loadJSON /Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli/package.json +3ms
      @oclif/config loadJSON /Users/cweber/.config/yarn/global/node_modules/@wcfactory/package.json +0ms
      @oclif/config loadJSON /Users/cweber/.config/yarn/global/node_modules/package.json +0ms
      @oclif/config reading core plugin /Users/cweber/.config/yarn/global/node_modules/@oclif/plugin-help +0ms
      @oclif/config loadJSON /Users/cweber/.config/yarn/global/node_modules/@oclif/plugin-help/package.json +0ms
      @oclif/config loadJSON /Users/cweber/.config/yarn/global/node_modules/@oclif/plugin-help/oclif.manifest.json +1ms
      @oclif/config:@oclif/plugin-help using manifest from /Users/cweber/.config/yarn/global/node_modules/@oclif/plugin-help/oclif.manifest.json +0ms
      @oclif/config config done +4ms
      @oclif/config start init hook +4ms
      @oclif/config init hook done +0ms
      wcf init version: @oclif/command@1.5.2 argv: [ 'start' ] +0ms
      @oclif/config runCommand start [] +5ms
      @oclif/config loadJSONSync /Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli/tsconfig.json +10ms
      @oclif/config loadJSONSync /Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli/tsconfig.json +1ms
    Error: Cannot find module '/Users/cweber/.config/yarn/global/node_modules/@wcfactory/cli/lib/commands/start'
        at fetch (~/.config/yarn/global/node_modules/@oclif/config/lib/plugin.js:96:31)
        at Plugin.findCommand (~/.config/yarn/global/node_modules/@oclif/config/lib/plugin.js:114:21)
        at Object.load (~/.config/yarn/global/node_modules/@oclif/config/lib/plugin.js:47:72)
        at Config.runCommand (~/.config/yarn/global/node_modules/@oclif/config/lib/config.js:149:27)
        at Main.run (~/.config/yarn/global/node_modules/@oclif/command/lib/main.js:21:27)
        at Main._run (~/.config/yarn/global/node_modules/@oclif/command/lib/command.js:29:31)
        at <anonymous>
    Chris Weber
    @cosmicdreams
    Oh that's just debug messaging
    looks like it failed at the same place
    Maybe I should upgrade node to 10
    Chris Weber
    @cosmicdreams
    Naw, that didn't fix it.
    So maybe it is a permission issue
    Oh and I don't think we've explored that error I'm getting, where it says that this command isn't in the right folder.
    I can't even find a commands or libs folder in the cli folder
    ```
    cweber-osx:nerdery cweber$ ls ~/.npm-global/lib/node_modules/@wcfactory/cli
    LICENCE.md        bin            npm-shrinkwrap.json    package.json
    README.md        node_modules        oclif.manifest.json
    There also isn't a tsconfig.json which it seems to want.
    Michael Potter
    @heyMP
    hm... .I'm wondering if it's a bad release then. try updgrading to @wcfactory/cli^0.3.1
    Chris Weber
    @cosmicdreams
    Oh forgot to mention that.
    I did
    Michael Potter
    @heyMP
    ok, I was able to replicate. Let me see.
    Michael Potter
    @heyMP
    in the mean time. if you have node 10 you can run npx which executes it correctly.
    npx @wcfactory/cli
    Chris Weber
    @cosmicdreams
    I did upgrade to node 10
    I'll try that
    no go
    cweber-osx:nerdery cweber$ npx @wcfactory/cli
    CLI for managing your custom elements at scale.
    
    VERSION
      @wcfactory/cli/0.3.1 darwin-x64 node-v10.10.0
    
    USAGE
      $ wcf [COMMAND]
    
    COMMANDS
      build    Create a new Build
      element  Create a new element
      factory  Create mono repo for your element library.
      help     display help for wcf
      start    Create a company for your factories.
    
    cweber-osx:nerdery cweber$ wcf start
    Error: Cannot find module '/Users/cweber/.npm-global/lib/node_modules/@wcfactory/cli/lib/commands/start'
        at fetch (~/.npm-global/lib/node_modules/@wcfactory/cli/node_modules/@oclif/config/lib/plugin.js:96:31)
        at Plugin.findCommand (~/.npm-global/lib/node_modules/@wcfactory/cli/node_modules/@oclif/config/lib/plugin.js:114:21)
        at Object.load (~/.npm-global/lib/node_modules/@wcfactory/cli/node_modules/@oclif/config/lib/plugin.js:47:72)
        at Config.runCommand (~/.npm-global/lib/node_modules/@wcfactory/cli/node_modules/@oclif/config/lib/config.js:149:27)
        at Main.run (~/.npm-global/lib/node_modules/@wcfactory/cli/node_modules/@oclif/command/lib/main.js:21:27)
        at Main._run (~/.npm-global/lib/node_modules/@wcfactory/cli/node_modules/@oclif/command/lib/command.js:29:31)
    cweber-osx:nerdery cweber$
    Same error
    Michael Potter
    @heyMP
    npx @wcfactory/cli start
    Chris Weber
    @cosmicdreams
    same error
    Michael Potter
    @heyMP
    hmmm.... maybe it's default to using your local install
    can you remove the cli? yarn global remove @wcfactory/cli
    something like that
    Chris Weber
    @cosmicdreams
    removing...
    removed
    npx @wcfactory start still fails
    Michael Potter
    @heyMP
    soooo yeah, I'm confused
    lol
    Going to have to ask OCLIF about this. It's really not clear what's going on under the hood.
    Chris Weber
    @cosmicdreams
    maybe it would be best if I created an issue
    Michael Potter
    @heyMP
    yeah definitely
    thanks chris!
    Bryan Ollendyke
    @btopro
    @cosmicdreams that error has been fixed; it was a packaging issue. code was right, npm config wasn't :(
    0.4.0 should take care of it
    Bryan Ollendyke
    @btopro
    @cosmicdreams confirmation from a fellow Drupal-er that 0.4.1 resolves that issue you ran into
    Biggisb
    @Biggisb
    Hey, we wannt to use wcfactory to develop our web-components but have some problems while trying to get docker up and running
    is this the right place to get an answer?
    1. git clone https://github.com/elmsln/wcfactory 2. in that folder docker-compose build (no errors ) 3. docker-compose run wcfactory <command>
    This message was deleted
    Problem now is that any command result in /root/.wcfconfig/ is missing! Run wcf start from your desired directory to get started!
    (node:1) TypeError Plugin: @wcfactory/cli: Cannot read property 'companyDir' of undefined
    even if we wcf start
    Biggisb
    @Biggisb
    any ideas? We are running on Ubuntu 18.04 all works fine if we dont use the docker image (in terms of contribution using that image is need)
    Biggisb
    @Biggisb
    same problem at https://hub.docker.com/r/elmsln/wcfactory after pull i try to start it
    Screenshot from 2019-03-19 13-51-35.png
    @btopro
    Blake Morgan
    @blakemorgan

    I'm getting an error when the gulpfile runs after creating an element:

    at ChildProcess.onexit (/home/btm296/Development/byu-wcf/factories/byu-wcf/node_modules/end-of-stream/index.js:39:36)
        at ChildProcess.emit (events.js:198:13)
        at ChildProcess.EventEmitter.emit (domain.js:466:23)
        at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)

    Has anyone seen this before? These are the options I'm using:

    ? Custom element base class to use lit-element -- data binding ++, very small library. 1 dependencies
    ? Element name byu-header
    ? Description / purpose of the element BYU themed page header.
    ? Do you want to use Sass in this element? Yes
    ? Do want to use existing Sass dependencies? rh-sass
    ? Do you want custom properties? (typically yes) Yes
    ? Auto build support for the HAX authoring system? Yes
    ? Add a new property? (Y/n) 
    ? Add a new property? Yes
    ? Name (eg: title) site-title
    ? Name (eg: title) site-title
    ? type of value (the way it is used as data) (Use arrow keys)
    ? type of value (the way it is used as data) String, text based input
    ? Default value (leave blank for none) 
    ? Default value (leave blank for none) 
    ? Make available in css styles? [name="stuff"] { color: blue; } (y/N) 
    ? Make available in css styles? [name="stuff"] { color: blue; } No
    ? Observe changes to this property? (Y/n) 
    ? Observe changes to this property? Yes
    ? Add a new property? (Y/n) n
    ? Add a new property? No