Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 12:00
    wswebcreation edited #7779
  • 11:59
    wswebcreation opened #7779
  • 11:57

    wswebcreation on add-step-name

    feat: add cucumber step name in… (compare)

  • 11:53
    0Leon0 edited #7778
  • 11:51
    0Leon0 labeled #7778
  • 11:51
    0Leon0 labeled #7778
  • 11:51
    0Leon0 opened #7778
  • 11:46
    wswebcreation opened #7777
  • 11:43

    wswebcreation on cucumberjs-fix-skipped-state

    fix: update state for a skipped… (compare)

  • 11:26
    jan-molak commented #7770
  • 11:16
    christian-bromann commented #7770
  • 09:36
    DudaGod labeled #7776
  • 09:36
    DudaGod labeled #7776
  • 09:36
    DudaGod opened #7776
  • 05:07
    emilioDuarte edited #7773
  • 04:28
    emilioDuarte commented #7773
  • 04:28
    emilioDuarte commented #7773
  • 04:26
    emilioDuarte opened #7773
  • 04:26
    emilioDuarte labeled #7773
  • 04:26
    emilioDuarte labeled #7773
Tanu
@Tanu51859628_twitter
image.png
Hi, I see these options in the wdio.conf.js " onReload: function(oldSessionId, newSessionId)" . How can I use these capabilities to inject newSession=('xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx') in my chrome browser after the session is created.
Or Can I use DevTool Services to set newSessionid?
Martijn Kuhlemeier
@martijnhjk
hello all! Quick question, Im exploring v6 and I noticed this log in the console Warning! Unsupported expect lib is used.
im a bit surprised because I am using Chai and https://webdriver.io/blog/2020/03/26/webdriverio-v6-released.html clearly states "If you already use an assertion library like Chai you can continue doing"
I'm setting expect globally by require('chai/register-expect');
is Chai not compatible with v6?
Djamal
@djamknacker_twitter

Hello here.
Updated my project from wdio v5 to v6 and faced with problem when running tests remotely on selenium grid.
Even if I set hostname: , port: , and path: , in wdio.conf tests are running on my machine.
Who knows if there were any config changes or maybe I need to add something else now in v6 to be able to run tests on remote selenium grid machine?

P.S> even if I set absolutely incorrect hostname in config -> it still launch browsers on my local machine. 😅

3 replies
crazy-reva
@crazy-reva
Hi All, I have been trying to do performance testing using wdio , I have followed the steps on to integrate chromedriver,devtools service in my project to run the tests, I am seeing the below error "browser.getMetrics() is not a function". Can anyone help me on how to resolve this issue? Thanks in advance!
Divya Seshadri
@divya_seshi_twitter
Hi everyone, Im new to the coding world and Im trying to automate our webpage for official purposes. Im trying to upload a file in import field but no luck. I tried the following commands --> setValue, chooseFile, uploadFile, addValue but nothing helped. Could someone help me on this? PS: Using macOs, node version - v12.16.1.
Pascal König
@pako88
@divya_seshi_twitter take a look here: https://webdriver.io/blog/2019/06/25/file-upload.html
Divya Seshadri
@divya_seshi_twitter
@pako88 Thank you for the response. I have tried that too. It isn't working for me.
1 reply
Pascal König
@pako88
@divya_seshi_twitter is you webpage in the internet? i can take a quick look at it
Javier
@javiergarciacotado
hello
fyi
I have opened an issue on github: webdriverio/webdriverio#5441
Divya Seshadri
@divya_seshi_twitter
@pako88 Its Zoho Mail web app, paid version.. I guess you will not be able to the view that particular page.
GYANENDRA PANDEY
@gyanendrapmca
WARN @wdio/jasmine-framework: Unable to load spec files quite likely because they rely on browser object that is not fully initialised.
browser object has only capabilities and some flags like isMobile.
Helper files that use other browser commands have to be moved to before hook.
Spec file(s): E:\ACA PROJECT DETAILS\ec-app-testing\test\specs\basic.js
any one help me regarding this error
Pascal König
@pako88
@divya_seshi_twitter nope - then i can't help you sorry - you should stick to that blog article
GYANENDRA PANDEY
@gyanendrapmca
how to initialize browser object in @wdio/jasmine-framework
Pascal König
@pako88
@divya_seshi_twitter you can try it out here: https://the-internet.herokuapp.com/upload
GYANENDRA PANDEY
@gyanendrapmca

WARN @wdio/jasmine-framework: Unable to load spec files quite likely because they rely on browser object that is not fully initialised.
browser object has only capabilities and some flags like isMobile.
Helper files that use other browser commands have to be moved to before hook.
Spec file(s): E:\ACA PROJECT DETAILS\ec-app-testing\test\specs\basic.js

???

Martin Coronel
@martincxx
Hi Guys, do you know if we can use webdriverio for bookmarking a page on Chrome?
Aldira Putra Raharja
@dirathea

Hi guys, could anyone here help me with typescript and custom commands?
so I have this on my wdio.conf.js

    mochaOpts: {
        require: [
            'ts-node/register',
            'tsconfig-paths/register'
        ],
        ui: 'bdd',
        timeout: 60000
    },
before: function (capabilities, specs) {
        browser.addCommand('customConfig', function () {
            return {
                text: 'Hi Custom Command'
            }
        });
    },

and I've added this command to my custom type definition at types/wdio.d.ts

declare module WebdriverIO {
    // adding command to `browser`
    interface Browser {
        customConfig: () => any;
    }
}

and I also setup tsconfig.json as follows

{
    "compilerOptions": {
        "typeRoots": ["./types"],
...
}

when I execute the test my custom commands not recognized with error

 Error:  TSError: ⨯ Unable to compile TypeScript:
error TS2339: Property 'customConfig' does not exist on type 'BrowserObject'.
I'm not directly using src folders, all typescript files is under web/ and I've added it into my path on tsconfig
        "paths": {
            "*": [ "./*" ],
            "web/*": ["./web/*"]
        },
27 replies
Divya Seshadri
@divya_seshi_twitter
@pako88 Sure, thank u
vrudhay
@vrudhay
image.png

Hi, when I try to execute for edge, I get this error.

ERROR @wdio/runner: Error: Couldn't find executable for browser

I have also been running msedge driver to match my edge browser version 83

Dmitry Munda
@dimkin-eu
anyone having some issues/experience running wdio+browerstack+local in concurrent runs on one jenkins agent ?
I have feeling, that this stuff can kill local runners of concurrent job
13:39:31 LocalError: Multiple binaries spawned with same configuration. Closing older one.
13:39:31     at /var/opt/jenkins-slave/workspace/.../node_modules/browserstack-local/lib/Local.js:65:20
13:39:31     at ChildProcess.exithandler (child_process.js:294:7)
13:39:31     at ChildProcess.emit (events.js:311:20)
13:39:31     at ChildProcess.EventEmitter.emit (domain.js:482:12)
13:39:31     at maybeClose (internal/child_process.js:1021:16)
13:39:31     at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5) {
13:39:31   name: 'LocalError',
13:39:31   message: '\u0000\u0000\u0000\u000b\u0000\u0000\u0000\u0000Multiple binaries spawned with same configuration. Closing older one.',
13:39:31   extra: undefined
13:39:31 }
13:39:31 
13:39:31 
13:39:31 Ended WebDriver sessions gracefully after a SIGINT signal was received!
Erwin Heitzman
@erwinheitzman
Haven't seen this before @dimkin-eu do you think you could provide an issue with a reproducible example?
2 replies
@vrudhay seems like it cannot find the browser binary at the default installation directory, you can also point it there
Viacheslav
@Gordiievskyi
@erwinheitzman sorry for ping you directly(I rised same question twice two days ago and didn't get any answer), just want to confirm that what I spot is a bug before open an issue in wdio git hub, it seams delay root suite doesn't work in wdio 6( I am not sure if it worked in prev versions). I set in mocha opts delay true and simple example from mocha do not execute any tests and mark them as skiped, while work in pure mocha. wdio docs doesn't have any example and if intended to work same as in pure mocha then I will open a ticket.
Raul Mocian
@raul.mocian_gitlab
It seems that browser.getWindowHandle() does not work on Chrome, does somebody know why? or if there is a workaround?
Fedor Kerzhakov
@kerzh672322_gitlab
Hi Guys, does Webdriver IO support Chrome Version 83? If yes, how do I need to change the package.json? Thank you
Pascal König
@pako88
vrudhay
@vrudhay
@erwinheitzman
Edge problem I resolved it... Now, for IE 11, I am using selenium-standalone
capabilities: [
{ "browserName": "internet explorer" }
],
services: ['selenium-standalone'],
I am able to launch the browser - but none of the events click are working... I am using IE11 - there are some registry setting in IE11 driver page. I did that as well.
Erwin Heitzman
@erwinheitzman
FYI, will fix this asap when I got the time: webdriverio/webdriverio#5443
vrudhay
@vrudhay
@erwinheitzman
Any quick support on wdio and ie11 settings? I am running out of ideas
Erwin Heitzman
@erwinheitzman
for anyone running into this, a quick workaround is to change the following in your config:
from runner: ''
to runner: 'local'
@vrudhay sorry but I am entering a meeting in exactly 1 minute
vrudhay
@vrudhay
@erwinheitzman Looking forward for any small bit of support... IE11 is crushing us
Fedor Kerzhakov
@kerzh672322_gitlab
@pako88 thank you, but if I just copy/paste your package.json, it does not work anyways, could you be so kind and tell me what I should do?
jpsouthy93
@jpsouthy93
Trying to get wdio working on a colleagues machine - I've pulled my repo, installed what i believe is all dependencies, and when trying to run tests I get error '$(...).isExisting is not a function' which I believe is just a wdio function?
Not sure what information would be needed to trouble shoot this, if I clone the exact same repo on my machine it works a treat
chan-ai
@chan-ai
@erwinheitzman Is there a limit on how many tabs we can open using webdriverio? I have the sample code
browser.newWindow('www.google.com');
browser.newWindow('www.google.com');
browser.newWindow('www.google.com');
It opens only two tabs
4 replies
Pascal König
@pako88
@kerzh672322_gitlab i don't know what you should do without knowing your code. take a look here, with this it should work: https://webdriver.io/docs/wdio-chromedriver-service.html
Olga
@osmolyar
@martijnhjk we have that warning message as well. We set it globally via
global.expect = chai.expect global.assert = chai.assert global.should = chai.should()
but still also have to import chai's expect into those files where expect is used (as 'expect' specifically is not compatible with expect-webdriverio's). I think that is what the warning is about
3 replies
@jpsouthy93 please check which version of webdriverio is used in each case. $(...).isExisting only works in v5+. In v4, the syntax is browser.isExisting(selector);
@vrudhay we see the exact same issue with IE11 with the current driver/browser versions. Click() always fails due to 'move target out of range' error. It must be the driver since it works fine with earlier browser/driver versions. However it is not possible to install an older IE11 version (on Windows10, at least). : /