Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 21:58
    christian-bromann commented #6993
  • 21:52
    kailin0512 commented #6993
  • 19:10
    licanhua commented #7007
  • 18:42

    christian-bromann on main

    Issue #6977: Renamed 'reset' co… (compare)

  • 18:42
    christian-bromann closed #7002
  • 18:41
    christian-bromann labeled #7002
  • 18:41
    christian-bromann synchronize #7002
  • 18:39
    christian-bromann commented #7007
  • 16:21
    licanhua commented #7007
  • 16:18
    srikanthgurram commented #7002
  • 16:17
    srikanthgurram synchronize #7002
  • 13:33
    lacell75 commented #7007
  • 13:32
    lacell75 commented #7007
  • 12:25
    christian-bromann commented #7007
  • 12:09
    lacell75 commented #7007
  • 11:57
    dependabot[bot] edited #7011
  • 11:55

    dependabot[bot] on npm_and_yarn

    (compare)

  • 11:55

    christian-bromann on main

    Bump @typescript-eslint/parser … (compare)

  • 11:55
    christian-bromann closed #7008
  • 11:55

    dependabot[bot] on npm_and_yarn

    (compare)

cpeck-bi
@cpeck-bi
krarpitgupta
@krarpitgupta
Hi Guys need your help I am using Cucumber + WebdriverIO v7 surprisingly
Then('I wait for {string} to not displayed', (elementInfo) => {
is recognized but when we are specifying like this
Then('I wait for {string} to (be|not) (clickable|displayed|enabled|exist)', (elementInfo, falseCase, condition) => {
It's not recognized getting following error Step "I wait for "SpinnerImage" to not displayed" is not defined. You can ignore this error by setting cucumberOpts.ignoreUndefinedDefinitions as true
Can anyone please help, I am having difficult time to understand what I am missing here ?
cpeck-bi
@cpeck-bi
@karpitgupta well, I am assuming you have accounted for that use case -- IE you have some step that should be running for that combination of arguments?
krarpitgupta
@krarpitgupta
@cpeck-bi May I know what I am missing here ?
I don't have any other step, I am in phase of building the things
cpeck-bi
@cpeck-bi
what does the step definition code look like, if you can share?
krarpitgupta
@krarpitgupta
Here it's

Then('I wait for {string} to (be|not) (clickable|displayed|enabled|exist)', (elementInfo, falseCase, condition) => {

let selector = lib.getSelector(elementInfo);
console.log("elementInfo : " + elementInfo);
console.log("falseCase : " + falseCase);
console.log("condition : " + condition);
lib.waitFor(selector, waitTimeout, true, `Timeout Occur : Spinner is displayed even after ${waitTimeout} ms`);

});

@cpeck-bi FYI
Here is the step in my feature file :
Then I wait for "SpinnerImage" to not displayed
However It works if I specify step like this : Then('I wait for {string} to not displayed', (elementInfo) => {
cpeck-bi
@cpeck-bi
how long is the waitTimeout generallly?
krarpitgupta
@krarpitgupta
It's 20000 ms
even If I comment lib.waitFor statement still step is not recognizable
krarpitgupta
@krarpitgupta
@cpeck-bi Any idea what I am missing here ?
For me it looks so strange
cpeck-bi
@cpeck-bi
you're not actually using the condition parameter are you?
or the falseCase?
krarpitgupta
@krarpitgupta
I am using
@cpeck-bi
Akamel
@Amrkamel1

@Amrkamel1 you can find the syntax here https://webdriver.io/docs/clioptions/#run-the-test-runner-programmatically

thank you so much its working now

Johnson E
@jonn-set
Hi, can someone help me with this issue please? https://github.com/webdriverio/webdriverio/discussions/6688

Copying this problem here:

We are using browser.mock() to spy on non XHR calls and we have situation where we need to do a browser.sessionReload() which causes browser.mock() to stop working on any new window opened. Is this is expected? And is there a workaround to this? We cant use clearCookies() as we have multiple applications and the clearing cookies at the end only clears cookies of the last opened domain.

Raziel Alron
@razielron
does anyone knows which version of Jasmine does wdio uses?
tobeliketree
@tobeliketree

My team keeps running into performance metrics errors when trying test the loading of an image gallery that first requires authentication first. The actual error is

[0-0] LHError in "Testing the performance of a specific core library gallery with 50 assets. Should open and get the performance metrics from core library gallery with 50 assets" LHError: NO_TTI_NETWORK_IDLE_PERIOD at Function.findOverlappingQuietPeriods (/Users/tree/Git_Repositories/performance/node_modules/lighthouse/lighthouse-core/computed/metrics/interactive.js:136:11) at Function.computeObservedMetric (/Users/tree/Git_Repositories/performance/node_modules/lighthouse/lighthouse-core/computed/metrics/interactive.js:165:41) at Function.compute_ (/Users/tree/Git_Repositories/performance/node_modules/lighthouse/lighthouse-core/computed/metrics/metric.js:65:21) at Browser.next [as getMetrics] (/Users/tree/Git_Repositories/performance/node_modules/@wdio/utils/build/monad.js:95:33)

Does anyone have any help on this and what LHError or NO_TTI_NETWORK_IDLE_PERIOD means and how I adjust a rather simple metrics test? . My test couldn't be any simpler and the util metrics function is gathering all available metrics results the wdio performance audits offers

 before(function(){
        browser.enablePerformanceAudits(); 
        const userVariables = tv.config.coreUserCredentials.
            sauce[sanitizedCapabilities.getBrowserOSName()];
        CoreImagesLeftPane.open(library);
        LoginPage.submitCoreLogin(userVariables.username, 
            userVariables.password);   
        CoreImagesLeftPane.clickListedTab();
    });

    after(function() {
        browser.disablePerformanceAudits();
    });

    it('Should open and get the performance metrics from core library gallery with 50 assets', function () {
        CoreImagesLeftPane.openCollectionOrGallery(fiftyImageGallery); 
        util.getPerformanceData();
    });
Erwin Heitzman
@erwinheitzman
@razielron you can check the version in the package.json of the jasmine framework service
7 replies
@jonn-set someone already replied and asked the question with a good reason as this issue should probably be resolved in v7
Johnson E
@jonn-set
@erwinheitzman thanks, is the upgrade from 6 to 7 non breaking?
Scott Mac Donald
@Corinos
Hey folks, does anyone have a tool for testing WDIO selectors? I have chained selector that seems to work with each part on their own in the console, but since the console doesn't let me use chained selectors the same way, I can't test the whole thing, and when I run WDIO using that selector, i get an unexpected return.
Is the a browser extension or anything that I could use?
Akamel
@Amrkamel1
is there any updates regarding the multi remote issue
    Error: Invalid or unsupported WebDriver capabilities found ("protocol", "hostname", "port", "path"). Ensure to only use valid W3C WebDrive
Christian Bromann
@christian-bromann
there is a PR that will be merged and released soon
fedoseevGIT
@fedoseevGIT
Hello everyone) Does anyone use restarting tests through the Re-run-service? After passing the tests, a sh file is generated to re-run the tests, but I do not quite understand where to call it. When I insert the execution of this file into the OnComplete hook, the process is automatically killed after a while and the tests are not restarted.
kfir ben hamou
@kfirbhCS
Anyone knows if video reported is fully sported on version 7 ?
Christian Bromann
@christian-bromann
@kfirbhCS what do you mean by video support?
1 reply
Marijana Rukavina
@mareru

Hello, I am using webdriverIO v7 and cucumber to test my application. When running tests in headless mode or non headless mode results in error: java.net.ConnectException: Connection refused: connect Some scenarios pass but in some fail with that error.
This is stack trace:

unknown error: java.net.ConnectException: Connection refused: connect
    at Object.getErrorFromResponseBody (C:\my-project\node_modules\webdriver\build\utils.js:189:12)
    at WebDriverRequest._request (C:\my-project\node_modules\webdriver\build\request.js:168:31)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at Browser.runCommandWithHooks (C:\my-project\node_modules\@wdio\sync\build\wrapCommand.js:105:25)
    at Browser.runCommandWithHooks (C:\my-project\node_modules\@wdio\sync\build\wrapCommand.js:100:24)
    at Browser.url (C:\my-project\node_modules\@wdio\sync\build\wrapCommand.js:67:44)
    at MyPage.openImportPage (C:\my-project\src\pages\/myPage.js:32:17)
    at forEach (C:\my-project\src\helpers\/helpers.js:60:21)
    at Array.forEach (<anonymous>)
    at Helpers.deleteWishLists (C:\my-project\src\helpers\/helpers.js:55:51)
    at World.<anonymous> (C:\my-project\src\step_definitions\/config_steps.js:28:13)
    at World.executeSync (C:\my-project\node_modules\@wdio\sync\build\index.js:38:22)
    at World.executeSync (C:\my-project\node_modules\@wdio\sync\build\index.js:52:38)
    at C:\my-project\node_modules\@wdio\sync\build\index.js:69:68

Any ideas what the issue might be? Thanks!

Anybody? :D Please, any idea is welcomed. Thanks!

Erwin Heitzman
@erwinheitzman
If I knew I'd tell you O_O
Orozbek Askarov
@Askarov5
Hi, QQ: Does webdriverio support Oracle Forms?
kfir ben hamou
@kfirbhCS
@christian-bromann
Sorry i meant video-reporter
Orozbek Askarov
@Askarov5
@christian-bromann Does WebdrivrIO support Oracle Forms? Any version? did anyone experience or try?
Erwin Heitzman
@erwinheitzman
@Askarov5 just did a quick search and it looks like this is not made for web, is that assumption correct?
If it's a Windows application there's a driver for that
Orozbek Askarov
@Askarov5
@erwinheitzman Oracle forms application can be opened in the browser, so I was thinking it might be possible... I made my research and found info for about selenium and Oracle Forms but not for webdriverio, So I just wanted to double check and make sure. Sorry, for bothering.
Erwin Heitzman
@erwinheitzman
@Askarov5 we utilize the same protocol so I don't see any limitations