Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 16:26
    dylanlive closed #7023
  • 16:26
    dylanlive commented #7023
  • 14:33
    dependabot[bot] edited #7035
  • 14:32

    dependabot[bot] on npm_and_yarn

    (compare)

  • 14:32

    christian-bromann on main

    Bump core-js from 3.14.0 to 3.1… (compare)

  • 14:32
    christian-bromann closed #7035
  • 14:32
    dependabot[bot] synchronize #7035
  • 14:32
    dependabot[bot] edited #7035
  • 14:32

    dependabot[bot] on npm_and_yarn

    Bump core-js from 3.14.0 to 3.1… (compare)

  • 14:32
    dependabot[bot] edited #7035
  • 14:31

    dependabot[bot] on npm_and_yarn

    (compare)

  • 14:31
    dependabot[bot] commented #7034
  • 14:31
    christian-bromann closed #7034
  • 14:31

    dependabot[bot] on npm_and_yarn

    (compare)

  • 14:31
    dependabot[bot] edited #7035
  • 14:31
    dependabot[bot] commented #7036
  • 14:30
    christian-bromann closed #7036
  • 14:30

    dependabot[bot] on npm_and_yarn

    (compare)

  • 14:30
    dependabot[bot] commented #7037
  • 14:30
    christian-bromann closed #7037
praveendvd
@praveendvd
The problem is the process never exits as the emulator is attached to the cmd session, how to force cmd or ps to close once webdriverio run completes
praveendvd
@praveendvd

const {execSync} = require('child_process');

onComplete: function(exitCode, config, capabilities, results) {
execSync('adb emu kill');
}

this worked thanks
Madhan
@madhank_gitlab

Hi all,

browser.execute('window.scrollTo(0, 0)');

Is this correct way to execute js script in wdio ? I am trying to reach the top of the web page, but its not working for me. Can anyone help me on this ? Thanks

Marijana Rukavina
@mareru

Hello, I get this error in IntelliJ

TS2694: Namespace 'global.WebDriver' has no exported member 'ChromeOptions'

I am using webdriverIO v7 with Typescript and I have used WebDriver.ChromeOptions as a type, but it doesn't recognize it.
Anybody knows how to fix it?

navsterrr
@navsterrr

hello folks , been stuck a few days trying to upgrade to webdriverio v6.12.1 from v4. @wdio/local-runner is failing to launch a test session with chromedriver service -

[0-0] ERROR @wdio/local-runner: Failed launching test session: TypeError: this._framework.init is not a function.

full stack trace here - https://paste.gg/p/anonymous/a073e92424c84f79b93156d5bd99797b
confirmed the chromedriver service was started successfully. this was working with webdriverio@4.14 but failing with webdriverio@6.12.1.
Would appreciate any help on this!

my package.json - webdriverio@6.12.1, @wdio/local-runner@6.12.1, @wdio/cli@6.12.1, wdio-chromedriver-service@6.0.4

my wdio.conf.js -
services: ['chromedriver']

tsibulya12
@tsibulya12
Hi guys, I'm installing wdio v7 on a new laptop, and there package.json is not creating, can someone tell me how to fix this issue?
npm WARN saveError ENOENT: no such file or directory, open 'C:\Users\tsibu\Desktop\WDIO\package.json'
rashiq231
@rashiq231
Hello, I am new to webdriverIO, while trying to run using cucumber framework, even though the execution is happening, I see the steps are retried as if there was a failure
ERROR @wdio/local-runner: Failed launching test session: Error: Couldn't find page handle
at DevToolsDriver.getPageHandle (D:\webdriverio\test2\node_modules\devtools\build\devtoolsdriver.js:143:19) can anyone help how to resolve this?
sureshneni
@sureshneni
Hi Team, I have used below block to run my multiple specs in sequential order but browser gettitng open twice at same times, please let me know how to fix it.
suites : {
login: [
'./test/specs/login.spec.js',
'./test/specs/openNewAccount.spec.js'
]
},
openNewAccount.spec.js has to run only after login.spec.js file
BhushanKinholkar
@BhushanKinholkar
Hi all addValue is not function
I am getting this error
on webdriver io
nileshye
@nileshye
Hello All, Can we use a global variable set in wdio.config.js in all other classes like test, util etc?
Łukasz Zwozniak
@affreux:matrix.org
[m]
Hi tsibulya12 (tsibulya12) Try to add your package.json file, use this command npm init -y
Then run this command npm i --save-dev @wdio/cli
and finally use this command to start the automatic configurator - npx wdio config
Raziel Alron
@razielron
is it possible to get a specific data of a test from custom-report?
question is well described here:
https://stackoverflow.com/questions/62451226/wdio-add-a-custom-property-to-test-object-web-driver-io
James
@jamesmortensen
I have a Selenium Hub running 3 instances of selenium/standalone-chrome using docker-compose. I have 3 spec files: spec1.js, spec2.js, and spec3.js. I want to start WebdriverIO from the CLI and have spec1 run on the first chrome image, spec2 on the second, and spec3 on the third.
In other words, I want to run all 3 spec files in parallel on different instances of the same browser so the tests finish faster.
I have read the instructions about setting this up in the capabilities, using maxInstances, but it seems that all 3 specs are run on all 3 instances of Chrome. My goal is to run different tests in parallel not the same tests in parallel. Is there an easy way to accomplish this? Thank you.
James
@jamesmortensen

Hi Team, I have used below block to run my multiple specs in sequential order but browser gettitng open twice at same times, please let me know how to fix it.

@sureshneni login.spec.js should contain all of your tests to test that login works. For instance, what happens if you enter valid credentials. What about an empty password, what about empty username?

However, openNewAccount.spec.js isn't testing login, but perhaps it requires you to be logged in first. If that's the case, you can make the spec files independent of one another. Make sure openNewAccount.spec.js doesn't depend on login.spec.js. Hope this helps.

pocket monster
@danizsh:matrix.org
[m]
hi can any help me about this if anyone good in python selenium scripts

rom selenium import webdriver driver = webdriver.Chrome("C:/Users/danish/PycharmProjects/chromedriver.exe") driver.get("https://www.tppcrpg.net/login.php")

identify username, password and signin elements
driver.find_element_by_name("LoginID").send_keys("3480199")

driver.find_element_by_name("NewPass").send_keys("12")

driver.find_element_by_class_name("submit").click()

driver.get("https://www.tppcrpg.net/battle_trainer.php")

identify Enter Trainer Name/Number
driver.find_element_by_name("Trainer").send_keys("2502909")

driver.find_element_by_class_name("submit").click()

driver.find_element_by_class_name("submit").click()

it works fine here but when i add again this line to click continue button

driver.find_element_by_class_name("submit").click()

then this gives me this error selenium.common.exceptions.NoSuchElementException: Message: no such element: Unable to locate element: {"method":"css selector","selector":".submit"} (Session info: chrome=90.0.4430.72)

oioi11
@oioi11
image.png
Hello everybody!
what should I do?
image.png
image.png
Refael Mah
@PrinceEX87_twitter
Hi, I've started to use the Re-run Service with mocha and it works great. But I've noticed that it rerun skipped tests also, is it the expected behavior?
Erwin Heitzman
@erwinheitzman
@oioi11 that should work I think, what happens if you add a waitForExist before clicking the element?
2 replies
Erwin Heitzman
@erwinheitzman
@PrinceEX87_twitter I believe this service was created before we supported those cases, by now I think everything is supported natively. checkout https://webdriver.io/docs/retry/ and try without the service I'd say
Akamel
@Amrkamel1
can I exclude a specific suite (mocha) of feature files (Cucumber) in the before hook in the config file?
filip-svrcek-CN
@filip-svrcek-CN
@Amrkamel1 I don't think you can exlude a suite. You can exclude spec file by spec file
5 replies
StevenRobinMason
@StevenRobinMason

anyone having issues running the install command for a new instance of WDIO

ran npm install wdio/cli and appears to be stuck on

reify:core-js-pure: timing reifyNode:node_modules/lodash Completed in 12207ms

and I cant seem to close the powershell window it is running from (this is like the third attempt to run the install command =/
sureshneni
@sureshneni

Hi Team, I have used below block to run my multiple specs in sequential order but browser gettitng open twice at same times, please let me know how to fix it.

@sureshneni login.spec.js should contain all of your tests to test that login works. For instance, what happens if you enter valid credentials. What about an empty password, what about empty username?

However, openNewAccount.spec.js isn't testing login, but perhaps it requires you to be logged in first. If that's the case, you can make the spec files independent of one another. Make sure openNewAccount.spec.js doesn't depend on login.spec.js. Hope this helps.

@jamesmortensen got it, thank you

filip-svrcek-CN
@filip-svrcek-CN
Is there a way to skip the rest of the test (specFile) after one it block fails and continue with another specFile? Thanks
Erwin Heitzman
@erwinheitzman
@StevenRobinMason it's npm i @wdio/cli
@filip-svrcek-CN not that I know of
Mircea Rosioru
@MirceaRosioru_twitter
hello guys! Can someone help me with some way of running my wdio v7, selenium-standalone tests on Safari? is this possible? I am using a WINDOWS machine.
Christian Bromann
@christian-bromann
@MirceaRosioru_twitter Safari only runs on Mac, so no
Christoph Herold
@coeamyd
Is there a way to get the console output from Chrome using the current webdriver.io? I've found various articles complaining, that the api was changed from 4 to 5 to 6. However, none of them said, what the current mechanism is. For me, it would be enough, if it works for Chrome only.
StevenRobinMason
@StevenRobinMason
image.png
@erwinheitzman the other command works which was npm install @wdio/cli as it does start to install. it just appears to get stuck at this particular big and can't even close the powershell window it is running from
Olga
@osmolyar
Is anyone seeing this?
[0-24] 2021-04-19T13:23:42.820Z ERROR @wdio/local-runner: Failed launching test session: Error: Couldn't initialise "@wdio/cucumber-framework".
Error: Cannot find module '@cucumber/messages/dist/src/stream'
Require stack:
- C:\osmolyar_qdtools\iris\latest\ManagementPortal\node_modules\@wdio\cucumber-framework\node_modules\@cucumber\gherkin\dist\src\stream\GherkinStreams.js