Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 26 09:46
    DudaGod commented #7753
  • Nov 26 09:39
    nirmalcrafty commented #7752
  • Nov 26 09:23
    erwinheitzman commented #7738
  • Nov 26 08:06
    GYuriy commented #7745
  • Nov 26 07:57
    GYuriy commented #7745
  • Nov 26 07:48
    wswebcreation commented #7722
  • Nov 26 07:48
    wswebcreation reopened #7722
  • Nov 26 07:48
    wswebcreation commented #7722
  • Nov 26 07:46

    wswebcreation on fix-7722

    (compare)

  • Nov 26 07:46
    wswebcreation closed #7726
  • Nov 26 07:46
    wswebcreation commented #7726
  • Nov 26 06:49
    dietergeerts labeled #7755
  • Nov 26 06:49
    dietergeerts labeled #7755
  • Nov 26 06:49
    dietergeerts opened #7755
  • Nov 26 05:02
    nirmalcrafty edited #7752
  • Nov 26 00:05
    Andrewnt219 edited #7754
  • Nov 26 00:04
    linux-foundation-easycla[bot] commented #7754
  • Nov 26 00:00
    Andrewnt219 edited #7754
  • Nov 25 23:59
    linux-foundation-easycla[bot] commented #7754
  • Nov 25 23:59
    Andrewnt219 opened #7754
sureshneni
@sureshneni
@jamesmortensen got it, thank you
Iqra Dilawar
@iqra-dilawar
@christian-bromann Hi, I wanted to know that can we automate kafka callbacks? Where we are not sure when will we receive response. If yes, what can be the way
4 replies
Jverrijk
@Jverrijk
image.png
I'm having trouble selecting a dynamically generated frame within a front-end checkout test. It consists of multiple frames where client information must be filled in. All goes well except the final one. I've tried so many things. In the inspector of Chrome you can see a #document is created in an iFrame, I'm unable to add a value to id="addressCollector-date_of_birth". Webdriver keeps telling me the frame doesn't exist.
Raziel Alron
@razielron
Coder123
@Coder123-Sai
Hiii
I am trying to login to GMAIL using WebdriverIO, but getting error
This browser or app may not be secure.
Can any one please help how to bypass this error?
Thanks in advance
Daniël Verburgh
@danielkroon
Hi all! I Just saw this notification that we can’t use sync mode anymore. Does that mean we have to rewrite all our tests to async? Or is there a quicker way? I can’t find any more information or documentation online. Just the message that we shouldn’t use sync mode anymore.
Christian Bromann
@christian-bromann
@danielkroon where did you see the message?
Here: https://webdriver.io/docs/sync-vs-async ? Let me add some more links for context. Thanks for letting me know that this is unclear
4 replies
Daniël Verburgh
@danielkroon
@christian-bromann yes in the docs. Thank you very much! No problem!
Christian Bromann
@christian-bromann
@danielkroon added a link to the RFC, hope this provides more context
Daniël Verburgh
@danielkroon
@christian-bromann thank you!
Krishna Kumar Singh
@kwishna
Default Scripts For Cucumber-Typescript Downloaded On Performing 'wdio init' Is Not Running For Me. Please check: https://stackoverflow.com/q/67186996/9544909
ttwu
@ttwu2019
Hi,Who knows this problem?
Ghost
@ghost~607dccd16da03739847a82b3
Hello. I need to execute tests with chrome extension in browser. In java I can do it like this:
ChromeOptions options = new ChromeOptions();
options.addExtensions(new File("app.crx"));
What should I do for it in js and webdriverIO?
ttwu
@ttwu2019
ERROR @wdio/local-runner: Failed launching test session: Error: Couldn't initialise "@wdio/cucumber-framework".
Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath './lib/formatter/helpers/event_data_collector' is not defined by "exports" in /Users/git/Desktop/192.168.5.66/eviauto_android/node_modules/@cucumber/cucumber/package.json
Christian Bromann
@christian-bromann
@ttwu2019 it seems there is an error in an external dependency
We are working on a fix
Krishna Kumar Singh
@kwishna
@christian-bromann Just 1 Day Back, Everything Was Working Fine. When I Checked, I Came To Conclusion That It Is Possibly Happening Because @cucumber/cucumber v7.2.0, Which Was Released Yesterday. On @cucumber/cucumber v7.1.0, The Same Code Is Working Fine.
Christian Bromann
@christian-bromann
Yes excactly. .. we will from now on pin the cucumber versions .. this has happened for the second time now
Federico Francia
@federicoitaly:matrix.org
[m]
Hi, after upgrading from wdio6 to wdio7 I get this error: ERROR @wdio/local-runner: Failed launching test session: Error: Couldn't initialise "@wdio/cucumber-framework".
Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath './lib/formatter/helpers/event_data_collector' is not defined by "exports" in /Users/federicof/Documents/Automation/Mobile/WMobileBDD/node_modules/@cucumber/cucumber/package.json
@christian-bromann:
Christian Bromann
@christian-bromann
@federicoitaly:matrix.org see the post above, I will make a release with a fix in a second
Federico Francia
@federicoitaly:matrix.org
[m]
@christian-bromann: thank you, for now I downgrade to v7.1.0
Christian Bromann
@christian-bromann
I believe this doesn’t help
the release pipeline is already triggered
so it is a matter of minutes
release it out actually
Federico Francia
@federicoitaly:matrix.org
[m]
notarget No matching version found for webdriverio@7.5.1.
Erwin Heitzman
@erwinheitzman
@federicoitaly:matrix.org it's the wdio-cucumber-framework package that was updated
@wdio/cucumber-framework is the actual package name
Federico Francia
@federicoitaly:matrix.org
[m]
@er
@erwinheitzman: thanks, now I have these: "@babel/cli": "^7.12.8",
"@babel/preset-env": "^7.13.15",
"@cucumber/cucumber": "^7.1.0",
"@slack/web-api": "^6.1.0",
"@wdio/appium-service": "^7.3.1",
"@wdio/browserstack-service": "^7.3.1",
"@wdio/cli": "^7.3.1",
"@wdio/config": "^7.3.1",
"@wdio/cucumber-framework": "^7.3.1",
"@wdio/local-runner": "^7.3.1",
"@wdio/sauce-service": "^7.3.1",
"@wdio/spec-reporter": "^7.3.1",
"@wdio/sync": "^7.3.1",
Erwin Heitzman
@erwinheitzman
@federicoitaly:matrix.org @wdio/cucumber-framework was updated to v7.5.1
Federico Francia
@federicoitaly:matrix.org
[m]
ok
i get two warnings: npm i --legacy-peer-deps
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
Federico Francia
@federicoitaly:matrix.org
[m]
locally it works, from Jenkins I get: + npm i --legacy-peer-deps
npm ERR! code ETARGET
npm ERR! notarget No matching version found for webdriverio@7.5.1.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
Erwin Heitzman
@erwinheitzman
No matching version found for webdriverio@7.5.1. I refer to my previous answer
Federico Francia
@federicoitaly:matrix.org
[m]
yes, locally it works, from jenkins it fails
"dependencies": {
"@babel/cli": "^7.12.8",
"@babel/preset-env": "^7.13.15",
"@cucumber/cucumber": "^7.1.0",
"@slack/web-api": "^6.1.0",
"@wdio/appium-service": "^7.3.1",
"@wdio/browserstack-service": "^7.3.1",
"@wdio/cli": "^7.3.1",
"@wdio/config": "^7.3.1",
"@wdio/cucumber-framework": "^7.5.1",
"@wdio/local-runner": "^7.3.1",
"@wdio/sauce-service": "^7.3.1",
"@wdio/spec-reporter": "^7.3.1",
"@wdio/sync": "^7.3.1",
"colornames": "^1.1.1",
"eslint-config-airbnb-base": "^14.2.1",
"eslint-plugin-import": "^2.22.1",
"eslint-plugin-wdio": "^7.0.0",
"express": "^4.17.1",
"fs-extra": "^9.1.0",
"gherkin": "^5.1.0",
"jsonwebtoken": "^8.5.1",
"multiple-cucumber-html-reporter": "^1.18.0",
"rimraf": "^3.0.2",
"shelljs": "^0.8.4",
"sync-fetch": "^0.3.0",
"wdio-cucumberjs-json-reporter": "^2.0.2",
"webdriverio": "^7.3.1",
"yargs": "^16.1.1"
},
Christian Bromann
@christian-bromann
@federicoitaly:matrix.org you might want to clean up your package-lock.json
Federico Francia
@federicoitaly:matrix.org
[m]
yes I did it locally, and it works
from jenkins i get the error, strange
Christian Bromann
@christian-bromann
you need to check in your updated package-lock
your jenkins probably still pulls the old version
Federico Francia
@federicoitaly:matrix.org
[m]
it is in gitignore