Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Ghost
    @ghost~5c839e38d73408ce4fba1bf4
    hacked
    hacked
    hacked
    hacked
    hacked
    hacked
    hacked
    hacked
    hacked
    hacked
    hacked
    Rajpal Chauhan
    @raj-here
    Hi, How to handle multiple environments build in webpack
    as i'm using mongourl from env files
    my scripts are
    "build": "webpack",
    "build:prod": "NODE_ENV=production npm run build",
    "build:preprod": "NODE_ENV=preprod npm run build",
    "build:dev": "NODE_ENV=development npm run build",
    "build:stage": "NODE_ENV=stage npm run build",
    "start:preprod": "NODE_ENV=preprod node build/server.js",
    but when i'm running start:preprod always get
    process.env.NODE_ENV = 'production'
    Pradeep Kumar
    @startx88
    Hi any one tell me how to generate dist folder with webpack-dev-server in webpack 4
    i am writing code but not runing.
    package.PNG
    config.PNG
    Ryan Drew
    @ryandrew14
    Has anyone run into this before? schemas/WebpackOptions.json need to be updated
    I added an option to schemas/WebpackOptions.json
    When running yarn test. The functionality I added works as intended
    JiShuiMozi
    @JiShuiMozi
    @zyflying 你好
    Shanmugapriya
    @pvipriya
    Hi, I am new to webpack. I have a doubt. I do have situation where i dont want the build to be run when we click button from 'Xcode' IDE not to npm run build. how can i achieve this?
    buoyantair
    @buoyantair

    @buoyantair
    Hey folks!
    Im a little confused with setting up my env for webpack-cli
    I have done the following steps so far:

    npm i
    npm run bootstrap
    npm test

    Ideally this should first, install some of the dependencies like rimraf required to bootstrap the application with lerna and then npm test should test everything and make sure nothing is broken.
    But the last command fails, and gives me this log...
    https://pastebin.com/nKa4ihsn

    Nitin Kumar
    @snitin315
    try removing all the modules and cleaning the npm cache
    and run the same steps again with yarn?
    buoyantair
    @buoyantair
    @snitin315 Let me give it a try
    buoyantair
    @buoyantair
    I am still getting the same error
    The modules are not actually getting bootstrapped it looks like... it keeps saying "module not found"
    image.png
    Nitin Kumar
    @snitin315
    I had faced the same problem but This worked for me. How about trying a fresh installation?
    buoyantair
    @buoyantair
    Hmm
    It doesn't work
    I think I will just reclone once again
    buoyantair
    @buoyantair
    Guys?
    Can someone please help me?
    For whatever reason my tests are not properly runnin
    Here's the pastebin containing the console logs
    I even used yarn for this particular attempt
    Michael Gobz
    @michaelgobz
    @buoyantair i think its a problem with module pursing with node .. telling you that what you are requesting for is not there
    u try reinstallation or even reclone
    buoyantair
    @buoyantair
    oh welp
    I already tried doing that...
    I guess I will try it once more
    Michael Gobz
    @michaelgobz
    if it fails
    then shall see another solution to that