Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 03:03
    webpack-bot labeled #15239
  • 03:03
    dependabot[bot] labeled #15239
  • 03:03
    dependabot[bot] opened #15239
  • 03:03

    dependabot[bot] on npm_and_yarn

    chore(deps-dev): bump webpack-c… (compare)

  • 03:03

    dependabot[bot] on npm_and_yarn

    chore(deps-dev): bump eslint-pl… (compare)

  • 03:03

    dependabot[bot] on npm_and_yarn

    (compare)

  • 03:03
    dependabot[bot] closed #15178
  • 03:02
    webpack-bot labeled #15238
  • 03:02
    dependabot[bot] labeled #15238
  • 03:02
    dependabot[bot] opened #15238
  • Jan 24 03:06
    webpack-bot labeled #15234
  • Jan 24 03:06
    webpack-bot labeled #15235
  • Jan 24 03:04
    dependabot[bot] opened #15234
  • Jan 24 03:04
    dependabot[bot] opened #15235
  • Jan 24 03:04

    dependabot[bot] on npm_and_yarn

    chore(deps-dev): bump lint-stag… (compare)

  • Jan 24 03:03
    dependabot[bot] closed #15216
  • Jan 24 03:03

    dependabot[bot] on npm_and_yarn

    (compare)

  • Jan 24 03:03

    dependabot[bot] on npm_and_yarn

    chore(deps-dev): bump @babel/co… (compare)

  • Jan 24 03:02
    webpack-bot labeled #15233
  • Jan 24 03:02

    dependabot[bot] on npm_and_yarn

    chore(deps-dev): bump simple-gi… (compare)

Josh Rouwhorst
@joshrouwhorst
That looks like it works! Thank you for your help, @DavidArchibald! I appreciate it.
Luke Abby
@DavidArchibald
glad it helped
Gabriel Ayham Semaan
@Gabson1
Hey - could someone help me with some issues I am facing while upgrading webpack from 4 to 5?
Luke Abby
@DavidArchibald
sure what're the problems
Gabriel Ayham Semaan
@Gabson1
To keep my problem short, only certain pages render when I run the app in either dev mode or prod mode. For example, an action like logging in will result in Status Code:
{"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred"}
Luke Abby
@DavidArchibald
is this using some system that works around Webpack?
like create-react-app etc
Gabriel Ayham Semaan
@Gabson1
Here'S a gist of my webpack: https://gist.github.com/Gabson1/8a94f74e696dc052b2397b7d9771244b
no, it's a custom webpack, build from scratch
its a react - hapi app
I first posted my question on stackoverflow, but barely any help there (as always...). It includes some more issues and detail, may I post the link or not?
Luke Abby
@DavidArchibald
sure
Luke Abby
@DavidArchibald
did the commenter's point about polyfilling help at all?
regarding the buffer issue
Also are you able to traceback the error better? An internal server error could happen for many reasons, if you've updated dependencies besides webpack that could do it or if they worked with some other polyfills that suddenly don't exist etc
Gabriel Ayham Semaan
@Gabson1
I wasn't quite sure how to implement the fallback for buffer... my way did not work unfortunately

Webpack mentions that not the full error message is being displayed,

1 WARNING in child compilations (Use 'stats.children: true' resp. '--stats-children' for more details) 1 warning has detailed information that is not shown. Use 'stats.errorDetails: true' resp. '--stats-error-details' to show it.

however whatever I try, I can't get webpack to spit out some more info

Luke Abby
@DavidArchibald
iirc you have to do this:
module.exports = {
  //...
  stats: {
    children: true,
  },
};
might actually be different
Gabriel Ayham Semaan
@Gabson1
it's exactly what I tried, lemme do it one more time
Webpack still outputs the same message and no more details for my errors
Luke Abby
@DavidArchibald
What's your node version
Gabriel Ayham Semaan
@Gabson1
v14.15.4
npm is 6.14.10 if you want this info as well
Luke Abby
@DavidArchibald
I presume you tried errorDetails as well?
Gabriel Ayham Semaan
@Gabson1
yes
Luke Abby
@DavidArchibald
Yeah not sure what's going wrong with stats.children: webpack/webpack#12653
it's obstensibly fine in this issue and up to date documentation references it
Gabriel Ayham Semaan
@Gabson1
I know, my IDE even suggest all the additional options I have for outputting the stats
Luke Abby
@DavidArchibald
At this point it seems you're partially on the burden of large code and config. Could you strip out as much as you absolutely can from your configs and your code until you've gotten it down to the smallest amount that reproduces the problem? Traceback and everything is being especially tricky so what's superflous and what's not matters, including minimal code etc. This sounds like it's probably an error or several with dependent things. I'd suggest making an actual repo instead of a gist if possible as you'll want to include a package.json etc.
The problem has become a needle in a haystack and you're most well equipped to tear away at superflous stuff until you need help again.
Gabriel Ayham Semaan
@Gabson1
Hmm ok, then I will do just that. I hoped it might be something suer obvious :P
Thanks for your suggestion, I'll do that this evening.
Luke Abby
@DavidArchibald
Doesn't seem to be since it's indirected by several layers of lack of traceability
gotcha
Jonas Schumacher
@jonasmerlin
Hey! Quick question: the https://github.com/webpack-contrib/node-loader README stated that "node-loader only works on the node/electron-main/electron-main targets." Should that second electron-main read electron-renderer?
Luke Abby
@DavidArchibald
most likely. The easiest way to see would be to try if you need to.
James Bromwell
@thw0rted
Does anybody have tips for looking at build performance? I just did a big dep update yesterday, a couple of loaders had major-version updates, and I'm pretty sure my prod build time is roughly double what it was before. How can I tell what's taking so long?
Luke Abby
@DavidArchibald
I'd start with the speed-measure-plugin as a good starting point
From there you'll have to figure out what parts of the plugin are running slower which will be a bit harder
James Bromwell
@thw0rted
I think I looked at that a while back, they were taking a really long time to add Webpack 5 support. The NPM page you linked still says "all versions (1,2,3 and 4)"
James Bromwell
@thw0rted
Am trying it anyway, will see what happens
James Bromwell
@thw0rted

OK, first try failed. I have a webpack.base.js and webpack.prod.js. Prod imports a partial config from base, then uses webpack-merge to export the final combined options. I had export default WebpackMerge(baseConfig, prodConfig). I replaced this with

const merged = WebpackMerge(baseConfig, prodConfig);
const smp = new SpeedMeasurePlugin();
export default smp.wrap(merged);

As far as I can tell, that's supposed to work. Instead, I get errors for all CSS files that look like

Error: You forgot to add 'mini-css-extract-plugin' plugin (i.e. `{ plugins: [new MiniCssExtractPlugin()] }`)

but of course the prodConfig has that entry in plugins -- otherwise the build without SMP would not work

I'm re-running the old version, without SMP, just as a sanity check, but the build takes about 7 minutes now, which is of course why I'm trying to profile it in the first place
confirmed, it did work without SMP
James Bromwell
@thw0rted
OK, I made sure to console.log(merged) just to be absolutely sure that the resulting options-object has a plugins array that contains a MiniCssExtractPlugin instance, and it definitely does, so it feels like this is a webpack 5 support problem. The relevant issue is stephencookdev/speed-measure-webpack-plugin#149 which hasn't seen much activity, sadly
David Anderson
@yowzadave
Is it possible to create a webpack loader that can import all of the files in a directory? I've created a file "format" which is actually just a folder with files in it; the directory has an extension like file.myformat but is actually just a directory.
I get a "Module not found" error when attempting to import, i.e.
import file from "file.myformat"
David Anderson
@yowzadave
I could turn the format into a zip file...but I was hoping to not have to turn it into a binary file type
David Anderson
@yowzadave
to clarify the above—the "Module not found" error seems to be thrown before my loader function is ever even called