by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 21:54
    johnsonw synchronize #2107
  • 21:54

    johnsonw on build-targets

    Add target cache and update sta… (compare)

  • 20:37

    jgrund on test-fix-fmt

    (compare)

  • 20:37

    jgrund on master

    Fix cargo formatting of system … (compare)

  • 20:37
    jgrund closed #2131
  • 20:37
    jgrund synchronize #2047
  • 20:37

    jgrund on fs-name

    Move ActionType to iml_wire_typ… Bump elliptic from 6.5.2 to 6.5… Use a single lustre install ste… and 4 more (compare)

  • 20:13

    jgrund on unify-iml-configured

    (compare)

  • 20:13

    jgrund on master

    Tests: Unify iml-configured gra… (compare)

  • 20:13
    jgrund closed #2130
  • 18:09
    jgrund commented #2131
  • 17:48
    jgrund edited #2131
  • 17:48
    utopiabound review_requested #2131
  • 17:48
    utopiabound labeled #2131
  • 17:48
    utopiabound assigned #2131
  • 17:48
    utopiabound opened #2131
  • 17:47

    utopiabound on test-fix-fmt

    Fix cargo formatting of system … (compare)

  • 17:35

    utopiabound on cli-debugapi

    Add 'iml debugapi' to iml cli … (compare)

  • 17:20
    jgrund review_requested #2130
  • 17:20
    jgrund review_requested #2130
Joe Grund
@jgrund
@ahkumar Thanks :)
Amit Kumar
@ahkumar
@jgrund thank you!!
Amit Kumar
@ahkumar
@jgrund Wondering if this doc https://whamcloud.github.io/Online-Help/docs/Contributor_Docs/cd_Installing_IML_On_Vagrant.html is available offline? so I can work offline ?
Joe Grund
@jgrund

Not really. If you have IML installed, those docs are bundled in under the help link, but I suspect you want a standalone solution.

We have an open that describes a way to do so (which we plan to automate) here: whamcloud/Online-Help#142

But there are also plugins available that can download webpages for you in Chrome or Firefox if you want to go that route.

Amit Kumar
@ahkumar
@jgrund Cool will try other options you mention, thank you!!
Alex Talker
@AlexTalker
@jgrund whamcloud/device-scanner#270 We checked and udev event is triggered on closing multipath device only on systems with IML. I asked to find out why systemd-udevd actually triggers the event.
Joe Grund
@jgrund
Ok, I’ll take a look
Amit Kumar
@ahkumar
@jgrund : i have a vagrant setup of the latest IML. Interestingly after I resized my MDT to a bigger disk size, I am not able to see the updated MDT size when I am selecting disks to create a file system. How can I get IML to redetect the targets to find its correct size. On the mds host itself I can see the disk size to be the updated size but not in the web interface?
Joe Grund
@jgrund
@ahkumar Is this a ZFS or ldiskfs setup?
Amit Kumar
@ahkumar
@jgrund ldiskfs
Joe Grund
@jgrund
Using the mpath devices?
Amit Kumar
@ahkumar
yup
Joe Grund
@jgrund
How are you expanding the disk?
Amit Kumar
@ahkumar
I removed the original mdt created by initial setup: and then created a new fixed disk and attached it to stat controller port where the original disk was connected on the iscsi host
*sata controller port
Joe Grund
@jgrund
This is all while IML was running?
Amit Kumar
@ahkumar
Yes
Joe Grund
@jgrund
Ok. Can you look at the output of echo '"Stream"' | socat - UNIX-CONNECT:/var/run/device-scanner.sock | jq (you may need to install jq) on the storage node the iscsi target is attached to?
And check to see that the size is as you expect for that device
Amit Kumar
@ahkumar
should I run the above on adm host?
i mean iscsi host?
Joe Grund
@jgrund
on mds1
or mds2
Amit Kumar
@ahkumar
I confirm that the size reported by the above command: "size": "10737418240" is the correct size 10G original setup i had trimmed it down 1G; So that looks good. Is it just the browser cache may be?
Amit Kumar
@ahkumar
ls
Amit Kumar
@ahkumar
@jgrund you can ignore my request. When I click into the details of the MDT i see that it says 10G. but the mdt selection page was incorrectly reporting it. In any case this is minor and not worry about. thank you for guiding. I am liking this new IML.
Joe Grund
@jgrund
Ok. If you can open an issue with screenshots of the bug we will look into it further.
Alex Talker
@AlexTalker
@jgrund In this PR whamcloud/device-scanner#279 you changed master code for device-scanner. But as far as I know, this version is not available in repository for IML 5.0. When this version will be available there?
Joe Grund
@jgrund

It’s going to be a few weeks until I can get it promoted to 5.0.

I need to make sure the new version works well enough for managed and monitored modes and upgrades.
I think I have managed mode working well, I need to spend some time now making sure monitored mode works.

There are patches on the agent and manager sides as well that will need to land:

whamcloud/iml-agent#98
whamcloud/integrated-manager-for-lustre#947

@jgrund From here? https://copr-be.cloud.fedoraproject.org/results/managerforlustre/device-scanner-devel/epel-7-x86_64/

Yes, that’s where the devel patches are being built

Alex Talker
@AlexTalker
I'm just hanging around this problem with "VolumeNode does not exists" problem but I'm going on a vacation next week. So I would really like to resolve the problem before it but since I debug only monitored mode, your current direction of resolving this issue is a bit deviated from mine
Which arises a problem that we look on different behavior directions
Also, as you might seen, this problem with volumes in UI hasn't been fixed for me.
Joe Grund
@jgrund
@AlexTalker can you share the rows in the database where you are seeing the VolumeNode error?
I’ll start integrating monitored mode support this week
Alex Talker
@AlexTalker
@jgrund Yeah, sure, just let me reproduce it
@jgrund Today I updated all agent-side code to packages for 5.0 as it seems to be fresher than devel repo, so now I haven't checked if the case still can be reproduced
Amit Kumar
@ahkumar
@jgrund i have an older 4.x install of IML that I am trying to wipe clean and upgrade. Can I just wipe the OS and install the NEW IML without having to remove the servers from the 4.x IML? I am just being careful/worries in case the agents on the production server that were added in monitoring mode will start behaving oddly if i were to add them back to the newly installed IML 5.x ?
Joe Grund
@jgrund
@ahkumar wipe the manager node OS?
Amit Kumar
@ahkumar
@jgrund yes wipe the manager nodes OS only, lustre server OS will remain as is as they are production ;)
node*
Joe Grund
@jgrund
You shouldn’t need to wipe the manager OS, just update it in place
What version OS are you running?
Amit Kumar
@ahkumar
@jgrund running 4.1.5 and centos 7.4 on the Lustre servers and centos 7.5 on IMLmanager node. Reason I want to wipe clean is the current IML manager node that I previously attempted with 4.x is in state where no action is allowed for me to even remove the production lustre server which were added in monitoring mode. Given this manager node is in the state I thought it would be nice for a clean install
Amit Kumar
@ahkumar
@jgrund If it does not hurt wiping clean I would prefer that, rather than digging through any issues after the upgrade . But my only concern is if this could pose any issues? if then I will follow the upgrade path?
Alex Talker
@AlexTalker
@ahkumar I'd rather recommended removing all nodes from IML if you want re-install. If you just shutdown IML server node without de-registering agents, this might lead to interesting behavior I think.
Amit Kumar
@ahkumar
image.png
@AlexTalker thank you for the note. But current state of my monitoring only install of IML is such that I cannot remove the nodes. The action button is grayed out. Any other way to de-register the agents?
Alex Talker
@AlexTalker
@ahkumar Is there no button "Force remove"?