Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Elliot Murphy
    @statik
    aha! that would explain it
    thanks a million for all the help on this. Excited to get it running!
    David Baldwynn
    @whitef0x0
    just updated the dockerhub image
    should work now
    Elliot Murphy
    @statik
    cool, pulling now
    sweeet, it works!
    David Baldwynn
    @whitef0x0
    Awesome!
    David Baldwynn
    @whitef0x0
    @statik let me know if you have any problems with the api
    docs for it are at http://api.tellform.com
    David Baldwynn
    @whitef0x0
    Also @statik you might want to turn off user signups with the SIGNUPS_DISABLED env variable
    Deepanshu Sinha
    @sinhaDroid
    Hi, I am unable to setup tell form
    getting this error
    /home/deepanshu/git/tellform/node_modules/.bin/touch: Syntax error: "(" unexpected
    Deepanshu Sinha
    @sinhaDroid

    here it getting stopped
    bcrypt@0.8.7 install /home/deepanshu/git/tellform/node_modules/bcrypt

    node-gyp rebuild

    make: Entering directory '/home/deepanshu/git/tellform/node_modules/bcrypt/build' CXX(target) Release/obj.target/bcrypt_lib/src/blowfish.o /home/deepanshu/git/tellform/node_modules/.bin/touch: 1: /home/deepanshu/git/tellform/node_modules/.bin/touch: Syntax error: "(" unexpected bcrypt_lib.target.mk:96: recipe for target 'Release/obj.target/bcrypt_lib/src/blowfish.o' failed make: *** [Release/obj.target/bcrypt_lib/src/blowfish.o] Error 2 make: Leaving directory '/home/deepanshu/git/tellform/node_modules/bcrypt/build' gyp ERR! build error gyp ERR! stack Error: `make` failed with exit code: 2 gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23) gyp ERR! stack at emitTwo (events.js:106:13) gyp ERR! stack at ChildProcess.emit (events.js:194:7) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12) gyp ERR! System Linux 4.4.0-72-generic gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /home/deepanshu/git/tellform/node_modules/bcrypt gyp ERR! node -v v7.8.0 gyp ERR! node-gyp -v v3.5.0 gyp ERR! not ok

    Vishal Gangwar
    @iit2011081
    I run this command docker run -d -p 3000:3000 --name tellform tellform/development . After downloading something the result was
    Digest: sha256:3dc5cb4bc9e120aae54cb2ed0b7ca0480f6bb6629fc955c4d6c0d849554f7e10
    Status: Downloaded newer image for tellform/development:latest
    8eb81df34626bd5c414fb436d56c3372993f3052ba331962db6f29da34914033
    but nothing happen after that. How can I see it ?
    David Baldwynn
    @whitef0x0
    @iit2011081 did you go to your browser at localhost:3000?
    You should see the app there.
    @sinhaDroid this is due to GCC/C compiler errors
    Deepanshu Sinha
    @sinhaDroid
    should i have to install gcc/c compiler?
    i have removed bcrypt and using this "bcrypt-nodejs": "0.0.3", in package.json
    Deepanshu Sinha
    @sinhaDroid
    the code you have pushed.. is it working ?
    @whitef0x0
    Deepanshu Sinha
    @sinhaDroid
    I am getting this error now
    (node:27989) DeprecationWarning: node --debug is deprecated. Please use node --inspect instead. Debugger listening on 127.0.0.1:5858 /home/deepanshu/git/tellform/node_modules/bindings/bindings.js:83 throw e ^
    Error: The module '/home/deepanshu/git/tellform/node_modules/bcrypt/build/Release/bcrypt_lib.node'
    was compiled against a different Node.js version using
    NODE_MODULE_VERSION 47. This version of Node.js requires
    NODE_MODULE_VERSION 51. Please try re-compiling or re-installing
    the module (for instance, using `npm rebuild` or`npm install`).
    Vishal Gangwar
    @iit2011081
    Now I am able to run code locally, I want to know how can I use the apis
    Vishal Gangwar
    @iit2011081
    after taking latest pull this line is giving me error
    /tellform/config/config.js:85
    js_assets = this.assets.js;
    David Baldwynn
    @whitef0x0
    @iit2011081 I've fixed the error
    @iit2011081 you mean the official api?
    @sinhaDroid you need to run npm rebuild
    and reinstall bcrypt with your current nodejs version
    Deepanshu Sinha
    @sinhaDroid
    Thanks @whitef0x0 it's working now
    Michael Medin
    @mickem
    Quick question: slightly confused by the docker thingy... whats the postgress details for? (only links docker containers for mongo and redis?) Should I have a postgress one as well?
    David Baldwynn
    @whitef0x0
    @mickem you shouldn't need to use postgres
    Michael Medin
    @mickem
    @whitef0x0 Yeah, I actually figure that out... when I google the command sample and noticed the docker sample was taken verbatim from another product... Might wanna remove the POSTGRES keys from the docker command line in the readme...
    Ezeh Uche
    @Ezehuche
    Hello @whitef0x0, please can give me give step by step installation of tellform on windows 10. Thanks
    David Baldwynn
    @whitef0x0
    @mickem Just fixed. Thanks for pointing that out! Sorry about the confusion caused by it
    David Baldwynn
    @whitef0x0
    @Ezehuche To start do you have Linux Bash Shell installed (if not check out this link for installation instructions https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/)
    Ezeh Uche
    @Ezehuche
    @whitef0x0 I have installed Linux Bash Shell, What's next?
    Vishal Gangwar
    @iit2011081
    is checkbox option in feature pipeline ?
    Vishal Gangwar
    @iit2011081
    on my aws server every time it is saying authentication error and when I try to create a new a/c with any email it says user already exist. On my local machine it is working. What could be the reason ? Is it because it is unable to connect to mongo ?
    Vishal Gangwar
    @iit2011081
    I want to add a new field in setting page so I changed in modules/users/view/settings/edit-profile.client.view.html but it is not reflecting. Where else do I need to change?
    Xshuozi
    @Xshuozi
    hi,i want to install the tellform on my vps but my vps didn't allow me use the docker.What should i do?
    @whitef0x0
    Vishal Gangwar
    @iit2011081
    i want to show same form in android app I am using same login, but I don't know how to use session/cookies so that other apis don't give unauthorized error.
    Vishal Gangwar
    @iit2011081
    why fieldOptions property is empty in case of yes_no ? As it is also a type of radio option so It should also contain fieldOptions like radio.
    abdul-ahad
    @abdul-ahad
    Hi Guys....I am trying to install tellform on my machine
    I get this error, when I am did : npm install
    Failed at the bcrypt@0.8.7 install script 'node-gyp rebuild'.
    any advise?
    Michael Medin
    @mickem
    @whitef0x0 How well tested are the docker container? I just gave it another shot but cant realy get anything to work... when booting is spews hundreds of errors... production images crashes and wont start... develop image starts but when I browse it redirect to /#!/forms and the webpage says "Page not found" "is not a valid path"...
    ohh... just saw "The Docker file is out of date and does not work"... so I guess that answers my question...