Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Felipe Vieira Almeida
    @fvalmeida
    Screenshot 2017-07-06 06.57.49.png
    David C.
    @Kalcode
    Hey guys
    Just checking out tellform, looking for something to replace Wufoo thats self-hosted.
    Had a few questions if anyone doesn't mind
    Can I use this as an API? So i can ajax my form submissions? Also what about file upload input? Is that supported currently? If so is there an integration for saving those files on a storage service like S3 bucket?
    José Luis Di Biase
    @josx
    @fvalmeida some days ago tellform merged some PR that fix your issue
    jsinn3
    @jsinn3
    Hi guys is this working for you?
    David Baldwynn
    @whitef0x0
    @Kalcode yep we have an api integrated with tellform
    docs are at api.tellform.com
    spali90
    @spali90
    I was trying to install tell form on ubuntu 14.04. grunt build does not work for me, gives error Warning: Task "jshint:all" failed. Used --force, continuing.
    David Baldwynn
    @whitef0x0
    @spali90 you should still be able to install it if jshint fails
    @spali90 can you pull from master and try again?
    Leonard Loo
    @leonardloo
    Hi I'm having issues with building my own docker image and running it
    after building it, and running it i get a Error: listen EADDRINUSE :::20523
    Do I just build with docker build -t tellform -f ./Dockerfile . and run with docker run -it tellform?
    tinxx
    @tinxx
    Hey guys, I set up tellform using docker and now I'm wondering how to log into the web ui. Is there a default user or something?
    Also I'm getting this error when I try creating a new account: ValidatorError: Path username is required.
    Leonard Loo
    @leonardloo
    @tinxx may i ask how you set up tellform locally with docker? when i built it and ran it according to the commands in the docker file, i hit localhost:3000 and got angular not loaded in my console
    Caio Augusto Peixer da Silva
    @caiooaugusto
    Hi, i'm trying to install tellform on heroku with "auto deploy" button in tellform website, but i'm getting this errors
    image.png

    "/tmp/build_b536cd132a46eb5122e9f1dcd82d294f/tellform-tellform-3a349a3/.heroku/node/bin/node" "/tmp/build_b536cd132a46eb5122e9f1dcd82d294f/tellform-tellform-3a349a3/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
    node-pre-gyp ERR! cwd /tmp/build_b536cd132a46eb5122e9f1dcd82d294f/tellform-tellform-3a349a3/node_modules/v8-debug
    node-pre-gyp ERR! node -v v8.2.1
    node-pre-gyp ERR! node-pre-gyp -v v0.6.36
    node-pre-gyp ERR! not ok
    Failed to execute '/tmp/build_b536cd132a46eb5122e9f1dcd82d294f/tellform-tellform-3a349a3/.heroku/node/bin/node /tmp/build_b536cd132a46eb5122e9f1dcd82d294f/tellform-tellform-3a349a3/.heroku/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/tmp/build_b536cd132a46eb5122e9f1dcd82d294f/tellform-tellform-3a349a3/node_modules/v8-debug/build/debug/v0.7.7/node-v57-linux-x64/debug.node --module_name=debug --module_path=/tmp/build_b536cd132a46eb5122e9f1dcd82d294f/tellform-tellform-3a349a3/node_modules/v8-debug/build/debug/v0.7.7/node-v57-linux-x64' (1)
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! v8-debug@0.7.7 install: node-pre-gyp install --fallback-to-build
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the v8-debug@0.7.7 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

       npm ERR! A complete log of this run can be found in:
       npm ERR!     /app/.npm/_logs/2017-07-31T23_50_53_069Z-debug.log

    -----> Build failed

       We're sorry this build is failing! You can troubleshoot common issues here:
       https://devcenter.heroku.com/articles/troubleshooting-node-deploys
    
       Some possible problems:
    
       - Dangerous semver range (>) in engines.node
       https://devcenter.heroku.com/articles/nodejs-support#specifying-a-node-js-version
    
       Love,
       Heroku

    ! Push rejected, failed to compile Node.js app.
    ! Push failed

    David Baldwynn
    @whitef0x0
    @caiooaugusto should be fixed now
    Ben Flowers
    @benoj
    Hey, Im intesresting in using tellform to build forms for my clients – is there an API for creating forms from my application similar to typeform api?
    Leonard Loo
    @leonardloo
    Hey guys, i'm facing some issues deploying tellform to production (AWS EC2), is it as simple as just building straight from the Dockerfile-production? OR do i have to run any steps before that?
    David Baldwynn
    @whitef0x0
    @benoj yep
    @benoj you can view the API specs here https://api.tellform.com/
    @leonardloo It's not really recommended to deploy using Docker
    Currently the .env files are being stored in the docker image which isn't ideal
    @leonardloo maybe email me at team@tellform.com and we can continue this over email?
    Leonard Loo
    @leonardloo
    @whitef0x0 emailed you
    Leonard Loo
    @leonardloo
    @whitef0x0 there's a critical error in your grunt build. When you delete the public/dist folder and re-run grunt build your code no longer works. Please look into that ASAP.
    Parth Jaggi
    @parthjaggi
    Could anyone tell me the use for socket.io and redis?
    Why can't analytics be stored in mongoDb itself
    Parth Jaggi
    @parthjaggi
    in dev mode, tellform doesn't send visitordata to socket.io, anyway to enable that
    Marc Grondin
    @grondinm
    Hello. I have tellform setup on ubuntu server using docker. Everything seems to work ok but when i export the form results as a CSV Some data is missing causing the data to not line up. Looking at the CSV it seems the data for the second field (Tittled #) is not exported...
    Gustavo Schirmer
    @hurrycaner
    Hi there, i'm trying to install tellform to heroku... should i set SOCKET_URL to <myapp>.herokuapp.com?
    I've tried setting that as <myapp>.herokuapp.com, then i've tried to create an user, but i got an error message: "[object Object]"
    Gustavo Schirmer
    @hurrycaner
    Nobody? :\
    David Baldwynn
    @whitef0x0
    @parthjaggi socketIO is used for analytics
    Redis is used for cluster mode (see pm2 docs)
    @hurrycaner no you don't need to set it to that
    You need to set your BASE_URL
    not SOCKET_URL
    Gustavo Schirmer
    @hurrycaner
    base_url is set to <myapp>.herokuapp.com, should i leave socket_url blank?
    MasinAD
    @MasinAD
    hello! just started trying the docking image once again. when registering an account there's a 400 error in the console and registration fails. does anyone know what happened?
    David Störcher
    @DrGanmon
    hey, i have a Problem with the current master, if i try do load the side, static files in the 'lib' folder return 404. every other static file work perfect
    Polynomendivision
    @Polynomendivision

    Hey guys, I would like to deploy tellform locally with the docker image. First of all jshint:all fails, cause he finds a load of errors (first task failes with 1218 errors in 140 files). He finds errors like url = require)'url'); <- 'require' is not defined
    Then i can still access the login page via localhost:3000 in my browser, but i cant even sign up. When i open the site, this is what the debugger lists me:
    GET / 304 100.186 ms - -
    GET /static/lib/bootstrap/dist/css/bootstrap.min.css 304 5.851 ms - -
    like 200 lines of this.

    Someone got any advice for me)
    My stats: running docker on 16.04 ubuntu with latest version of docker-ce

    modiplus91
    @modiplus91
    Hello everyone
    modiplus91
    @modiplus91
    I am deploying tellfrom to my local Machine.
    It is working fine but on creating new form it is not showing any options like for multiple choice