by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 14 18:14
    dependabot[bot] labeled #1090
  • Sep 14 18:14

    dependabot[bot] on maven

    Bump ant from 1.10.7 to 1.10.8 … (compare)

  • Sep 14 18:14
    dependabot[bot] opened #1090
  • Sep 05 03:05
    sksamuel closed #945
  • Aug 27 12:49
    StefanKruk edited #1089
  • Aug 27 12:38
    StefanKruk edited #1089
  • Aug 27 11:59
    StefanKruk opened #1089
  • Jul 11 19:48
    sewe opened #1088
  • Jun 11 09:38
    hbourada edited #1087
  • Jun 11 09:35
    hbourada edited #1087
  • Jun 11 09:34
    hbourada edited #1087
  • Jun 11 09:34
    hbourada edited #1087
  • Jun 11 09:33
    hbourada opened #1087
  • May 23 17:49
    Crydust opened #1086
  • Feb 19 11:45
    alexo commented #987
  • Feb 18 20:14
    trajano commented #987
  • Feb 14 13:07
    alexo milestoned #1039
  • Feb 14 13:07
    alexo demilestoned #1039
  • Feb 13 13:58
    alexo milestoned #1075
  • Feb 13 13:58
    alexo milestoned #1077
Scott Busche
@busches
We're at the end of a large project and there's no time to change the entire build system
Alex Objelean
@alexo
I see
Scott Busche
@busches
Goal state is maven, but that'll probably be an entire project itself
yay enterprise
Alex Objelean
@alexo
I know, I work for enterprise projects as well :)
related to your issue: I could add a quick fix for this issue ... but I would rather would like to understand why this happens and fix the root cause, rather than applying quick & dirty fix
Scott Busche
@busches
Sounds good
Alex Objelean
@alexo
@busches do you see any other exceptions in logs when the build fails?
I assume that one of the processor fails for a similar reason
I'm not yet able to reproduce the problem in isolation
it would be nice to have as much info as possible which would help me to reproduce it
otherwise I can never be sure the problem is actually fixed
Scott Busche
@busches
Nope, that's the only one
Scott Busche
@busches
@alexo you're right on it being a fluke that we had seen so many successes, seems to be back to randomly failing/passing again. Always the same error with isIgnoreFailingProcessor being the call
Alex Objelean
@alexo
@busches I'll do my best to identify the problem
if you have any relevant info which could help me reproduce the issue, let me know
Scott Busche
@busches
Nope, just fails on the group processing each time and we don't have a way to reliably reproduce it either
Raj
@rajjaiswalsaumya
any sample to use wro4j autoconfiguration with springboot
?
i added jar into classpath and hope it should run optimisation, but it didnt as debug logs are not showing properties i overriden in application.yml
Alex Objelean
@alexo
The springboot is not officially supported, but there are several contributions which aims to fill this gap: https://github.com/sbuettner/spring-boot-autoconfigure-wro4j
Marcus Lim
@Maraket
Is there anywhere an example of how to use the PlaceholderProcessor (as in how to actually load it into the stack of preprocessors)
Marcus Lim
@Maraket
Figured it out :)
islam drissi
@zirconias
hi there , is there a way to do some hot reloads and builds like webpack ?
Alex Objelean
@alexo
hi @zirconias
I don't know much about webpack, but there are the following options:
either use runtime solution which detects the change automatically
or use the m2e-wro4j eclipse plugin
which triggers the maven plugin whenever a change is detected
I none of the above is good enough, feel free to open an issue
with detailed description of the feature
islam drissi
@zirconias
hi @alexo thanks for your quick reply,
i'm somehow beginer in the stack ,
what i think i go for is just , separate concerns, i'll go for a front-end stack using gulp or webpack.
i think that wro4j is best choice if we use server side templating ,there we'll need css/js in the same java project. but in my case i don't realy know !!!!
i'll stack when i start using typescript. (i don't know if wro4j have a processor to transpile it)
Guido Pochettino
@guidopochettino_twitter
Hello Everyone, I would like to add some missing fonts of bootstrap using wro to the final package. Is there any documentation on that?
Guido Pochettino
@guidopochettino_twitter
I fixed it by adding a mvn plugin to unpack the fonts and include it in the context folder
Luís Duarte
@driverpt
Hello guys
did anyone manage to get wro4j working with SASS and LESS ?
namely the @import thingy
Luís Duarte
@driverpt
anybody ?
ahhhkah
@ahhhkah
Hi guys,
I have a problem using WRO as a runtime filter. The css and js is generated correctly, but on every request the ResourceWatcher is reporting "The FacesServlet cannot have a url-pattern of /. Please define a different url-pattern.". I have tried different versions, enabled and disabled almost everything in the web.xml (there is no "/") and now I am running out of ideas. Anyone has a clue what the problem might be?
Alex Objelean
@alexo
@driverpt there are some known issues when using import with sass & less... but it would help if you could raise an issue with a detailed description of your particular case
when using less, prefer using less4j processor
since it is the most mature and stable one
the sass has 2 implementations: one based on ruby and onother based on js
@ahhhkah the error is exactly what you could receive by invoking the endpoint directly from browser
Alex Objelean
@alexo
Unless I see your web.xml
I can tell what exactly is wrong
ahhhkah
@ahhhkah
Hi @alexo , thank you for your answer. We switched to the maven plugin for now. Works perfectly!
Anton Barkan
@AntonBarkan
Hi. I want to use wro4j with angular 2 . Can someone to point me some information how to do it? I try to minimize javascript code with jsMin but it falls.
Peter E Olsen III
@hepaestus
I am using Maven to include a JqGrid Webjar in my project. I am also using WRO. What should the path in my wro.xml file be for the jqgrid.js files?