Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    tavasti
    @tavasti
    Thanks!
    tavasti
    @tavasti
    Not getting it working right away, need to add some debug prints to see what is happening
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Strange...
    tavasti
    @tavasti
    I think it is pretty normal that I don't get all working with first try
    tavasti
    @tavasti
    Ok, now I got volume to right zone, then need to handle also instance. This is progressing, but unfortunately running out of time for today, continuing tomorrow
    Would it be wanted for main branch, and what is workflow, that gerrit?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]

    https://docs.opendev.org/opendev/infra-manual/latest/developers.html

    You need to create a gerrit account, install git-review and that is all

    tavasti
    @tavasti
    Ok, I'll check
    Thanks for help
    tavasti
    @tavasti
    I got that VMTasks.boot_runcommand_delete running, server part worked ok once it had proper parameters
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    \ะพ/
    Konstantin Ivanov
    @o1o1o11o1_twitter
    Hey guys, how do you specify a network id when using NovaServers.boot_and_delete_server ? I get a 409 when multiple networks exist: Conflict: Multiple possible networks found, use a Network ID to be more specific. (HTTP 409)
    Konstantin Ivanov
    @o1o1o11o1_twitter
    never mind, I figured it out
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Oops, sorry. I saw your message late at night and decided to answer at the morning...
    Konstantin Ivanov
    @o1o1o11o1_twitter
    ah no worries
    Konstantin Ivanov
    @o1o1o11o1_twitter
    basically had to add a network section with start_cidr stanza specifying a subunet range and it seems to pick the correct network based on that
    ansao-aci
    @ansao-aci
    Hi All, Can anyone pls point me to datapath tests of security group ?
    Jaan Vaks
    @elx-vax:matrix.org
    [m]

    When I run docker run -v /my/rally/volume/rally:/home/rally/.rally xrally/xrally-openstack:2.1.0' verify create-verifier --type tempest --name tempest-verifier I get a git clone error.
    "2021-10-11 13:39:13.845 1 ERROR rally.verification.utils [-] Error output: 'Cloning into '/home/rally/.rally/verification/verifier-e18dac62-1d56-4418-aa07-bd836904ab31/repo'...
    fatal: unable to access 'https://opendev.org/openstack/tempest/': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
    ': subprocess.CalledProcessError: Command '['git', 'clone', 'https://opendev.org/openstack/tempest', '/home/rally/.rally/verification/verifier-e18dac62-1d56-4418-aa07-bd836904ab31/repo']' returned non-zero exit status 128."

    Am I doing something wrong or can someone confirm and reproduce this error?

    Jaan Vaks
    @elx-vax:matrix.org
    [m]

    :point_up: Edit: When I run docker run -v /my/rally/volume/rally:/home/rally/.rally xrally/xrally-openstack:2.1.0 verify create-verifier --type tempest --name tempest-verifier I get a git clone error.
    "2021-10-11 13:39:13.845 1 ERROR rally.verification.utils [-] Error output: 'Cloning into '/home/rally/.rally/verification/verifier-e18dac62-1d56-4418-aa07-bd836904ab31/repo'...
    fatal: unable to access 'https://opendev.org/openstack/tempest/': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
    ': subprocess.CalledProcessError: Command '['git', 'clone', 'https://opendev.org/openstack/tempest', '/home/rally/.rally/verification/verifier-e18dac62-1d56-4418-aa07-bd836904ab31/repo']' returned non-zero exit status 128."

    Am I doing something wrong or can someone confirm and reproduce this error?

    :point_up: Edit: When I run docker run -v /my/rally/volume/rally:/home/rally/.rally xrally/xrally-openstack:2.1.0 verify create-verifier --type tempest --name tempest-verifier I get a git clone error.
    "2021-10-11 13:39:13.845 1 ERROR rally.verification.utils [-] Error output: 'Cloning into '/home/rally/.rally/verification/verifier-e18dac62-1d56-4418-aa07-bd836904ab31/repo'...
    fatal: unable to access 'https://opendev.org/openstack/tempest/': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
    ': subprocess.CalledProcessError: Command '['git', 'clone', 'https://opendev.org/openstack/tempest', '/home/rally/.rally/verification/verifier-e18dac62-1d56-4418-aa07-bd836904ab31/repo']' returned non-zero exit status 128."

    Am I doing something wrong or can someone confirm and reproduce this error?

    EDIT: I suppose you need to create a database first hand in the volume specified.

    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Hm... I see such error first time..
    Probably, we need to rebuild the rally-openstack image to take the latest ca-certificates
    1 reply
    No need, I will propose a new release later today or tomorrow and it should automatically build a new image
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    In the meantime I've been trying to override the tempest config to disable ssl_verification https://github.com/openstack/rally-openstack/blob/master/rally_openstack/verification/tempest/config.py#L147-L150
    but i can't find a way to pass the new tempest config.
    to use the rally verify configure-verifier --reconfigure i have to have an "installed" verifier which i never get to since the original command fails.
    anyone know how to set the disable_ssl_certificate_validation option for tempest?
    when running in the docker xrally/xrally-openstack
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    Don't want to seem pushy or annoying but is there anything I can do to speed up the release of a new image? Can I help in testing in any way?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Thanks for reminder
    I'll work on updating release notes right now
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Jaan Vaks: soo, we need to wait till https://review.opendev.org/c/openstack/rally-openstack/+/814965 is merged (it will happen as soon as it passed ci) and I'll ask openstack team to release rally-openstack package
    1 reply
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    I just tested the xrally-openstack:latest and it has the same problem as before. Is the "git cert" problem included in this fix?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Hm. Strange.
    I thought that building a new package with updated system certs should solve the issue
    *building a new image
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Jaan Vaks: the new version of latest should work now
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    awesome
    hmm. At first glance I seem to get the same error
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Try to update the local image
    this line should fix an issue
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    yes nice that works!
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    great
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    when will this reach xrally/xrally-openstack on docker hub?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    latest tag should be already updated and new tag will be cut as soon as the following change will be merged
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Jaan Vaks: 2.2.0 is released and is available at dockerhub
    Anil
    @venkataanil
    @andreykurilin:matrix.org I have opened this bug https://bugs.launchpad.net/rally/+bug/1956956 do I need to create a card in trello https://trello.com/b/DoD8aeZy/rally ?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    @venkataanil: hi! thanks for detailed bug report. no need in trello, I'll try to check this bug soon