Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    to use the rally verify configure-verifier --reconfigure i have to have an "installed" verifier which i never get to since the original command fails.
    anyone know how to set the disable_ssl_certificate_validation option for tempest?
    when running in the docker xrally/xrally-openstack
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    Don't want to seem pushy or annoying but is there anything I can do to speed up the release of a new image? Can I help in testing in any way?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Thanks for reminder
    I'll work on updating release notes right now
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Jaan Vaks: soo, we need to wait till https://review.opendev.org/c/openstack/rally-openstack/+/814965 is merged (it will happen as soon as it passed ci) and I'll ask openstack team to release rally-openstack package
    1 reply
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    I just tested the xrally-openstack:latest and it has the same problem as before. Is the "git cert" problem included in this fix?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Hm. Strange.
    I thought that building a new package with updated system certs should solve the issue
    *building a new image
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Jaan Vaks: the new version of latest should work now
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    awesome
    hmm. At first glance I seem to get the same error
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Try to update the local image
    this line should fix an issue
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    yes nice that works!
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    great
    Jaan Vaks
    @elx-vax:matrix.org
    [m]
    when will this reach xrally/xrally-openstack on docker hub?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    latest tag should be already updated and new tag will be cut as soon as the following change will be merged
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    Jaan Vaks: 2.2.0 is released and is available at dockerhub
    Anil
    @venkataanil
    @andreykurilin:matrix.org I have opened this bug https://bugs.launchpad.net/rally/+bug/1956956 do I need to create a card in trello https://trello.com/b/DoD8aeZy/rally ?
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    @venkataanil: hi! thanks for detailed bug report. no need in trello, I'll try to check this bug soon
    Anil
    @venkataanil
    thanks Andrey
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    @venkataanil: should fix described issue - https://review.opendev.org/c/openstack/rally/+/823996
    Anil
    @venkataanil
    @andreykurilin:matrix.org thanks for the quick fix. That looks perfect.
    Asma Suhani S H
    @asyedham
    @andreykurilin:matrix.org I have opened a bug https://bugs.launchpad.net/rally/+bug/1957763
    and submitted the fix https://review.opendev.org/c/openstack/rally-openstack/+/824521
    Could you please have a look
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    @asyedham: hi! thanks for posting a fix for an issue. I'll check it as soon as find a fix for functional job that is broken now
    Asma Suhani S H
    @asyedham
    hi @andreykurilin:matrix.org sure, thanks!
    endjoker
    @endjoker
    Hi all, I want to use constant_for_duration for rally tool test like
    NovaServers.boot_and_delete_server:
    -
    args:
    flavor:
    name: m1.tiny
    image:
    name: cirros-aarch64.qcow2
    force_delete: false
    runner:
    type: "constant_for_duration"
    duration: 30
    concurrency: 1
    timeout: 10
    context:
    users:
    tenants: 1
    users_per_tenant:
    sla:
    failure_rate:
    max: 0
    But I run it and it prompts “TypeError: 'NoneType' object is not callable ”. My rally version is 1.1.0 and I don't know what my problem is?
    2022-01-17_16-08-29.bmp
    Andrey Kurilin
    @andreykurilin:matrix.org
    [m]
    @endjoker: I heard about such problem on macos version of python. using a vm or a container should solve an issue
    endjoker
    @endjoker
    @andreykurilin:matrix.org Thank you for your answer. I am using a container environment on a Linux system. I learned from Google that the cause of this problem is the multiocessing.pool function due to multiprocessing. python version 3.4 solves this problem, is there any way I can modify the python environment where the rally tool is running? Downloading the latest version of python directly does not solve the problem.
    rajeshP524
    @rajeshP524
    Hi all,
    In the latest openstack-rally code, it is not expecting 'remote_group_id' as an argument for creating a security group rule.
    can someone explain why?
    https://github.com/openstack/rally-openstack/blob/1c470d56f4dd63374f41f7b243092b0a0751a22f/rally_openstack/common/services/network/neutron.py#L1222
    Swogat Pradhan
    @swogat:matrix.org
    [m]
    Hi, i am trying to setup openstack-rally to test my openstack wallaby which was deployed using tripleo and i am facing an issue when adding the existing deployment https://bugs.launchpad.net/rally/+bug/1977797
    Anisha V
    @AnishaVardh
    Hi, i am trying to run some benchmark tests using openstack rally, i am facing few issue when i am running this code https://github.com/boris-42/rally/blob/master/samples/tasks/scenarios/neutron/create-and-delete-ports.json
    the error is "Subtask Neutron.Networks.create-and-delete-ports has wrong configuration and it doesnt pass required validation"
    Anisha V
    @AnishaVardh
    @andreykurilin:matrix.org can you please help me out!