Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 02 2016 16:31
    @chamons banned @IfErrThrowBrick_twitter
Sören Nils Kuklau
@chucker
that points to a sketchy tool that you can open, then you get a Tools menu, and there you can download it
i'm… not really sure why Apple makes that so hard
gonzobrains
@gonzobrains
Right?
Thanks for that. When you say "sketchy" does that mean I need to worry about malware?
Sören Nils Kuklau
@chucker
i'm not sure :D
gonzobrains
@gonzobrains
heh.
Sören Nils Kuklau
@chucker
you can also try https://github.com/munki/macadmin-scripts and run that with --help. maybe it lets you just download the package without running it. if so, I think you can just drag that into VMware when creating a VM
i can't really test this stuff because my machine does run Catalina
gonzobrains
@gonzobrains
I have a spare Mac Pro I can try it with. I think I already updated the EFI on it to run Catalina natively but the video card wigs out. It would be nice to just run Catalina in a VM then, but that machine is running 10.7.5, so maybe that wouldn't work.
I should just buy a new Mac. lol.
Sören Nils Kuklau
@chucker
oof, yeah, that's quite a jump
gonzobrains
@gonzobrains
My laptop is running High Sierra though, so I can try it there first but need to think about running those third-party apps.
Sören Nils Kuklau
@chucker
the Python script should be fine; i'm not really sure if it allows downloading, though.
gonzobrains
@gonzobrains
Yeah, I tried the direct links and they still send me to the App Store which prevents downloading.
I'll look at the other solutions though.
Sören Nils Kuklau
@chucker
i'm kind of surprised nobody has run something like Fiddler to figure out the URL. assuming it's not some kind of stream, that is.
gonzobrains
@gonzobrains
right.
Like maybe spoof being the App Store app and report a different OS version to the server?
that's a 7 Gig file that seems to be the one softwareupdate fetches
gonzobrains
@gonzobrains
So you ran Fiddler? Nice.
Sören Nils Kuklau
@chucker
Wireshark, in this case :)
gonzobrains
@gonzobrains
Righteous!

VMware fusion doesn't like the mounted DMG I extracted from it. I'm looking into this as a viable solution:

https://apple.stackexchange.com/q/199892/78541

Alex Soto
@dalexsoto
The current stable version is able to build against Xcode 11.5 without issues but if you want our next build candidates you can find them here xamarin/xamarin-macios#8475
gonzobrains
@gonzobrains
Do they include instructions on how to manually install them? Usually, I just let Visual Studio do all this automatically.
Alex Soto
@dalexsoto
If you are on windows not yet but if you are on macOS you just download them and double click on them
that said current released stable is capable of building against Xcode 11.5 just fine
gonzobrains
@gonzobrains
Under what circumstances should I download these ahead of "official" releases? Will they cure any toolchain failures? The biggest problem I have right now is storyboards not opening in VS Mac.
DesignerRemoteException
Alex Soto
@dalexsoto
This is the Xamarin.iOS SDK development channel if you are having issues with Visual Studio I would suggest going to https://gitter.im/xamarin/VisualStudio
YMMV on going ahead of official releases, we try to keep all of our release branches in the best shape possible so you can go and pick the latest HEAD of a release branch and try yourself, if you want to go back to previous "official" build you can do that using the Visual Studio updater
gonzobrains
@gonzobrains
I'm having problems with VS Mac 2019 preview complaining that it can't open storyboards because I need xCode 8 or higher installed. I have always had 11.4 installed so I don't know why this is happening. I have the latest Preview version installed. Furthermore, I have the latest Preview version installed on my Windows machine as well, but whenever it tries to connect to the Mac is says I need to downgrade Xamarin.iOS from .20 to .15. Why is this happening?
Sebastien Pouliot
@spouliot
make sure your VSMac preferences points to your Xcode 11.4 directory
also open Xcode 11.4, sometimes the installation is not 100% complete (additional downloads) until it’s opened
Sören Nils Kuklau
@chucker
you can also try running xcode-select -p to see if that points to the right Xcode path
Tomasz Cielecki
@Cheesebaron
Can I somehow disable signing of an IPA when building a Xamarin.iOS project?
I am running a build just to get some results to be reported to SonarQube
I don't care about the signing step
Can't seem to find the Property that allows skipping this
Maybe I could just set IsMacEnabled to false?
Rolf Bjarne Kvinge
@rolfbjarne
you could just override the signing target
<Target Name="CoreCodesign" />
Jeffrey Stedfast
@jstedfast
morning guys
I got an interesting bug report filed against MimeKit this morning (well, 2 actually) but the first one is: jstedfast/MimeKit#578
this person is getting Could not load the file 'I18N, Version=2.0.5.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'. (which is a FIleNotFoundException) and sometimes a NotSupportedException for the charset
I think he probably just needs to check the checkboxes in his Project Options to enable I18N support for all regions
what's odd about this is that where this fails, MimeKit has try/catches around the ENcoding.GetENcoding() calls
which I would have thought would have caught these exceptions
Jeffrey Stedfast
@jstedfast
One question I have regarding this bug is: is there any way for MimeKit to "force" a Xamarin project to include all I18N regions by default in the build?