Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 02 2016 16:31
    @chamons banned @IfErrThrowBrick_twitter
Alex Soto
@dalexsoto
YMMV on going ahead of official releases, we try to keep all of our release branches in the best shape possible so you can go and pick the latest HEAD of a release branch and try yourself, if you want to go back to previous "official" build you can do that using the Visual Studio updater
gonzobrains
@gonzobrains
I'm having problems with VS Mac 2019 preview complaining that it can't open storyboards because I need xCode 8 or higher installed. I have always had 11.4 installed so I don't know why this is happening. I have the latest Preview version installed. Furthermore, I have the latest Preview version installed on my Windows machine as well, but whenever it tries to connect to the Mac is says I need to downgrade Xamarin.iOS from .20 to .15. Why is this happening?
Sebastien Pouliot
@spouliot
make sure your VSMac preferences points to your Xcode 11.4 directory
also open Xcode 11.4, sometimes the installation is not 100% complete (additional downloads) until it’s opened
Sören Nils Kuklau
@chucker
you can also try running xcode-select -p to see if that points to the right Xcode path
Tomasz Cielecki
@Cheesebaron
Can I somehow disable signing of an IPA when building a Xamarin.iOS project?
I am running a build just to get some results to be reported to SonarQube
I don't care about the signing step
Can't seem to find the Property that allows skipping this
Maybe I could just set IsMacEnabled to false?
Rolf Bjarne Kvinge
@rolfbjarne
you could just override the signing target
<Target Name="CoreCodesign" />
Jeffrey Stedfast
@jstedfast
morning guys
I got an interesting bug report filed against MimeKit this morning (well, 2 actually) but the first one is: jstedfast/MimeKit#578
this person is getting Could not load the file 'I18N, Version=2.0.5.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'. (which is a FIleNotFoundException) and sometimes a NotSupportedException for the charset
I think he probably just needs to check the checkboxes in his Project Options to enable I18N support for all regions
what's odd about this is that where this fails, MimeKit has try/catches around the ENcoding.GetENcoding() calls
which I would have thought would have caught these exceptions
Jeffrey Stedfast
@jstedfast
One question I have regarding this bug is: is there any way for MimeKit to "force" a Xamarin project to include all I18N regions by default in the build?
Rolf Bjarne Kvinge
@rolfbjarne
he doesn't have a full stack trace?
Jeffrey Stedfast
@jstedfast
he doesn't provide one, no
Rolf Bjarne Kvinge
@rolfbjarne
that would show exactly where the exception is thrown, and could provide very valuable info
Jeffrey Stedfast
@jstedfast
you mean as far as where in System.Text.Encoding?
yea
dusting off my old macbook to see f I can repro
Jeffrey Stedfast
@jstedfast
this'll be a little while because apparently I need a newer xcode :p
Romil
@theromie
Xcode 11.3.1 is currently selected in Preferences and is incompatible...
How can i download VS 2019 version 8.4 with Xamrin iOS with 13.10.0.17 version. I mean link
Chris Hamons
@chamons
While we strongly recommend using the latest macios SDK we do have links to older SDK builds here - https://github.com/xamarin/xamarin-macios#downloads
.21 not .17 though, since there was a service release after 17
pm64
@pm64
Did anyone attend Build this year and receive a "Microsoft employee store discount from Microsoft Build" email? I can't tell if this is spam/fraud or not.
The email comes from the domain "microsoft.regsvc.com" and links to a web site under the domain "store.ecompanystore.com"
Jeffrey Stedfast
@jstedfast
there is a legit Microsoft store at store.ecompanystore.com
but I do not know if the email you got was spam or not
(s/spam/legit/)
Romil
@theromie
Error MT2002: Failed to resolve "AuthenticationServices.IASAuthorizationControllerDelegate"
gonzobrains
@gonzobrains
@pm64 I attended and did not get that email.
@dalexsoto Why are the Xamarin.iOS versions available to VS 2019 Windows not in sync with VS 2019 Mac? It seems that Mac is ahead, causing my Windows machine to always want to downgrade when it connects to the Mac.
Alex Soto
@dalexsoto
mmm interesting, they should be in sync, what version do you see on Windows?
gonzobrains
@gonzobrains
It depends on whether I use VS 2019 or 2019 Preview. I just installed the latest VS 2019 updates and it wants to install Xamari.iOS 13.18.2.1 whereas my Mac installed 13.20.0.22. I know it went up from .20 to .22 because I'm on Preview with the Mac, mostly because I'm working with an MS support engineer to get storyboards working again. Otherwise I wouldn't want to use Preview at all on either platform.
I just installed VS 2019 v16.6.2 a few minutes ago.
Alex Soto
@dalexsoto
Make sure you are using Visual Studio 2019 version 16.6.1/2 both should serve Xamarin.iOS 13.18.2.1 which is the latest stable release
which matches the one available in Visual Studio For Mac stable
As for 16.7 Previews it should be serving Xamarin.iOS 13.20.0.22 on both windows and mac
So if you want to keep them in sync you would need to have both windows and mac in the same preview channel
or both in stable
Alex Soto
@dalexsoto
That said IIRC if you just hit cancel in the pair dialog on windows that prompts you to install a different Xamarin.iOS it will just connect to it anyways and may or may not work fine, it is an unsupported configuration since they should always be in sync.
gonzobrains
@gonzobrains
okay, I'm reverting to stable Mac and it looks like it will install 13.18.2.1
Ideally, I would like to keep everything in sync and stable but we are in the middle of diagnosing Visual Studio bugs and have been asked to try the preview versions.
Romil
@theromie
How can i add apple account in VS 2019 as i have enabled Two step verification