These are chat archives for yasp-dota/yasp

4th
Oct 2015
Aleksandar Bukurecki
@natoshi
Oct 04 2015 02:36
@howardc93 you on?
Trying to clone this on Ubuntu 14.04
node-gyp is giving me nightmares
spend 2 hours and still no solution, it simply wont install certain modules
Error: make failed with exit code: 2
this happens for multiple modules when i run npm install
Howard Chung
@howardchung
Oct 04 2015 03:57
Project won't build yet on node v4+. c3 and selectize have dependencies on the contextify module which doesn't work yet. Use 0.12
Aleksandar Bukurecki
@natoshi
Oct 04 2015 03:59
ok
i removed those
and works fine now
thanks!
Howard Chung
@howardchung
Oct 04 2015 03:59
both are client side dependencies. if you're only interested in server side stuff that's fine
Aleksandar Bukurecki
@natoshi
Oct 04 2015 03:59
yep i noticed
Howard Chung
@howardchung
Oct 04 2015 03:59
you won't get the graphs or the nice select boxes
Aleksandar Bukurecki
@natoshi
Oct 04 2015 03:59
yep
tho this worked on windows :D
just no on ubuntu
Howard Chung
@howardchung
Oct 04 2015 04:00
probably you had node 0.12 on windows
Aleksandar Bukurecki
@natoshi
Oct 04 2015 04:00
nope was 4.1
let me double check
Howard Chung
@howardchung
Oct 04 2015 04:00
probably the node-gyp works differently
i don't know exactly, never used it on windows
Aleksandar Bukurecki
@natoshi
Oct 04 2015 04:00
yep 4.1.1 with 0.13 on node gyp
ye who knows
anyways i ll keep those 2 turned off for now
thanks for your work btw!