Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 00:50
    GitLab | Luis Fernandes pushed 1 commits to TvhClient-TV
  • Jan 12 20:00
    GitLab | Luis Fernandes pushed 1 commits to TvhClient
  • Dec 09 2019 00:58
    GitLab | Luis Fernandes pushed 2 commits to TvhClient
  • Dec 09 2019 00:58
    GitLab | Luis Fernandes pushed 3 commits to TvhClient-TV
  • Jul 19 2019 22:13
    GitLab | Luis Fernandes pushed 2 commits to TvhClient
  • Jul 07 2019 23:09
    GitLab | Luis Fernandes pushed 2 commits to TvhClient
  • Jul 07 2019 12:58
    GitLab | Luis Fernandes pushed 3 commits to TvhClient
  • Jul 06 2019 18:11
    GitLab | Luis Fernandes pushed 1 commits to TvhClient
  • Jul 06 2019 17:22
    GitLab | Luis Fernandes pushed 1 commits to TvhClient
  • Jul 06 2019 17:19
    GitLab | Luis Fernandes pushed 1 commits to TvhClient
  • Jul 06 2019 15:49
    GitLab | Luis Fernandes pushed 1 commits to TvhClient
  • Jul 01 2019 21:33
    GitLab | Luis Fernandes pushed 3 commits to TvhClient-TV
  • Jul 01 2019 00:17
    GitLab | Luis Fernandes pushed 1 commits to TvhClient
  • Jul 01 2019 00:17
    GitLab | Luis Fernandes pushed 5 commits to TvhClient
  • Jun 21 2019 23:58
    GitLab | Luis Fernandes pushed to TvhClient
  • Jun 21 2019 23:58
    GitLab | Luis Fernandes pushed 1 commits to TvhClient
  • Feb 20 2019 22:06
    GitLab | Luis Fernandes pushed 2 commits to TvhClient-TV
  • Feb 12 2019 11:59
    GitLab | Luis Fernandes pushed 2 commits to TvhClient-TV
  • Jan 22 2019 15:12
  • Jan 04 2019 00:58
    hawflakes starred zipleen/tvheadend-ios-lib
Luis Fernandes
@zipleen
The problem with that one is attempting to restart the stream. But that's a good idea, thanks
The "above" menu is the one having huge issues with tvOS 13
gabb1
@gabb1
or long press on channel will ask you which profile you want
Luis Fernandes
@zipleen
No one will find that one. Did you know that you could have clicked on the "play" button in the epg to start playing a channel? Me neither, that's why I changed the default to start playing right away lol
Although long pressing could be a possibility for added options on both menus
mickeyjee
@mickeyjee
@zipleen Quick question. I am using TVH with 3 users (1 internal, 2 external). With the external users (using TVHC on tvOS) i don't see their username when they start the stream. The credentials are accepted.
Luis Fernandes
@zipleen
See where the username? In status screen?
mickeyjee
@mickeyjee
Normally on the TVHClient and TVHeadend server i can see which channels are being watched and with which username. But i can only see the channel being watched but it is not showing the username on client or server.
Luis Fernandes
@zipleen
the only reason that would be like that is if the person is using the token to playback - therefore there's no user, just a token
this could happen if the user is non admin .. I don't remember the correct scenario by heart
if you have the server setup as only accepting Digest authentication, vlc can't handle that
so the only fallback is to go the &ticket route, bypassing authentication
if you change the server to be basic+digest, you should be able to see the users again because tvhclient won't fallback to the ticket route
however, the ticket route will be fallback if the user is non-admin, because there's no way for tvhclient to detect if your server has basic auth configured
(only an admin can read that property)
Luis Fernandes
@zipleen
so if you select that the user is non-admin, it will always fallback to thinking the server is configured with digest (it's the new default only) and thus ticket route
Luis Fernandes
@zipleen
Screenshot 2020-01-24 at 11.21.20.png
make sure you have this option like that in Configuration -> General -> Base
then set the user to "is admin" in tvhclient.
then see if the users pop up or not
mickeyjee
@mickeyjee
Thank you for the information. I don't have that option. I do have an option "Use HTTP digest authentication:" which is turned on.
I tried to test something to with the "user" *
Is it possible it is using that "user"? I put that user below all usernames. Or do i maybe have to disable it and then reconnect on each client?
Luis Fernandes
@zipleen
user * means no user
if you have a * user, then it's irrelevant to have users because someone can simply go into the server lol
jooost
@jooost
Hi, any reason the search does not work on the iOS client. I have tried through tvheadend web interface and Can find episodes ok but fails on iPhone. Any thoughts ? Many thanks.
Luis Fernandes
@zipleen
search works on the ios client. I use it all the time
jooost
@jooost
Great. Any suggestions as to what might be wrong with my config.
Luis Fernandes
@zipleen
are you searching for extended characters? or just using normal a-z characters without modifiers ?
jooost
@jooost
I was just searching for the word “college”. If I use Charles proxy on the phone I can see http request/response being successful from server. If I search on the
Now tab it works but if I search on channels tab it does not.
Luis Fernandes
@zipleen
channels tab is to… search channels :P
and not EPG inside channels lol
if you want to search on a specific channel or tag, go to the now tag, hit the down arrow or the magnifying glass, select the tag or channel, and then search within that specific tag or channel
the search in the channels tab is just for searching channel names. so you can go to "all channels" and search for whatever channel you want
jooost
@jooost
Thank you very much. I feel a bit stupid. Sorry for wasting your time.
Luis Fernandes
@zipleen
sorry for not making that search box only for channel names more obvious :P
mickeyjee
@mickeyjee

@zipleen I have a few questions about the tvOS version. Hope you can clarify;

1: VLC network buffer. When it's set on 999 or 2000 or 3333. Every livestream channels starts as quick as possible so it looks like it doesn't use this buffer?
2: Default settings de-interlace mode [yes/no]. Which settings does it use when setting it to yes? I'm using PASS so on the server-side there is nothing setup. I've set some de-interlace settings in the tvOS client.
3: Sometimes a live stream (TS-stream) just freezes the stream on the tvOS client and does not continue. I'm using PASS and restart on error is Enabled. I think the connection to the live-stream maybe has some corrupted bits? Or maybe the client loses connection to the server? When stopping the channel and directly re-open it, it just works and continue the live stream. Are you familiar with this behaviour? That's why i was looking at the VLC network buffer :-)

Luis Fernandes
@zipleen
Network buffer is used, try 9999 or 20000 and you'll see the difference :p
De interlace yes means deinterlace setting will be forced to yes. This has somewhat weird effects on non interlaced content. Leave it auto and VLC will auto detect if the stream is interlaced or not
I'm not familiar with the stream stopping completely . I'm familiar with stream errors making the image go bananas. Increasing buffer does nothing because VLC just goes insane with the wrong bits. Restarting the channel by force is the only way to recover.
An usual occurrence is that after some errors on the stream the sound and video just desync, or you start "running at 10fps" - although if you give it a minute it sometimes recovers gracefully
I've also seen this type of situation occur in kodi, although I haven't used kodi to watch live tv for a long time
mickeyjee
@mickeyjee

Ah thank you. I thought 3333 was the maximum. Now i can see the difference.

I have de-interlace set to auto on the client. But at the server config (just below the VLC buffer) there is an option "Default setting de-interlace: yes/no". I set it now to No so i think it looks at the client settings now?

Okay, yeah sometimes i see the stream also go bananas but sometimes recover also. And sometimes i have a stream completely frozen but after re-starting it just plays again. Thanks for clarifying. Maybe with a future update of the VLCKit it will get solved

mickeyjee
@mickeyjee
Just froze again. No errors found on server side. The bandwith just drops to nothing.
Luis Fernandes
@zipleen
Yeah that's all VLC unfortunately :/ is your connection local?
But on the other hand, I was watching tv coming from a dvb-T source (no encryption), remotely, through OpenVPN, I fell asleep and at 8am the stream was still going so it was there all night lol
Is your connection through lan on something that doesn't require decryption?
(Deinterlace on the tvheadend means transcoding on the server - that's super heavy on the server, don't transcode unless you know what you're doing)
mickeyjee
@mickeyjee

Yes, i'm local. TVHeadend server on Synology NAS with IPTV. AppleTV with local ethernet.
Ah, i though de-interlacing was done on the client because i was using pass :-)

I also have an account remotely which also shows sometimes the same behaviour. I know transcoding. Had the same issue with Plex. Transcoding on Synology is a no-go.

hornerr
@hornerr
Hi! I have a question about the tvOS version. When I'm trying to watch any channel the stream looks like its "low fps". I'm using Apple TV 4K and tvheadend is installed on RasPi 3. The stream looks ok on the free bowerbird app on the apple tv. Any idea how to fix this? Thanks!
hornerr
@hornerr
Never mind. I bought the full version of the app and everything seems smooth now. :P
Luis Fernandes
@zipleen
there shouldn't be any difference between the in app purchase and without it
it's still VLCKit with the same parameters...